This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 859265 - JSVC installation on Tomcat 7 (Refer: JBPAPP-9814)
JSVC installation on Tomcat 7 (Refer: JBPAPP-9814)
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-HTTP-Connectors-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
: 859266 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 20:07 EDT by Misha H. Ali
Modified: 2012-11-08 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 17:10:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2012-09-20 20:07:55 EDT
As in $TITLE.

Need an SME for this information.
Comment 1 Misha H. Ali 2012-09-20 20:08:57 EDT
Adding Jean-Frederic to confirm if he is SME for this bug. If not, could you please cc the relevant person, Jean-Frederic?
Comment 2 Jean-frederic Clere 2012-09-21 02:38:39 EDT
I suggested something like:
> MHA: http://svn.apache.org/viewvc/commons/proper/daemon/trunk/src/samples/Tomcat7.sh?revision=1132665&view=markup&pathrev=1202069

you have to describe the 5 parameters:
 --java-home: The JAVA_HOME. (default: guessed for the PATH variable).
 --catalina-home: The directory where tomcat is installed. Environment variable: CATALINA_HOME (default: guessed from the script location).
 --catalina-base: in case of multiple servers using the same installation the directory containing the specific configuration and setup. Environment variable: CATALINA_BASE (default: catalina-home).
--catalina-pid: file to store the pid of the running tomcat. (default: $CATALINA_BASE/logs/catalina-daemon.pid
--tomcat-user: User to use to run tomcat7. (Default: tomcat).
Comment 3 Misha H. Ali 2012-09-23 19:39:48 EDT
For some introductory matter for JSVC, referring to the following JIRA:

https://issues.jboss.org/browse/JBPAPP-9814
Comment 4 Misha H. Ali 2012-09-24 01:03:27 EDT
Added for this bug:

1. Information about what Jsvc is.
2. How to install Jsvc with Tomcat 7.
3 How to run Jsvc with (any) Tomcat. -- Need ACK from Jean-Frederic if older versions of Tomcat have different instructions.

Did not add:

1. Instructions to move daemon.sh file (see JIRA) as this problem is now resolved.

This bug will be set to ON_QA with a link once the results appear on the stage.
Comment 6 Jean-frederic Clere 2012-09-24 04:19:39 EDT
For 12.2 the parameters are the parameters of the tomcat7/bin/daemon.sh utility not the parameters of jsvc itself.
jsvc is the same of tomcat6 and tomcat7 but the start scripts are different.
The input I gave you is for daemon.sh script not for jsvc itself,

In 12.3: 
CLASSPATH is not \
It is:
$JAVA_HOME/lib/tools.jar:$CATALINA_HOME/bin/commons-daemon.jar:$CATALINA_HOME/bin/bootstrap.jar

Note I assumed we used a script in tomcat6 but it is not in delivery I need to check how to fix that part of the doc accordingly.
Comment 7 Jean-frederic Clere 2012-09-25 02:19:59 EDT
So for 12.2. Install Jsvc with Tomcat 7 I suggest:
Which Tomcat7 jsvc is control via a wrapper script daemon.sh the parameter of the script are the following.

Keep the table 12.1. Jsvc Installation Parameters for Tomcat 7

After the table add:

If you want to modify the script or write your owen see next chap.
Comment 8 Jean-frederic Clere 2012-09-25 03:01:57 EDT
the 12.4. Run Tomcat with Jsvc in fact that is only for Tomcat7 (we don't have the script for Tomcat6).
Comment 9 Misha H. Ali 2012-10-02 04:11:34 EDT
These problems should be fixed in the next build. This bug will be set to ON_QA when the results appear on the stage.
Comment 11 Libor Fuka 2012-10-11 06:57:18 EDT
check chapter 11.3 table 11.2

1. Java 2 SDK version 1.5 -> JDK 1.6 or later
2. The temporart - The temporary

after this fix its ok.
Comment 12 Jean-frederic Clere 2012-10-11 08:14:46 EDT
11.2.2. Configure Jsvc with Tomcat 7

I spotted the following:

"if multiple values of --java-home are configured, this parameter determines the Java home directory for the script."

That is wrong see comment #2
Comment 13 Misha H. Ali 2012-10-12 02:01:48 EDT
For comment#11:

1. Fixed, now reads JDK 1.6 or later.
2. Typo fixed, now reads temporary.

For comment#12:

1. Fixed using comment#2 as a reference.
Comment 15 Misha H. Ali 2012-10-12 23:22:42 EDT
*** Bug 859266 has been marked as a duplicate of this bug. ***
Comment 16 Jean-frederic Clere 2012-10-15 02:17:00 EDT
-cp $JAVA_HOME/lib/tools.jar:CATALINA_HOME/bin/commons-daemon.jar:$CATALINA_HOME/bin/bootstrap.jar should be:
-cp $JAVA_HOME/lib/tools.jar:$CATALINA_HOME/bin/commons-daemon.jar:$CATALINA_HOME/bin/bootstrap.jar

$ missing.
Comment 17 Jean-frederic Clere 2012-10-15 02:19:10 EDT
Oops my comment should go in 859263 I think.
Comment 18 Misha H. Ali 2012-11-08 17:10:41 EST
This bug is set to CLOSED CURRENT RELEASE to indicate that this fix is now released and available at access.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.