Bug 859424 - Log messages for start of crawl, end of crawl and number of files self-healed has to be reported in glustershd.log file
Log messages for start of crawl, end of crawl and number of files self-healed...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate (Show other bugs)
2.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: vsomyaju
spandura
: FutureFeature
: 868107 (view as bug list)
Depends On: 868107
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 10:09 EDT by spandura
Modified: 2016-09-17 08:11 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 868107 949400 (view as bug list)
Environment:
Last Closed: 2015-02-25 00:59:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glustershd.log file. (4.02 MB, text/x-log)
2012-09-21 10:09 EDT, spandura
no flags Details

  None (edit)
Description spandura 2012-09-21 10:09:11 EDT
Created attachment 615457 [details]
glustershd.log file.

Description of problem:
------------------------

In a replicate volume , When there are files to be self-heal when a offline brick comes online,  the glustershd.log file doesn't report any log messages on start of crawl and  end of crawl. 

Currently Available options for checking files to be self-healed:-
----------------------------------------------------------------
Number of files that has to be self-healed can be obtained from the gluster cli command : "gluster volume heal <vol_name> info" 

Number of files that got self-healed (Only 1023 entries reported)can be obtained from the gluster cli command : "gluster volume heal <vol_name> info healed" 

To check pending self-heals other option is to keep monitoring ".glusterfs/indices/xattrop" directory of the source brick. 


Expected Output:-
------------------
We would like to see the start time of the crawl and End time of the crawl in the glustershd.log file. It would be helpful if number of files that got self-healed (only the count) is also reported in the glustershd.log file. 

Version-Release number of selected component (if applicable):
------------------------------------------------------------
glusterfs 3.3.0rhs built on Sep 10 2012 00:49:11

(glusterfs-3.3.0rhs-28.el6rhs.x86_64)


Steps to Reproduce:
--------------------
1.Create a replicate volume (1x2). Start the volume
2.Bring down brick2
3.Create a fuse mount. Create 10k of files and directories from the mount point.
4.Bring back brick2 online
5.Check glustershd.log file for self-heal information. 

Actual Result:-
---------------
No messages related to start of crawl, end of crawl is reported.
Comment 2 Sudhir D 2012-10-19 01:06:34 EDT
In the bz scrum, it was agreed to log the start and end of crawl immediately and this bug will be kept open for furture to log the number of files that got self healed.
Comment 3 Vijay Bellur 2012-12-17 00:58:50 EST
Let us record the last 50 start and end crawl timestamps per brick and provide a new command to dump this information out.
Comment 4 vsomyaju 2013-03-12 06:15:46 EDT
*** Bug 868107 has been marked as a duplicate of this bug. ***
Comment 5 krishnan parthasarathi 2013-09-23 02:23:18 EDT
vsomyaju,

Could you add a comment with the review url for the patch(es) which fix this issue? I am moving the bug state to ASSIGNED. The necessary criteria for a bug to be in POST state is that patches that fix the bug needs to be merged into upstream master branch. Once you have added the review url and a summary of the root cause, you could move the bug to POST state.
Comment 6 Pranith Kumar K 2014-02-18 03:47:08 EST
gluster volume heal <volname> statistics is introduced to address this.
Comment 7 vsomyaju 2014-02-18 04:01:44 EST
http://review.gluster.org/#/c/4790/
Comment 8 Nagaprasad Sathyanarayana 2014-05-19 06:56:16 EDT
Setting flags required to add BZs to RHS 3.0 Errata

Note You need to log in before you can comment on or make changes to this bug.