Bug 859536 - nm-connection-editor throws SIGTRAP
nm-connection-editor throws SIGTRAP
Status: CLOSED DUPLICATE of bug 852792
Product: Fedora
Classification: Fedora
Component: network-manager-applet (Show other bugs)
18
ppc64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 15:14 EDT by Mark Hamzy
Modified: 2012-09-24 03:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-24 03:20:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace log of nm-connection-editor #1 (476.21 KB, application/octet-stream)
2012-09-21 15:15 EDT, Mark Hamzy
no flags Details
strace log of nm-connection-editor #2 (12.27 KB, application/octet-stream)
2012-09-21 15:15 EDT, Mark Hamzy
no flags Details
strace log of nm-connection-editor #3 (1.38 KB, application/octet-stream)
2012-09-21 15:16 EDT, Mark Hamzy
no flags Details
strace log of nm-connection-editor #4 (2.61 KB, application/octet-stream)
2012-09-21 15:16 EDT, Mark Hamzy
no flags Details

  None (edit)
Description Mark Hamzy 2012-09-21 15:14:53 EDT
During installation, I open up another bash prompt and run the following command:

[anaconda root@sharpie ~]# DISPLAY=:1 nm-connection-editor --edit 44d23bba-f357-4296-8747-4a59d54e5328
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

(nm-connection-editor:1509): GLib-GIO-ERROR **: Settings schema 'org.gnome.nm-applet.eap' is not installed

Trace/breakpoint trap




However just:

[anaconda root@sharpie ~]# DISPLAY=:1 nm-connection-editor

works.
Comment 1 Mark Hamzy 2012-09-21 15:15:36 EDT
Created attachment 615574 [details]
strace log of nm-connection-editor #1
Comment 2 Mark Hamzy 2012-09-21 15:15:55 EDT
Created attachment 615576 [details]
strace log of nm-connection-editor #2
Comment 3 Mark Hamzy 2012-09-21 15:16:12 EDT
Created attachment 615577 [details]
strace log of nm-connection-editor #3
Comment 4 Mark Hamzy 2012-09-21 15:16:30 EDT
Created attachment 615578 [details]
strace log of nm-connection-editor #4
Comment 5 Mark Hamzy 2012-09-21 16:21:07 EDT
[anaconda root@sharpie tmp]# DISPLAY=:1 gdb
(gdb) file /bin/nm-connection-editor
Reading symbols from /usr/bin/nm-connection-editor...Missing separate debuginfo for /usr/bin/nm-connection-editor
Try: yum --disablerepo='*' --enablerepo='*debug*' install /usr/lib/debug/.build-id/26/606733391ab1302a1698f405bd186b0c8e2aa6.debug
Reading symbols from /usr/bin/nm-connection-editor...(no debugging symbols found)...done.
(no debugging symbols found)...done.
(gdb) run --edit 44d23bba-f357-4296-8747-4a59d54e5328
...
Program received signal SIGTRAP, Trace/breakpoint trap.
0x00000fffb6ba77c4 in .raise () from /lib64/libpthread.so.0
(gdb) bt
#0  0x00000fffb6ba77c4 in .raise () from /lib64/libpthread.so.0
#1  0x00000fffb6d527e8 in g_logv (log_domain=0xfffb7345420 "GLib-GIO",
    log_level=G_LOG_LEVEL_ERROR,
    format=0xfffb7360488 "Settings schema '%s' is not installed\n",
    args1=0xfffffffd668 "") at gmessages.c:758
#2  0x00000fffb6d529c8 in g_log (
    log_domain=<error reading variable: value has been optimized out>,
    log_level=<error reading variable: value has been optimized out>,
    format=<error reading variable: value has been optimized out>)
    at gmessages.c:792
#3  0x00000fffb72dcf44 in g_settings_set_property (object=<optimized out>,
    prop_id=<optimized out>, value=<optimized out>, pspec=<optimized out>)
    at gsettings.c:492
#4  0x00000fffb6ef3590 in object_set_property (nqueue=<optimized out>,
    value=0x10475ce8, pspec=0x103bedc0, object=<optimized out>)
    at gobject.c:1357
#5  g_object_constructor (type=<optimized out>,
    n_construct_properties=<optimized out>, construct_params=<optimized out>)
    at gobject.c:1868
#6  0x00000fffb6ef5658 in g_object_newv (object_type=273268592,
    n_parameters=<optimized out>, parameters=<optimized out>) at gobject.c:1718
#7  0x00000fffb6ef5fa4 in g_object_new_valist (object_type=273268592,
    first_property_name=<optimized out>, var_args=<optimized out>)
Comment 6 Jirka Klimes 2012-09-24 03:20:28 EDT
Mark, what nm-connection-editor (network-manager-applet) do you have?

The bug is fixed in latest package that has landed in stable:
https://admin.fedoraproject.org/updates/FEDORA-2012-13866/network-manager-applet-0.9.7.0-3.git20120820.fc18

*** This bug has been marked as a duplicate of bug 852792 ***

Note You need to log in before you can comment on or make changes to this bug.