Bug 852792 - [Configure] button in network spoke doesn't work (nm-c-e fails to run)
[Configure] button in network spoke doesn't work (nm-c-e fails to run)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: network-manager-applet (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 859536 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-08-29 11:39 EDT by Radek Vykydal
Modified: 2012-10-19 12:30 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-23 23:20:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log messages (12.37 KB, image/png)
2012-08-29 11:39 EDT, Radek Vykydal
no flags Details

  None (edit)
Description Radek Vykydal 2012-08-29 11:39:37 EDT
Created attachment 607937 [details]
log messages

Description of problem:

Configure button in network spoke doesn't work, nm-c-e fails to run with:
(nm-connection-editor:1035): GLib-GIO-ERROR **: Settings schema 'org.gnome.nm-applet.eap' is not installed

Version-Release number of selected component (if applicable):

anaconda 18.99 - Fedora-20120829-x86_64-7074c9c-netinst.iso,
network-manager-applet-0.9.5.96-2.fc18 I think

This would most probably concern F18 Alpha too.

Additional info:

We (or nm-connection-editor) seem to miss gsettings dependency. See the last bullet of this changelog:

* Fri Jul 13 2012 Jiří Klimeš <jklimes@redhat.com> - 0.9.5.95-1.git20120713
 - update to 0.9.5.95 (0.9.6-rc1) snapshot
 - editor: fixed UI mnemonics
 - editor: fix defaults for PPP echo values
 - applet: various crash and stability fixes
 - applet: show IPv6 addressing page for VPN plugins that support it
 - applet: port to GSettings and split out 0.8 -> 0.9 migration code into standalone tool
Comment 1 Radek Vykydal 2012-08-29 11:41:10 EDT
Jirka, can you comment?
Comment 2 Jirka Klimes 2012-08-30 06:45:03 EDT
The settings schema was not found. It could be caused by not compiling the installed schema file with 'glib-compile-schemas'. The command is run in rpm scriplets, however it was missing in %post. I've just added it to the %post section and made a new network-manager-applet build.

In case, the scriplets are not run in your images, you should ensure that

glib-compile-schemas /usr/share/glib-2.0/schemas &>/dev/null

is executed somewhere.
Comment 3 Chris Lumens 2012-08-30 10:15:09 EDT
%post scripts should be run during image creation, so if I understand comment #2 correctly, this should be fixed with the next build of network-manager-applet.
Comment 4 Fedora Update System 2012-09-04 06:38:55 EDT
network-manager-applet-0.9.7.0-2.git20120820.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/network-manager-applet-0.9.7.0-2.git20120820.fc18
Comment 5 Radek Vykydal 2012-09-04 09:42:12 EDT
Hmm, the schemas on anaconda image (with older network-manager-applet-0.9.5.96-2.fc18) seem to be actually compiled (gschemas.compiled is there), but the image is missing .xml source schema org.gnome.nm-applet.gschema.xml which is part of network-manager-applet package making it dependency of nm-connection-editor missing in spec file - so it doesn't get pulled as dependency when building installer image.

It seems to me that either the missing schema should not be fatal for nm-c-e or nm-connection-editor should require network-manager-applet.
Comment 6 Fedora Update System 2012-09-04 12:54:15 EDT
Package network-manager-applet-0.9.7.0-2.git20120820.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing network-manager-applet-0.9.7.0-2.git20120820.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13293/network-manager-applet-0.9.7.0-2.git20120820.fc18
then log in and leave karma (feedback).
Comment 7 Radek Vykydal 2012-09-06 06:17:18 EDT
Moving to assigned based on comment #5 so that we don't miss this for F18 Alpha eventually.

Still failing with F18 Alpha TC6. I am not sure the new network-manager-applet packages made it to the image, nevertheless I still believe the real problem is missing .xml from network-manager-applet package (so dependency problem). Didn't the package used to compile schemas in %posttrans anyway?
If I am correct, it is possible to work the missing dependency around by adding network-manager-applet to lorax template and anaconda.spec explicitly, but it should be fixed here in NM.
Comment 8 Radek Vykydal 2012-09-07 05:02:31 EDT
Proposing as NTH, similar issue in bug 854586 was NTH accepted.
Comment 9 Jóhann B. Guðmundsson 2012-09-07 15:37:46 EDT
+1 NTH
Comment 10 Tom Lane 2012-09-07 18:14:36 EDT
What I'm seeing with TC6 is that the "Configure..." button on the network configuration page just does nothing at all.  Is that this same bug or something different?
Comment 11 Radek Vykydal 2012-09-10 03:34:14 EDT
(In reply to comment #10)
> What I'm seeing with TC6 is that the "Configure..." button on the network
> configuration page just does nothing at all.  Is that this same bug or
> something different?

It is the same bug. To confirm you can switch to tty1 where you should see the error message from Description:

(nm-connection-editor:1035): GLib-GIO-ERROR **: Settings schema 'org.gnome.nm-applet.eap' is not installed
Comment 12 Tom Lane 2012-09-10 11:39:37 EDT
(In reply to comment #11)
> It is the same bug. To confirm you can switch to tty1 where you should see
> the error message from Description:
> 
> (nm-connection-editor:1035): GLib-GIO-ERROR **: Settings schema
> 'org.gnome.nm-applet.eap' is not installed

Hm, well, no, that's not what I'm seeing in TC6.  I see

** (anaconda:655): WARNING **: Device activation failed: (1) Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/0' failed in libnm-glib.

as well as three occurrences of

** (anaconda:655): WARNING **: async_got_type: could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/0: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

and then the same for .../ActiveConnection/1, and while I was typing this another three popped up for .../ActiveConnection/2.

I'm not sure why this isn't considered a blocker bug.  TC6 is completely useless if I can't get networking started.
Comment 13 Adam Williamson 2012-09-10 13:08:25 EDT
Discussed at 2012-09-10 QA meeting, acting as an NTH review meeting. There appears to be quite a lot of confusion between possibly different bugs here, and no clear indication as to whether the update actually fixes anything. I will try and do some local testing of this, and we will revisit it on Wednesday.
Comment 14 Radek Vykydal 2012-09-11 03:27:17 EDT
> (In reply to comment #11)

> 
> Hm, well, no, that's not what I'm seeing in TC6. 

Ah, so it is a different issue. In this BZ the problem is not starting network devices but its configuration using nm-c-e ([Configure...] button).

I am not able to reproduce your issue with TC6.
Please file a new bug with logs attached (/tmp/syslog, /tmp/anaconda.log, /tmp/ifcfg.log). If you use any special boot options or kickstart, that would be also very helpful to mention.
Comment 15 Jaroslav Reznik 2012-09-11 08:26:39 EDT
I can see it on RC2, [Configure] button does nothing on DVD. It's not a problem on Live (see the second bug) but on DVD this means it's not possible to setup network correctly and thus I think it breaks "The installer must be able to use at least one of the HTTP or FTP remote package source options" as the correct network setup is impossible.
Comment 16 Adam Williamson 2012-09-12 02:11:56 EDT
OK, so I concur with Jaro, I see this in Alpha RC2 DVD. This bug is for the failure of the Configure... button in the network spoke on DVD/netinst: we have https://bugzilla.redhat.com/show_bug.cgi?id=854586 for the similar failure on Live, the symptom is the same but the cause is different.

As to whether it's a blocker, well, at least it works if your connection doesn't _need_ configuring, which is probably the most common case. So it's a conditional breakage, which means it's a judgement call...definitely +1 NTH, will vote on blocker tomorrow. Adjusting the proposal from NTH to blocker.

Alpha RC2 did not include the updated nm-connection-editor package, so we do not yet know whether that addresses the problem.
Comment 17 Adam Williamson 2012-09-12 03:03:34 EDT
I've asked tflink to build a test compose with the updated network-manager-applet package, to see if it does fix the issue.
Comment 18 Radek Vykydal 2012-09-12 04:31:29 EDT
(In reply to comment #17)
> I've asked tflink to build a test compose with the updated
> network-manager-applet package, to see if it does fix the issue.

I think it will confirm that it does not fix it (comment #5, comment #7) but let's give it a try. I talked about it also with Jirka Klimes from NM who agrees and will look at the dependency issue in NM.
Comment 19 Fedora Update System 2012-09-12 07:57:40 EDT
network-manager-applet-0.9.7.0-3.git20120820.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/network-manager-applet-0.9.7.0-3.git20120820.fc18
Comment 20 Tim Flink 2012-09-12 10:59:20 EDT
I built a test image using network-manager-applet-0.9.7.0-3.git20120820.fc18 and NetworkManager-0.9.7.0-1.git20120820.fc18 (for dependencies)

http://imagebuilder.fedoraproject.org/testimage/18/prerc3/20120912-f18alpha-prerc2.x64.boot.iso

When I try to click on the 'configure' button in the network configuration spoke, nothing happens. When I switch to VT1, I see the following:

(process:930): Gtk-WARNING **: Locale not supported by C library. Using the fallback 'C' locale.
GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications.

(nm-connection-editor:930): GLib-GIO-ERROR **: Settings schema 'org.gnome.nm-applet.eap' is not installed

I'll make sure that there weren't any problems in the boot.iso build but at the moment, it looks like something else may be going on.
Comment 21 Adam Williamson 2012-09-12 13:00:40 EDT
Discussed at 2012-09-12 blocker review meeting. We agreed this constitutes a conditional breakage of the criterion "The installer must be able to use at least one of the HTTP or FTP remote package source options" in the case of using a network connection which requires configuration (so, anything other than wired full DHCP). It was a close call, but we decided for Alpha, just wired full DHCP is good enough, so this is rejectedblocker, acceptednth.

For the record, I think the problem might be that there's no Requires(post) on glib2, so in some situations, the schema compilation in %post fails because glib2 hasn't been installed yet...I'm doing a scratch build to test that.
Comment 22 Fedora Update System 2012-09-12 15:13:29 EDT
Package network-manager-applet-0.9.7.0-3.git20120820.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing network-manager-applet-0.9.7.0-3.git20120820.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13866/network-manager-applet-0.9.7.0-3.git20120820.fc18
then log in and leave karma (feedback).
Comment 23 Adam Williamson 2012-09-12 16:09:39 EDT
So now I look at this again, I was thinking we had 2.git20120820 in RC2 for some reason, but I don't think we do. The build in bleed is network-manager-applet-0.9.5.96-2.fc18 and network-manager-applet-0.9.7.0-2.git20120820.fc18 never went stable, so I think RC2 just has 0.9.5.96-2.fc18 . So we haven't actually tested whether 2.20120820 or 3.20120820 fix this. My proposed addition of Requires(post) for 4.20120820 I think is probably *correct*, but may be unnecessary, it may turn out that just pulling 3.20120820 would fix this. tflink is doing a test build with that network-manager-applet right now, so we'll see.
Comment 24 Tim Flink 2012-09-12 16:41:53 EDT
(In reply to comment #20)
> I built a test image using network-manager-applet-0.9.7.0-3.git20120820.fc18
> and NetworkManager-0.9.7.0-1.git20120820.fc18 (for dependencies)

It turns out that I made a mistake when reporting that I actually pulled -2 into that test iso instead of the -3 I reported. Assumptions are fun ...

Anyhow, I built another iso that actually has -3 in it and the nm configuration window appears.

http://imagebuilder.fedoraproject.org/testimage/18/prerc3/20120912-f18alpha-prerc3-3.x64.boot.iso
Comment 25 Tom Lane 2012-09-12 20:39:13 EDT
(In reply to comment #14)
> I am not able to reproduce your issue with TC6.
> Please file a new bug with logs attached (/tmp/syslog, /tmp/anaconda.log,
> /tmp/ifcfg.log). If you use any special boot options or kickstart, that
> would be also very helpful to mention.

Filed at bug #856852
Comment 26 Tom Lane 2012-09-12 20:40:48 EDT
(In reply to comment #24)
> Anyhow, I built another iso that actually has -3 in it and the nm
> configuration window appears.
> http://imagebuilder.fedoraproject.org/testimage/18/prerc3/20120912-f18alpha-
> prerc3-3.x64.boot.iso

FWIW, it still doesn't work for me; I see the same behavior mentioned in comment #12.  I filed a new bug per Radek's advice.
Comment 27 Fedora Update System 2012-09-23 23:20:32 EDT
network-manager-applet-0.9.7.0-3.git20120820.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Jirka Klimes 2012-09-24 03:20:28 EDT
*** Bug 859536 has been marked as a duplicate of this bug. ***
Comment 29 Mads Kiilerich 2012-10-19 12:30:16 EDT
(In reply to comment #12)
> ** (anaconda:655): WARNING **: Device activation failed: (1) Creating object
> for path '/org/freedesktop/NetworkManager/ActiveConnection/0' failed in
> libnm-glib.
...
> ** (anaconda:655): WARNING **: async_got_type: could not read properties for
> /org/freedesktop/NetworkManager/ActiveConnection/0: Method "Get" with
> signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

I see the same on f17 - bug 868378.

Note You need to log in before you can comment on or make changes to this bug.