Bug 859734 - Moving mouse pointer over window results in garbage all over the window
Moving mouse pointer over window results in garbage all over the window
Status: CLOSED DUPLICATE of bug 827746
Product: Fedora
Classification: Fedora
Component: tuxguitar (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-23 12:13 EDT by Jonathan Underwood
Modified: 2012-09-23 16:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-23 16:25:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2012-09-23 12:13:23 EDT
Description of problem:
On F17, when I move the mouse pointer over the tuxguitar display window (where the tabs, notes etc are) it leaves a trail of blocks and garbage behind it, leaving it unreadable.

Version-Release number of selected component (if applicable):
tuxguitar-1.2-7.fc17.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Move mouse pointer over tuxguitar window
2.
3.
  
Actual results:
Junk is drawn into the window

Expected results:
No junk )

Additional info:
Comment 1 Orcan Ogetbil 2012-09-23 12:30:08 EDT
Unfortunately (or maybe fortunately), it does not happen here, so I am not sure how much help I can provide. Now a few questions:
- Do you use any proprietary video card drivers, e.g. nvidia?
- What window manager do you use? gdm, kdm, ...?
- Did you look at the console output? Is there any hints for the source of the misbehavior?
- Did you report this to the upstream developers? They might have a better idea for where the problem stems from, since it is their code.
Comment 2 Jonathan Underwood 2012-09-23 12:40:56 EDT
(In reply to comment #1)
> Unfortunately (or maybe fortunately), it does not happen here, so I am not
> sure how much help I can provide. Now a few questions:
> - Do you use any proprietary video card drivers, e.g. nvidia?

No. I am using an on-board Intel graphics chip:

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

And using the shipped xorg intel driver

> - What window manager do you use? gdm, kdm, ...?

I'm using Gnome 3 in fallback mode.

> - Did you look at the console output? Is there any hints for the source of
> the misbehavior?

Nothing appears in a console if I start tuxguitar from a command line.

> - Did you report this to the upstream developers? They might have a better
> idea for where the problem stems from, since it is their code.

Nope, I haven't.

I notice this problem appears only in "Score Edition Mode" and not in "Selection Mode"
Comment 3 Orcan Ogetbil 2012-09-23 13:04:36 EDT
I see. Let's try the following:
- Please switch to root in a command line. 
- Back up the file /usr/bin/tuxguitar, for example to /usr/bin/tuxguitar.original
- Edit the file /usr/bin/tuxguitar. Try replacing the last line via

   ${JAVA} ${VM_ARGS} -cp :${CLASSPATH} -Dtuxguitar.share.path="/usr/share/tuxguitar/" -Djava.library.path="${LD_LIBRARY_PATH}" -Dorg.eclipse.swt.internal.gtk.cairoGraphics=false ${MAINCLASS} "$1" "$2" "$arg"

Note that _all_ of the above should be in _one_ line.
- Start tuxguitar.

See if this helps. If it does help, please try to see if this change breaks any of the other previously working features.
Comment 4 Jonathan Underwood 2012-09-23 13:20:59 EDT
Ah, yes. Adding -Dorg.eclipse.swt.internal.gtk.cairoGraphics=false does indeed fix the issue. Thanks for the suggestion.

I have played around with this added in, and so far nothing appears broken - but I am new to tuxguitar and only just getting used to using it, so my testing isn't by any means exhaustive.
Comment 5 Orcan Ogetbil 2012-09-23 16:25:20 EDT
Thanks for the feedback. I am marking this bug as a duplicate to bug #827746 as that one was filed earlier. Please continue over there.

*** This bug has been marked as a duplicate of bug 827746 ***

Note You need to log in before you can comment on or make changes to this bug.