Bug 859767 - ovirt-engine-restapi: Cannot see data center quota mode using rest API
ovirt-engine-restapi: Cannot see data center quota mode using rest API
Status: CLOSED DUPLICATE of bug 893927
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michael Pasternak
Oded Ramraz
sla
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-23 18:07 EDT by Oded Ramraz
Modified: 2016-02-10 15:14 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-30 11:01:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Ramraz 2012-09-23 18:07:59 EDT
Description of problem:

Cannot see data center quota mode ( audit , disabled , enforced )using rest API
I can see the data center quotas but not the quota mode of the data center itself ( see Additional Information data center object representation )

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

<data_centers><data_center href="/api/datacenters/41846e5c-fca3-11e1-bdbf-171960d572aa" id="41846e5c-fca3-11e1-bdbf-171960d572aa"><name>Default</name><description>The default Data Center</description><link href="/api/datacenters/41846e5c-fca3-11e1-bdbf-171960d572aa/storagedomains" rel="storagedomains"/><link href="/api/datacenters/41846e5c-fca3-11e1-bdbf-171960d572aa/permissions" rel="permissions"/><link href="/api/datacenters/41846e5c-fca3-11e1-bdbf-171960d572aa/quotas" rel="quotas"/><storage_type>nfs</storage_type><storage_format>v3</storage_format><version major="3" minor="1"/><supported_versions><version major="3" minor="1"/></supported_versions><status><state>up</state></status></data_center></data_centers>
Comment 1 Oded Ramraz 2012-09-23 18:12:28 EDT
Might be worth to add it to capabilities as well .
Comment 2 Michael Pasternak 2013-01-30 11:01:40 EST

*** This bug has been marked as a duplicate of bug 893927 ***

Note You need to log in before you can comment on or make changes to this bug.