Bug 893927 - [RFE] Implement quota support in API
Summary: [RFE] Implement quota support in API
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Doron Fediuck
QA Contact: Artyom
URL: http://www.ovirt.org/Features/Quota
Whiteboard:
: 859767 950076 1132256 (view as bug list)
Depends On:
Blocks: 950076 1132506
TreeView+ depends on / blocked
 
Reported: 2013-01-10 09:32 UTC by Ondra Machacek
Modified: 2016-03-09 20:28 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this update, you can configure quotas using the REST API. New entities such as QuotaStorageLimit and QuotaClusterLimit were added to the quotas sub-collection. QuotaStorageLimit allows you to specify a quota policy for individual or all storage domains. QuotaClusterLimit allows you to specify the Memory and CPU limit for individual or all clusters in a data center.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:28:51 UTC
oVirt Team: SLA
sgrinber: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 39902 master MERGED restapi: add quota mode to data center Never
oVirt gerrit 39904 master MERGED restapi: implement Quota REST-API Never

Description Ondra Machacek 2013-01-10 09:32:41 UTC
Description of problem:
Please implement quota support in API.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 3 Michael Pasternak 2013-01-30 16:01:40 UTC
*** Bug 859767 has been marked as a duplicate of this bug. ***

Comment 7 Doron Fediuck 2014-05-08 16:16:07 UTC
*** Bug 950076 has been marked as a duplicate of this bug. ***

Comment 8 Doron Fediuck 2014-11-25 16:25:23 UTC
*** Bug 1132256 has been marked as a duplicate of this bug. ***

Comment 13 Max Kovgan 2015-06-28 14:12:49 UTC
ovirt-3.6.0-3 release

Comment 14 Artyom 2015-10-27 08:24:22 UTC
Verified on rhevm-3.6.0.2-0.1.el6.noarch
1) Add, update and remove of quota
2) Change datacenter quota mode
3) Add limits to quota(storage, cluster)
4) Add consumer to quota
5) Attach quota to vm
6) Attach quota to disk

Comment 16 Julie 2016-02-23 02:00:40 UTC
If this bug requires doc text for errata release, please provide draft text in the doc text field in the following format:

Cause:
Consequence:
Fix:
Result:

The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Comment 17 Julie 2016-02-29 05:32:17 UTC
hi Doron and Artyom, I have updated the doc text; however, it seems there should also be entities to allow assigning quotas per object, for example vms and disks. Could you advise?

Cheers,
Julie

Comment 18 Artyom 2016-02-29 13:28:33 UTC
I believe such option exist from 3.4:
for for example to update vm with quota:
<vm>
  <quota id="408039c9-e6e9-41bc-8e85-4476f0f13c0d"/>
</vm>

to update disk with quota:
<disk>
  <quota id="408039c9-e6e9-41bc-8e85-4476f0f13c0d"/>
</disk>

With name it show, that update succeed but vm and disk stay with old quota.
https://bugzilla.redhat.com/show_bug.cgi?id=1312896

Comment 19 Julie 2016-02-29 23:51:07 UTC
(In reply to Artyom from comment #18)
> I believe such option exist from 3.4:
> for for example to update vm with quota:
> <vm>
>   <quota id="408039c9-e6e9-41bc-8e85-4476f0f13c0d"/>
> </vm>
> 
> to update disk with quota:
> <disk>
>   <quota id="408039c9-e6e9-41bc-8e85-4476f0f13c0d"/>
> </disk>
> 
> With name it show, that update succeed but vm and disk stay with old quota.
> https://bugzilla.redhat.com/show_bug.cgi?id=1312896

Thanks!

Comment 21 errata-xmlrpc 2016-03-09 20:28:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.