Bug 859913 - [US2105][fork] Can not jenkins build a jbossas-7/jbosseap-6.0 application
[US2105][fork] Can not jenkins build a jbossas-7/jbosseap-6.0 application
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 07:44 EDT by Jianwei Hou
Modified: 2015-05-14 18:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:50:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jenkins.log (6.43 KB, text/x-log)
2012-09-24 07:44 EDT, Jianwei Hou
no flags Details
jenkins_20120928.log (20.76 KB, text/x-log)
2012-09-28 08:04 EDT, Jianwei Hou
no flags Details

  None (edit)
Description Jianwei Hou 2012-09-24 07:44:32 EDT
Created attachment 616505 [details]
jenkins.log

Description of problem:
Can not jenkins build jbossas-7/jbosseap-6.0 application successfully

Version-Release number of selected component (if applicable):
On fork_ami_US2105_133

How reproducible:
Always

Steps to Reproduce:
1. Create a jenkins server app, then create a jbossas-7/jbosseap-6.0 application
2. Embed jenkins client to jbossas-7/jbosseap-6.0 app
3. Make some change in app's repo and git push

  
Actual results:
Jenkins build failed:
............
remote: Waiting for build to schedule........
remote: **BUILD FAILED/CANCELLED**
remote: Please see the Jenkins log for more details via rhc-tail-files
remote: !!!!!!!!
remote: Deployment Halted!
remote: If the build failed before the deploy step, your previous
remote: build is still running.  Otherwise, your application may be
remote: partially deployed or inaccessible.
remote: Fix the build and try again.
remote: !!!!!!!!
..............

Expected results:
Jenkins build should be successful

Additional info:
Added jenkins.log
Comment 1 Dan Mace 2012-09-24 16:57:50 EDT
NOTE: This issue also exists in devenv_2215, and is not specific to the fork AMI in which it was found.
Comment 2 Dan Mace 2012-09-24 16:59:35 EDT
This issue is also with Jenkins in general, not just JBoss/Jenkins integration. Create a new Jenkins instance in dev, and it will fail to start due to a port binding exception.
Comment 3 Bill DeCoste 2012-09-25 12:13:40 EDT
Dan, any idea why is Jenkins now trying to bind to 0.0.0.0 instead of OPENSHIFT_INTERNAL_IP?
Comment 4 Dan Mace 2012-09-25 15:32:14 EDT

*** This bug has been marked as a duplicate of bug 859828 ***
Comment 5 Jianwei Hou 2012-09-28 08:03:40 EDT
This bug can be reproduce on fork_ami_US2105_178

devenv already has a fix for bug 859828, but I still can not jenkins build jbossas/jbosseap apps on fork_ami_US2105_178, I can embed jenkins-client to app and was able to access jenkins webconsole, and this seems different from bug 859828

Problem is described in comment 1


So reopen this bug and expect a fix
Comment 6 Jianwei Hou 2012-09-28 08:04:46 EDT
Created attachment 618536 [details]
jenkins_20120928.log
Comment 7 Paul Morie 2012-09-28 12:28:15 EDT
I was able to recreate this:

Sep 28, 2012 12:23:12 PM hudson.slaves.NodeProvisioner update
WARNING: Provisioned slave jbossas-build failed to launch
com.openshift.client.OpenShiftException: Cartridge for jenkins-client-1.4 not found
	at hudson.plugins.openshift.OpenShiftSlave.getCartridge(OpenShiftSlave.java:105)
	at hudson.plugins.openshift.OpenShiftSlave.createApp(OpenShiftSlave.java:235)
	at hudson.plugins.openshift.OpenShiftSlave.provision(OpenShiftSlave.java:222)
	at hudson.plugins.openshift.OpenShiftCloud$2.call(OpenShiftCloud.java:450)
	at hudson.plugins.openshift.OpenShiftCloud$2.call(OpenShiftCloud.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
Sep 28, 2012 12:23:11 PM hudson.plugins.openshift.OpenShiftCloud cancelBuild
WARNING: Build for label/builderName jbossas-build/jbossasbldr has been cancelled
Sep 28, 2012 12:23:11 PM hudson.plugins.openshift.OpenShiftCloud cancelBuild
INFO: Cancelling build
Comment 8 Paul Morie 2012-09-28 17:04:08 EDT
Root cause is that for jbossas/jbosseap, the jenkins job config is being created with an incorrect value.
Comment 9 Paul Morie 2012-09-28 18:18:30 EDT
Fix pushed and will be available in the next AMI for US2105.
Comment 10 Jianwei Hou 2012-09-28 22:52:55 EDT
Verified on fork_ami_US2105_189

Steps:
1. Create a jenkins server app
2. Create jbossas/jbosseap app, and embed jenkins client
3. Make some change in app's local repo and git push
4. Check both jbossas and jbosseap would git push successfully

Result:
Jenkins build for both jbossas and jbosseap app are successful.

Note You need to log in before you can comment on or make changes to this bug.