Bug 859828 - jenkins server can not be accessed after created and cannot embed jenknis client to existing apps
jenkins server can not be accessed after created and cannot embed jenknis cli...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Dan Mace
libra bugs
: Regression
: 860868 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 02:45 EDT by Meng Bo
Modified: 2015-05-14 18:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: devenv_2230+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:49:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jenkins.log (7.15 KB, text/x-log)
2012-09-24 02:45 EDT, Meng Bo
no flags Details
Jenkins error (194.08 KB, image/png)
2012-09-26 02:28 EDT, Yujie Zhang
no flags Details

  None (edit)
Description Meng Bo 2012-09-24 02:45:46 EDT
Created attachment 616384 [details]
jenkins.log

Description of problem:
Access the jenkins server home page after created will got some error messages. And got failed when trying to embed the jenkins client to existing apps.

Version-Release number of selected component (if applicable):
devenv_2215
cartridge-jenkins-client-1.4-0.33.2-1.git.0.8a57b87.el6.noarch
cartridge-jenkins-1.4-0.98.1-1.git.50.b863e16.el6.noarch

How reproducible:
always

Steps to Reproduce:
1.Create jenkins server
$rhc app create -a jenkins -t jenkins-1.4
2.Access the jenkins server home page
3.Try to embed jenkins client to existing apps
  
Actual results:
Got the following error from the home page. And jenkins client cannot be embedded.
==============
org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
	at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:246)
	at jenkins.InitReactorRunner.run(InitReactorRunner.java:43)
	at jenkins.model.Jenkins.executeReactor(Jenkins.java:849)
	at jenkins.model.Jenkins.<init>(Jenkins.java:761)
	at hudson.model.Hudson.<init>(Hudson.java:81)
	at hudson.model.Hudson.<init>(Hudson.java:77)
	at hudson.WebAppMain$2.run(WebAppMain.java:217)
Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
	at hudson.init.InitializerFinder.invoke(InitializerFinder.java:124)
	at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
	at jenkins.model.Jenkins$6.runTask(Jenkins.java:838)
	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
	... 8 more
Caused by: java.net.SocketException: Permission denied
	at sun.nio.ch.Net.bind(Native Method)
	at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:137)
	at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:77)
	at org.apache.mina.transport.socket.nio.NioSocketAcceptor.open(NioSocketAcceptor.java:248)
	at org.apache.mina.transport.socket.nio.NioSocketAcceptor.open(NioSocketAcceptor.java:48)
	at org.apache.mina.core.polling.AbstractPollingIoAcceptor.registerHandles(AbstractPollingIoAcceptor.java:525)
	at org.apache.mina.core.polling.AbstractPollingIoAcceptor.access$200(AbstractPollingIoAcceptor.java:66)
	at org.apache.mina.core.polling.AbstractPollingIoAcceptor$Acceptor.run(AbstractPollingIoAcceptor.java:406)
	at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:64)
	... 3 more


Expected results:
Jenkins server works correctly.

Additional info:
Attached jenkins.log for debug.

Output when embedding jenkins client to app.

[root@F17x64-openshift openshiftttest]# rhc app cartridge add -a py1s -d -c jenkins-client-1.4
Contacting https://ec2-184-73-85-219.compute-1.amazonaws.com
Problem reported from server. Response code was 500.

DEBUG:
Cartridge return code: 157

Exit Code: 143
api_c: ["placeholder"]
broker_c: ["namespace", "rhlogin", "ssh", "app_uuid", "debug", "alter", "cartridge", "cart_type", "action", "app_name", "api"]
API version:    1.1.3

RESULT:
Error contacting Jenkins server.
Could not download https://jenkins-bmengdev.dev.rhcloud.com/jnlpJars/jenkins-cli.jar
Comment 1 Dan Mace 2012-09-25 15:32:14 EDT
*** Bug 859913 has been marked as a duplicate of this bug. ***
Comment 2 Yujie Zhang 2012-09-26 02:24:42 EDT
This same issue exists on website on fork_ami_opensource_ruby19_3, tried to access the jenkins url , and caught the same issue. Details see in attachment.
Comment 3 Yujie Zhang 2012-09-26 02:28:37 EDT
Created attachment 617412 [details]
Jenkins error
Comment 4 Dan Mace 2012-09-26 09:10:06 EDT
Resolved as of devenv_2230+ by https://github.com/openshift/crankcase/pull/531.
Comment 5 Meng Bo 2012-09-27 01:34:41 EDT
Checked on devenv_2240. Issue has been fixed.
Jenkins server can be accessed after created.


# rhc app create -a php1 -t php-5.3 --enable-jenkins
Submitting form:
rhlogin: bmeng@redhat.com
debug: true
Contacting https://
Creating application: jenkins in bmengdev
Contacting https://
Response from server:
DEBUG:


Exit Code: 0
api_c: placeholder
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
API version:    1.1.3
DEBUG: 'jenkins' creation returned success.
Now your new domain name is being propagated worldwide (this might take a minute)...

Note: There is a git repo for your Jenkins application 'jenkins'
but it isn't being downloaded as part of this process.  In most cases
it isn't needed but you can always clone it later.

Checking if the application is available #1
Application jenkins is available at: http://jenkins-bmengdev.dev.rhcloud.com/
  Git URL: ssh://002258eba74e4186a74abefa1f1564c1@jenkins-bmengdev.dev.rhcloud.com/~/git/jenkins.git/
To make changes to 'jenkins', you must first clone it with:
git clone ssh://002258eba74e4186a74abefa1f1564c1@jenkins-bmengdev.dev.rhcloud.com/~/git/jenkins.git/

Then run 'git push' to update your OpenShift space.

Jenkins created successfully.  Please make note of these credentials:

   User: admin
   Password: nqThNs9waR-T

Note:  You can change your password at: https://jenkins-bmengdev.dev.rhcloud.com/me/configure

Creating application: php1 in bmengdev
Contacting https://
Response from server:
DEBUG:


Exit Code: 0
api_c: placeholder
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
API version:    1.1.3
DEBUG: 'php1' creation returned success.
Now your new domain name is being propagated worldwide (this might take a minute)...
Pulling new repo down
git clone  ssh://60c43c41c3ca475db779073c6286c6e9@php1-bmengdev.dev.rhcloud.com/~/git/php1.git/ php1
Now embedding the jenkins client into 'php1'...
Contacting https://
Response from server:
DEBUG:
Embedded app details: Job URL: https://jenkins-bmengdev.dev.rhcloud.com/job/php1-build/

Exit Code: 0
api_c: placeholder
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
API version:    1.1.3

RESULT:

Associated with job 'php1-build' in Jenkins server.

Job URL: https://jenkins-bmengdev.dev.rhcloud.com/job/php1-build/

Jenkins client 1.4 has been added to: php1

Checking if the application is available #1
Application php1 is available at: http://php1-bmengdev.dev.rhcloud.com/
  Git URL: ssh://60c43c41c3ca475db779073c6286c6e9@php1-bmengdev.dev.rhcloud.com/~/git/php1.git/
To make changes to 'php1', commit to php1/.
Successfully created application: php1
Comment 6 Xiaoli Tian 2012-09-27 04:32:37 EDT
*** Bug 860868 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.