Bug 85996 - ATI FireGL locks display when switching VTs
ATI FireGL locks display when switching VTs
Status: CLOSED DUPLICATE of bug 79248
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-11 18:07 EST by Stephen Savitzky
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config file (8.91 KB, text/plain)
2003-03-11 18:12 EST, Stephen Savitzky
no flags Details
XFree86.0.log -- logfile for first server (VT7) (30.15 KB, text/plain)
2003-03-11 18:19 EST, Stephen Savitzky
no flags Details
XFree86.0.log -- logfile for second server (VT8) (23.59 KB, text/plain)
2003-03-11 18:20 EST, Stephen Savitzky
no flags Details

  None (edit)
Description Stephen Savitzky 2003-03-11 18:07:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207
Phoenix/0.5

Description of problem:
When running X on an ATI FireGL card, with two copies of X running on different
VTs, switching between the VTs with, e.g., <ctrl><alt><F7> causes a greenish bar
of noise across the topmost (roughly)32 rows of the display.  The display,
keyboard, and mouse are then locked up, and not even logging in from the network
and killing X and gdm will restore normal operation.  A reboot fixes the problem.



Version-Release number of selected component (if applicable):
fglrx-glc22-4.2.0-2.4.0.i586

How reproducible:
Always

Steps to Reproduce:
1. Log in as root via gdm
2. Start a second X server with "startx `which xterm` -- :1
3. Try to get back to the original display with <ctrl><alt><F7>

(Note that _any_ way of starting two X servers produces the same bug, including
configuring gdm to start them on different VTs.

Actual Results:  A bar of noise appears across the top of the screen.  The
display, keyboard, and mouse are locked up.

Expected Results:  Should be able to switch between the two copies of X using
<ctrl><alt><f7> and <ctrl><alt><f8>

Additional info:

Problem does not occur switching between a single copy of X and a text virtual
terminal (e.g. using <ctrl><alt><f1>).

This machine is a Dell Precision 350n workstation with RH8.0 pre-installed, and
an ATI Fire GL E1 video card with 64MB of RAM.

I have tried this with both the driver shipped by Dell,
fglrx-glc22-4.2.0-2.4.0.i586, and also the latest driver from ATI,
fglrx-glc22-4.2.0-2.5.1.i586.  The problem also exists on both RedHat 8.0 and on
RedHat 7.3.

This bug seems to be superficially similar to Bug 68615
Comment 1 Stephen Savitzky 2003-03-11 18:12:30 EST
Created attachment 90563 [details]
XF86Config file

This is one of the various XF86Config files I've tried.  It's basically the
same as the one the initial setup configured, edited to add additional video
modes and a second mouse.
Comment 2 Stephen Savitzky 2003-03-11 18:19:10 EST
Created attachment 90564 [details]
XFree86.0.log -- logfile for first server (VT7)

This is a typical XFree86.0.log for the first X server to be started.
Comment 3 Stephen Savitzky 2003-03-11 18:20:46 EST
Created attachment 90565 [details]
XFree86.0.log -- logfile for second server (VT8)

Here's the log for the second server.  Note that it starts correctly; it's only
when you try to switch back to the first server on VT7 that the problem occurs.
Comment 4 Mike A. Harris 2003-03-12 06:38:33 EST
Red Hat does not support 3rd party drivers.  If you have problems while using
3rd party drivers, or if you require technical support for 3rd party drivers,
please contact the vendor of whom supplied you the drivers, or your hardware
vendor directly for assistance.

Closing report NOTABUG as this is not something which is supported by Red Hat.

*** This bug has been marked as a duplicate of 79248 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:52:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.