Bug 860233 - [as7 plugin] newly deployed war through JON CLI is not discovered
[as7 plugin] newly deployed war through JON CLI is not discovered
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: RHQ 4.5.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 07:08 EDT by bkramer
Modified: 2012-12-04 03:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 860231
: 860231 (view as bug list)
Environment:
Last Closed: 2012-12-04 03:57:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bkramer 2012-09-25 07:08:32 EDT
Description of problem:
Using JON CLI, newly created war file was "promoted" to the server-group of the eap6. That worked fine and the result of the operation was successful. Also, the server.log file showed successful deployment. However, deployed war file was not discovered and not added into inventory. The log file showed the following message:

...
"TRACE [InventoryManager.discovery-1] (rhq.core.pc.inventory.InventoryManager)- No need to prepare the activation of resource Resource[id=29821, uuid=c757a5a1-739c-4ebf-b035-011ce532219a, type={JBossAS7}DomainDeployment, key=deployment=helloworld, name=helloworld, parent=EAP Domain Controller (127.0.0.1:9990)] - its component is already started and its plugin config has not been updated since it was last started."
...

After more then one hour, and after "discovery -f" was performed, the war file was discovered and added into ManagedServerDeployments. 

Version-Release number of selected component (if applicable):
JON 3.1
EAP 6.0 (domain mode)

How reproducible:
Every time.

Steps to Reproduce:
1. import EAP6 in domain mode; 
2. create new DomainDeployment for EAP 6.0 using JON UI;
3. use JON CLI and "scheduleResourceOperation" method to promote war file to the server-group;
 
  
Actual results:
Deployment is properly done but promoted war file is not discovered and it's not added in the inventory.

Expected results:
Promoted war file is properly discovered and added into inventory

Additional info:
Discovery of the war file was performed after "discovery -f" was executed from the JON Agent command line.
Comment 1 Heiko W. Rupp 2012-12-04 03:57:22 EST
Closing, as this was already fixed in August and is thus included in RHQ 4.5.1

Note You need to log in before you can comment on or make changes to this bug.