Bug 860556 - Japanese : Bug tracking several pages , text needs to be translated to Japanese
Japanese : Bug tracking several pages , text needs to be translated to Japanese
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Shveta
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 03:15 EDT by Aziza Karol
Modified: 2012-12-04 10:21 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Some components of the Cloud Engine (Japanese) user interface did not have correct translations. This update adds the Japanese translations and are visible in the user interface.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:21:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
choose Provider text (65.75 KB, image/png)
2012-09-26 03:16 EDT, Aziza Karol
no flags Details
setting button & header (62.88 KB, image/png)
2012-09-26 03:18 EDT, Aziza Karol
no flags Details
label names for new usr grp (45.24 KB, image/png)
2012-09-26 03:19 EDT, Aziza Karol
no flags Details
header message for usr_grp (47.53 KB, image/png)
2012-09-26 03:20 EDT, Aziza Karol
no flags Details
usr grp delete pop up (150.85 KB, image/png)
2012-09-26 03:22 EDT, Aziza Karol
no flags Details
Tesxt Permissions (110.37 KB, image/png)
2012-09-26 03:23 EDT, Aziza Karol
no flags Details
provider eable disable message (86.63 KB, image/png)
2012-09-26 03:24 EDT, Aziza Karol
no flags Details
cancel and ok button (128.75 KB, image/png)
2012-09-26 03:30 EDT, Aziza Karol
no flags Details
X-delatcaloud text (60.53 KB, image/png)
2012-09-26 03:33 EDT, Aziza Karol
no flags Details
Settings Button and error message (65.24 KB, image/png)
2012-10-23 17:49 EDT, Shveta
no flags Details
UserGroup Labels (44.03 KB, image/png)
2012-10-23 17:50 EDT, Shveta
no flags Details
name in header (46.01 KB, image/png)
2012-10-23 17:51 EDT, Shveta
no flags Details
Text permission not fixed (147.95 KB, image/png)
2012-10-23 17:55 EDT, Shveta
no flags Details
cancel and ok button (182.04 KB, image/png)
2012-10-23 17:56 EDT, Shveta
no flags Details
X-deltacloud Driver text (61.47 KB, image/png)
2012-10-23 17:58 EDT, Shveta
no flags Details

  None (edit)
Description Aziza Karol 2012-09-26 03:15:32 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

Translation required in japanese for all the following
1.choose provider text (choose_provider_text.png)
2.setting header message and setting button (settings_button&header.png)
3.Label names while adding new user  group and administrator button(label_name_new_usr_grp_adminbutton.png)
4.Header message while adding user grp with blank name.(header_for_usr_group.png)
5.user group delete pop up message(user_grp_delete_popup.png)
6.Label "Permissions" on user profile page(label_permissions.png)
7.Provider enable disable message (provider_enble_disble_msg.png)
8.cancel and ok button while enabling/disabling provider and also connection buttons.(cncel_ok_connectionbutton.png)
9.Text "X-Deltacloud-xx" .(xdeltacloud-text.png)
  



Expected results:
Needs translation to japanese.

Additional info:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
Comment 1 Aziza Karol 2012-09-26 03:16:38 EDT
Created attachment 617418 [details]
choose Provider text
Comment 2 Aziza Karol 2012-09-26 03:18:32 EDT
Created attachment 617419 [details]
setting button & header
Comment 3 Aziza Karol 2012-09-26 03:19:46 EDT
Created attachment 617420 [details]
label names for new usr grp
Comment 4 Aziza Karol 2012-09-26 03:20:33 EDT
Created attachment 617421 [details]
header message for usr_grp
Comment 5 Aziza Karol 2012-09-26 03:22:26 EDT
Created attachment 617428 [details]
usr grp delete pop up
Comment 6 Aziza Karol 2012-09-26 03:23:33 EDT
Created attachment 617429 [details]
Tesxt Permissions
Comment 7 Aziza Karol 2012-09-26 03:24:44 EDT
Created attachment 617430 [details]
provider eable disable message
Comment 8 Aziza Karol 2012-09-26 03:30:57 EDT
Created attachment 617434 [details]
cancel and ok button
Comment 10 Aziza Karol 2012-09-26 03:33:18 EDT
Created attachment 617436 [details]
X-delatcaloud text
Comment 11 Jozef Zigmund 2012-10-16 12:08:29 EDT
Patch was sent: https://lists.fedorahosted.org/pipermail/aeolus-devel/2012-October/012952.html

#1,2,3,4,6 - were fixed,
#5,8 - caused by OS language settings(means cannot be translated in HTML),
#7 - fixed in the newest translations,
#9 - X-DC is not there in current UI
Comment 12 Matt Wagner 2012-10-16 13:37:31 EDT
Why is this bug private? May I flip it to public?
Comment 13 Matt Wagner 2012-10-16 14:13:15 EDT
Unsetting "private" flag, reviewed all screenshots and none reveal any sensitive info. The patch is on an upstream list, so it's weird to be fixing a "secret" bug upstream.

I reviewed the patch, though it has a few issues I will mention (and need to be able to reference bug).
Comment 14 Matt Wagner 2012-10-17 14:06:44 EDT
#3 and #4 will require a follow-up translation.

For #9, we shouldn't be translating "X-Deltacloud-Provider" at all -- it's the name of an HTTP header. I entered https://bugzilla.redhat.com/show_bug.cgi?id=867560 to track this as a separate issue.
Comment 15 Matt Wagner 2012-10-17 14:07:27 EDT
On 1.1:


commit 26e173967fb3a94e0530d5cb85172a8b268d6be0
Author: Jozef Zigmund <jzigmund@redhat.com>
Date:   Tue Oct 16 17:40:34 2012 +0200

    BZ 860556 Revised missing translation keys
    
    https://bugzilla.redhat.com/show_bug.cgi?id=860556
    (cherry picked from commit c764fef454bf5519f2292059ba3c27a0448ec418)
Comment 17 Shveta 2012-10-23 17:49:00 EDT
Created attachment 632416 [details]
Settings Button and error message

The Button "Setting" and error message for wrong value of quota still display in English
Comment 18 Shveta 2012-10-23 17:50:45 EDT
Created attachment 632417 [details]
UserGroup Labels

Not fixed
Comment 19 Shveta 2012-10-23 17:51:51 EDT
Created attachment 632418 [details]
name in header

Not fixed ( 3rd one )
Comment 20 Shveta 2012-10-23 17:55:02 EDT
Created attachment 632420 [details]
Text permission not fixed

7th screenshot not fixed
Comment 21 Shveta 2012-10-23 17:56:48 EDT
Created attachment 632421 [details]
cancel and ok button

8th one not fixed
Comment 22 Shveta 2012-10-23 17:58:17 EDT
Created attachment 632422 [details]
X-deltacloud Driver text

not fixed


rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.5-1.el6cf.noarch
aeolus-conductor-doc-0.13.20-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-conductor-daemons-0.13.20-1.el6cf.noarch
aeolus-all-0.13.20-1.el6cf.noarch
aeolus-conductor-0.13.20-1.el6cf.noarch
Comment 23 Angus Thomas 2012-10-24 13:49:53 EDT
Retesting with aeolus-conductor-0.13.21-1.el6cf, I see that:

The occurrence of "Settings" in Comment 17 is fixed
The occurrence of "Permissions" in Comment 20 is fixed

I'd also note that the occurrence of "X-Deltacloud-Driver" in Comment 22 is not a bug. That string is an HTTP header which should not be translated.
Comment 24 Mike Orazi 2012-10-24 14:12:12 EDT
I think we should probably confirm that Comment 23 is true, limit the scope of the testing of this BZ to the fixed ones, and open new bugs against 2.0 for any issues that are still outstanding.
Comment 25 Shveta 2012-10-24 14:49:43 EDT
Opened new bugs for outstanding issues..

Verifying this one
Comment 27 errata-xmlrpc 2012-12-04 10:21:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.