Bug 860688 - New Deployments preset filter returns PG error
New Deployments preset filter returns PG error
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: beta3
: ---
Assigned To: Jiri Tomasek
Rehana
:
: 861384 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 09:39 EDT by Jiri Tomasek
Modified: 2012-12-04 10:21 EST (History)
8 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.15-1.el6cf
Doc Type: Bug Fix
Doc Text:
On the Overview page, selecting 'Filter View', switching to the Applications tab, and then selecting the 'New Applications' preset filter caused an error: "returns PG::Error". This occurred because the query used for listing the deployments was incorrect. This bug fix corrects the query and the error no longer occurs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:21:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new_application (126.02 KB, image/png)
2012-10-02 19:31 EDT, Shveta
no flags Details

  None (edit)
Description Jiri Tomasek 2012-09-26 09:39:09 EDT
Description of problem:

The "New Deployments" preset filter in Deployments list does not work and returns PG::Error

Version-Release number of selected component (if applicable):


How reproducible:
Go to Overview page, select filter view and switch to deployments tab. Select "New Deployments" preset filter. PG:Error is returned.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
New Deployments preset filter displays filtered deployment list.

Additional info:
Comment 1 Jiri Tomasek 2012-09-26 09:44:12 EDT
pull request https://github.com/aeolusproject/conductor/pull/77
Comment 3 Tzu-Mainn Chen 2012-09-28 10:53:49 EDT
ACK'd and pushed to master/1.1:

commit bd4b8937a1b68a0ae7d159fe048871e373dd71f3
Author: Jiri Tomasek <jtomasek@redhat.com>
Date:   Wed Sep 26 15:41:59 2012 +0200

    BZ860688 fix the New Deployments preset filter
    
    https://bugzilla.redhat.com/show_bug.cgi?id=860688
    (cherry picked from commit 3de8d43ba550b3c7c37a7ea9d4b227e8fe6a9467)
Comment 5 Shveta 2012-10-02 19:31:46 EDT
Created attachment 620562 [details]
new_application

Go to Overview page, select filter view and switch to Applications tab. Select "New Applications" preset filter. 

No error as shown in screenshot.
Comment 6 Shveta 2012-10-02 19:35:58 EDT
rpm -qa|grep aeolus
aeolus-conductor-doc-0.13.16-1.el6cf.noarch
aeolus-configure-2.8.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.3-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.13.16-1.el6cf.noarch
aeolus-conductor-daemons-0.13.16-1.el6cf.noarch
aeolus-all-0.13.16-1.el6cf.noarch
Comment 7 Jiri Tomasek 2012-10-04 04:20:06 EDT
*** Bug 861384 has been marked as a duplicate of this bug. ***
Comment 9 Jiri Tomasek 2012-11-09 04:19:44 EST
The definition of the query used for listing the deployments in "new" state was incorrect. (Basically a typo thing).
Comment 11 errata-xmlrpc 2012-12-04 10:21:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.