Bug 861384 - SQL error displayed when filtering on "New Applications" in Monitor -> applications (grid) view
SQL error displayed when filtering on "New Applications" in Monitor -> applic...
Status: CLOSED DUPLICATE of bug 860688
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jiri Tomasek
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 08:52 EDT by Aaron Weitekamp
Modified: 2012-10-04 04:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 04:20:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
filtering on New Applications SQL error (228.49 KB, image/jpeg)
2012-09-28 08:52 EDT, Aaron Weitekamp
no flags Details
filtering on All applications. Notice several states: new, stopped, running (188.86 KB, image/jpeg)
2012-09-28 08:54 EDT, Aaron Weitekamp
no flags Details
aeolus-debug logs (5.40 MB, application/x-gzip)
2012-09-28 08:56 EDT, Aaron Weitekamp
no flags Details

  None (edit)
Description Aaron Weitekamp 2012-09-28 08:52:55 EDT
Created attachment 618553 [details]
filtering on New Applications SQL error

Description of problem:
I launched 5 applications consecutively and they stayed in "New" state. I filtered on New applications when in monitor applications grid view and it displayed SQL error text. All other filter actions succeeded as expected.

Version-Release number of selected component (if applicable):
1.1
[root@qeblade40 ~]# rpm -qa |grep aeolus
aeolus-conductor-0.13.14-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch


How reproducible:
Presumably very reproducible if one can get applications into "New" state

Steps to Reproduce:
1. Launch a bunch of instances consecutively so they are in "New" state
2. Click Monitor tab, switch to grid view, click applications sub-tab
3. Select drop-down filter "New Applications
  
Actual results:
PGError displaying SQL. See attached screenshots. Error text below.

Expected results:
Filter displayed applications so only apps with New status are displayed


Error text displayed:
PGError: ERROR: column deployments.statenew does not exist LINE 1: ..._id WHERE "deployments"."deleted_at" IS NULL AND (deployment... ^ : SELECT "deployments"."id" AS t0_r0, "deployments"."name" AS t0_r1, "deployments"."realm_id" AS t0_r2, "deployments"."owner_id" AS t0_r3, "deployments"."pool_id" AS t0_r4, "deployments"."lock_version" AS t0_r5, "deployments"."created_at" AS t0_r6, "deployments"."updated_at" AS t0_r7, "deployments"."frontend_realm_id" AS t0_r8, "deployments"."deployable_xml" AS t0_r9, "deployments"."scheduled_for_deletion" AS t0_r10, "deployments"."uuid" AS t0_r11, "deployments"."pool_family_id" AS t0_r12, "deployments"."deleted_at" AS t0_r13, "deployments"."state" AS t0_r14, "deployments"."partial_launch" AS t0_r15, "pools"."id" AS t1_r0, "pools"."name" AS t1_r1, "pools"."exported_as" AS t1_r2, "pools"."quota_id" AS t1_r3, "pools"."pool_family_id" AS t1_r4, "pools"."lock_version" AS t1_r5, "pools"."created_at" AS t1_r6, "pools"."updated_at" AS t1_r7, "pools"."enabled" AS t1_r8, "provider_accounts"."id" AS t2_r0, "provider_accounts"."label" AS t2_r1, "provider_accounts"."provider_id" AS t2_r2, "provider_accounts"."quota_id" AS t2_r3, "provider_accounts"."lock_version" AS t2_r4, "provider_accounts"."created_at" AS t2_r5, "provider_accounts"."updated_at" AS t2_r6, "provider_accounts"."priority" AS t2_r7, "providers"."id" AS t3_r0, "providers"."name" AS t3_r1, "providers"."url" AS t3_r2, "providers"."lock_version" AS t3_r3, "providers"."created_at" AS t3_r4, "providers"."updated_at" AS t3_r5, "providers"."provider_type_id" AS t3_r6, "providers"."deltacloud_provider" AS t3_r7, "providers"."enabled" AS t3_r8, "providers"."available" AS t3_r9, "users"."id" AS t4_r0, "users"."username" AS t4_r1, "users"."email" AS t4_r2, "users"."crypted_password" AS t4_r3, "users"."first_name" AS t4_r4, "users"."last_name" AS t4_r5, "users"."quota_id" AS t4_r6, "users"."login_count" AS t4_r7, "users"."failed_login_count" AS t4_r8, "users"."last_request_at" AS t4_r9, "users"."current_login_at" AS t4_r10, "users"."last_login_at" AS t4_r11, "users"."current_login_ip" AS t4_r12, "users"."last_login_ip" AS t4_r13, "users"."created_at" AS t4_r14, "users"."updated_at" AS t4_r15 FROM "deployments" LEFT OUTER JOIN "pools" ON "pools"."id" = "deployments"."pool_id" LEFT OUTER JOIN "instances" ON "deployments"."id" = "instances"."deployment_id" LEFT OUTER JOIN "provider_accounts" ON "provider_accounts"."id" = "instances"."provider_account_id" LEFT OUTER JOIN "providers" ON "providers"."id" = "provider_accounts"."provider_id" LEFT OUTER JOIN "users" ON "users"."id" = "deployments"."owner_id" LEFT OUTER JOIN provider_types ON provider_types.id = providers.provider_type_id WHERE "deployments"."deleted_at" IS NULL AND (deployments.statenew) AND (lower(pools.name) LIKE '%%' OR lower(deployments.name) LIKE '%%' OR lower(provider_types.name) LIKE '%%') ORDER BY "deployments".name asc
Comment 1 Aaron Weitekamp 2012-09-28 08:54:05 EDT
Created attachment 618554 [details]
filtering on All applications. Notice several states: new, stopped, running
Comment 2 Aaron Weitekamp 2012-09-28 08:56:14 EDT
Created attachment 618566 [details]
aeolus-debug logs
Comment 4 Jiri Tomasek 2012-10-04 04:20:06 EDT

*** This bug has been marked as a duplicate of bug 860688 ***

Note You need to log in before you can comment on or make changes to this bug.