Bug 86077 - updated WindowMaker messes up title bar
updated WindowMaker messes up title bar
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: WindowMaker (Show other bugs)
2.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Ben Levenson
: Security
: 186078 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-13 11:44 EST by Michael J. Eisenhower
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-19 08:47:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Eisenhower 2003-03-13 11:44:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ia64; en-US; rv:1.0.1) Gecko/20020728

Description of problem:
This bug is for Red Hat Linux Advanced Workstation release 2.1AW (Derry) but I
can't seem to find that as an options so I'm reporting it as a 2.1AS bug.  With
a fully patched system the upgrade of WindowMaker causes the title bar to get
messed up.  It appears to be transparent and  makes it impossible to read what
is on the title bar.  This happens with mozilla and ANSYS but doesn't seem to
affect xterm.  Downgrading to the versions on the install media fixes the
problem (but it has a security vunerability).

Version-Release number of selected component (if applicable):
WindowMaker-0.65.1-4.1

How reproducible:
Always

Steps to Reproduce:
1.upgrade to new version of windowmaker
2.fire up mozilla
3.try to read title bar
    

Actual Results:  you see an unreadable titlebar

Expected Results:  you should be able to read it

Additional info:
Comment 1 Havoc Pennington 2003-03-13 15:27:59 EST
I bet the AS windowmaker patch was the old broken one I did, instead of the one 
we ended up shipping for 6.2/7.x/8; if so I guess we'll need to update the 
errata.
Comment 2 Michael J. Eisenhower 2003-03-13 15:40:14 EST
I removed my GNUstep folder and the problem went away.  However when I went to
edit my configuration (I can't stand click to focus) with wmakerconf I get the
following error:

[meisenho@ducati meisenho]$ wmakerconf 
wmakerconf: rimage.c:461: rimage_2_preview: Assertion `image && image->width &&
image->height' failed.
Aborted

After reading the errata description for WindowMaker that wmakerconf needs to
updated as well, maybe?
Comment 3 Havoc Pennington 2003-03-13 16:05:08 EST
Those are the symptoms of the broken patch, it can't load any image over some
really small size.
Comment 4 Michael J. Eisenhower 2003-03-27 10:44:05 EST
Is an updated rpm going to be issued for this ????
Comment 5 Mark J. Cox (Product Security) 2003-03-31 06:54:34 EST
We are updating the erratum packages attached to the RHSA-2003:009 advisory to
correct this issue.  (Once these have passed QA and get pushed this bug will get
automatically updated)
Comment 6 Mark J. Cox (Product Security) 2003-05-22 12:43:50 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2003-009.html
Comment 7 Michael J. Eisenhower 2003-06-17 16:08:33 EDT
This is fine and all, but as I reported in the first report, this was for
Red Hat Linux Advanced Workstation release 2.1AW (Derry), which is NOT a
choice in bugzilla!  WindowMaker-0.65.1-4.2.ia64.rpm seems to be only 
available in RHN for 2.1AS.  This needs to be setup on RHN for 2.1AW 
as well.
Comment 8 Mark J. Cox (Product Security) 2003-06-17 17:00:43 EDT
It looks like when we did the update on this errata the packages for Advanced
Workstation 2.1 for Itanium were omitted.  We'll work on fixing this, thanks for
reporting it.
Comment 9 Mark J. Cox (Product Security) 2003-06-19 08:47:41 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2003-009.html
Comment 10 Ngo Than 2006-03-22 06:25:35 EST
*** Bug 186078 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.