Bug 864087 - wired ethernet defaults to Off in certain situations
wired ethernet defaults to Off in certain situations
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedNTH RejectedBlocker
:
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-08 10:32 EDT by Kamil Páral
Modified: 2012-12-03 03:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 03:48:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-10-08 10:32:57 EDT
Description of problem:
Sometimes I have wired ethernet disabled by default in the installed system. That happens if:

1) I install from LiveCD converted to USB stick using livecd-iso-to-disk
2) I install from LiveCD converted to PXE using livecd-iso-to-pxeboot

But doesn't happen if:

3) I install from LiveCD burnt to optical media
4) I install from LiveCD using KVM

On the installed system I see ONBOOT="no" in /etc/sysconfig/network-scripts/ifcfg-eth0. I don't have any further logs because of bug 862801. Once the bug is fixed, I can provide more logs.

Version-Release number of selected component (if applicable):
F18 Beta TC2 Live GNOME x86_64
anaconda 18.12

How reproducible:
seems always

Steps to Reproduce:
1. install from LiveCD using USB or PXE
Comment 1 Kamil Páral 2012-10-08 10:35:09 EDT
We have waged wars about the ethernet connection defaults in the past. The situation was resolved by making sure all installation types (live, dvd, minimal) lead to ethernet connection enabled by default. This could be accepted as a blocker (it would be very border-line I guess), or at least NTH.
Comment 2 Kamil Páral 2012-11-28 11:56:45 EST
This is a certain +1 NTH for me, and I'd slightly incline even to +1 blocker. My belief is that network should work out of the box, if possible. Quite a few users may be confused when their network doesn't work and they are not familiar with GNOME interface. Optical media are not affected, but USB media are, and they are popular. Another reason is that lots of the affected users will be forced to enable their network on every boot, because they won't know how to change it in configuration, and that highly annoying. I've met some of these users (affected exactly by this behavior) in our past releases.
Comment 3 Adam Williamson 2012-11-29 14:58:37 EST
Discussed at 2012-11-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-29/f18final-blocker-review-1.1.2012-11-29-17.01.log.txt . Assuming this affects only post-install configuration (re-propose if the network is down on boot of the live image), this is rejected as a blocker but accepted as NTH - it's annoying, but you can always just turn it on. We shipped with it off intentionally for years. Accepted as NTH as this isn't the intended behaviour and it can't be fixed with an update.
Comment 4 Radek Vykydal 2012-11-30 08:29:47 EST
I am not able to reproduce with 1). Could you please try to reproduce with F18 Beta and attach ifcfg.log, anaconda.log and syslog eventually?
Comment 5 Kamil Páral 2012-12-03 03:48:02 EST
This is indeed fixed in F18 Beta.

Note You need to log in before you can comment on or make changes to this bug.