Bug 860848 - mirror to thinpool conversion attempt passes when it should fail if it's not supported
mirror to thinpool conversion attempt passes when it should fail if it's not ...
Status: CLOSED DUPLICATE of bug 858874
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 17:01 EDT by Corey Marthaler
Modified: 2012-10-11 11:19 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 11:19:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2012-09-26 17:01:57 EDT
Description of problem:
This is basically bug 858874, but with a mirror volume being converted instead of a linear volume. I'm not even sure if this is or is not supported, but bug 855171 appears to imply that it's not.


[root@taft-04 ~]# lvcreate -m 1 -n mirror -L 100M TEST
  Logical volume "mirror" created

[root@taft-04 ~]# lvs -a -o +devices
  LV                VG   Attr     LSize   Log         Copy%  Devices
  mirror            TEST mwi-a-m- 100.00m mirror_mlog 100.00 mirror_mimage_0(0),mirror_mimage_1(0)
  [mirror_mimage_0] TEST iwi-aom- 100.00m                    /dev/sde1(0)
  [mirror_mimage_1] TEST iwi-aom- 100.00m                    /dev/sdf1(0)
  [mirror_mlog]     TEST lwi-aom-   4.00m                    /dev/sdg1(0)

[root@taft-04 ~]# lvconvert --thinpool TEST/mirror
[root@taft-04 ~]# echo $?
0

[root@taft-04 ~]# lvs -a -o +devices
  LV                VG   Attr     LSize   Log         Copy%  Devices
  mirror            TEST mwi-a-m- 100.00m mirror_mlog 100.00 mirror_mimage_0(0),mirror_mimage_1(0)
  [mirror_mimage_0] TEST iwi-aom- 100.00m                    /dev/sde1(0)
  [mirror_mimage_1] TEST iwi-aom- 100.00m                    /dev/sdf1(0)
  [mirror_mlog]     TEST lwi-aom-   4.00m                    /dev/sdg1(0)

[root@taft-04 ~]# lvcreate --virtualsize 1G --thinpool TEST/mirror -n origin
  Logical volume mirror is not a thin pool.


Version-Release number of selected component (if applicable):
2.6.32-279.el6.x86_64

lvm2-2.02.97-3.el6    BUILT: Tue Sep 11 05:06:56 CDT 2012
lvm2-libs-2.02.97-3.el6    BUILT: Tue Sep 11 05:06:56 CDT 2012
lvm2-cluster-2.02.97-3.el6    BUILT: Tue Sep 11 05:06:56 CDT 2012
udev-147-2.41.el6    BUILT: Thu Mar  1 13:01:08 CST 2012
device-mapper-1.02.76-3.el6    BUILT: Tue Sep 11 05:06:56 CDT 2012
device-mapper-libs-1.02.76-3.el6    BUILT: Tue Sep 11 05:06:56 CDT 2012
device-mapper-event-1.02.76-3.el6    BUILT: Tue Sep 11 05:06:56 CDT 2012
device-mapper-event-libs-1.02.76-3.el6    BUILT: Tue Sep 11 05:06:56 CDT 2012
cmirror-2.02.97-3.el6    BUILT: Tue Sep 11 05:06:56 CDT 2012
Comment 1 Zdenek Kabelac 2012-10-11 11:19:09 EDT

*** This bug has been marked as a duplicate of bug 858874 ***

Note You need to log in before you can comment on or make changes to this bug.