Bug 860861 - yum install clang fails because it needs an old version of libstdc++-devel
yum install clang fails because it needs an old version of libstdc++-devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
: 861103 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 18:04 EDT by Ondrej Majerech
Modified: 2014-01-21 18:23 EST (History)
12 users (show)

See Also:
Fixed In Version: llvm-3.0-14.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-28 09:26:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of 'yum install clang' (3.42 KB, text/plain)
2012-09-26 18:04 EDT, Ondrej Majerech
no flags Details

  None (edit)
Description Ondrej Majerech 2012-09-26 18:04:53 EDT
Created attachment 617800 [details]
Output of 'yum install clang'

Description of problem:

Doing 'yum install clang' on an x86_64 Fedora 17 machine tries to pull in libstdc++-devel.i686 along with its dependencies, which fails with Error:  Multilib version problems found. (Complete yum output attached.)

Version-Release number of selected component (if applicable):
yum.noarch 3.4.3-29.fc17

How reproducible:
Always

Steps to Reproduce:
1. yum install clang
2.
3.
  
Actual results:
Yum tries to pull in .i686 packages and fails at that.

Expected results:
Yum install clang without trying to pull in any unnecessary .i686 packages.

Additional info:
System is up to date, I did yum update before trying to install clang; the update went without problems. Also tried 'yum clean all' and 'yum install clang' again, but to no avail. I don't have any -testing repos enabled.

'yum check' outputs the following:

  kernel-headers-3.5.3-1.unpatch.fc17.x86_64 is a duplicate with kernel-headers-3.5.2-3.unpatch.fc17.x86_64
  kernel-headers-3.5.4-1.unpatch.fc17.x86_64 is a duplicate with kernel-headers-3.5.3-1.unpatch.fc17.x86_64
  Error: check all

I'm not sure if it's related to this problem or not. 'yum remove kernel-headers' wants to remove 20 other packages, including akmods, gcc and eclipse-cdt, all of which I want to keep.

I don't currently have any .i686 packages installed:

  [root@nightshade ~]# yum list installed '*.i686'
  Loaded plugins: langpacks, presto, refresh-packagekit
  Error: No matching Packages to list
Comment 1 Andre Robatino 2012-09-27 00:43:34 EDT
I saw this after already having clang.x86_64 installed and was prevented from updating by the multilib conflict. Removing clang allowed me to update the rest of the packages.
Comment 2 Andre Robatino 2012-09-27 01:13:10 EDT
There is a version currently in updates-testing which resolves this:

https://admin.fedoraproject.org/updates/FEDORA-2012-14699/llvm-3.0-14.fc17
Comment 3 Andre Robatino 2012-09-27 10:16:28 EDT
It fails also on i386:

[root@dell-pc ~]# yum install clang
Loaded plugins: langpacks, presto, refresh-packagekit, security
Resolving Dependencies
--> Running transaction check
---> Package clang.i686 0:3.0-13.fc17 will be installed
--> Processing Dependency: llvm(x86-32) = 3.0-13.fc17 for package: clang-3.0-13.fc17.i686
--> Processing Dependency: libstdc++-devel = 4.7.0 for package: clang-3.0-13.fc17.i686
--> Running transaction check
---> Package clang.i686 0:3.0-13.fc17 will be installed
--> Processing Dependency: libstdc++-devel = 4.7.0 for package: clang-3.0-13.fc17.i686
---> Package llvm.i686 0:3.0-13.fc17 will be installed
--> Finished Dependency Resolution
Error: Package: clang-3.0-13.fc17.i686 (updates)
           Requires: libstdc++-devel = 4.7.0
           Installed: libstdc++-devel-4.7.2-2.fc17.i686 (@updates)
               libstdc++-devel = 4.7.2-2.fc17
           Available: libstdc++-devel-4.7.0-5.fc17.i686 (fedora)
               libstdc++-devel = 4.7.0-5.fc17
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@dell-pc ~]#
Comment 4 Cristian Ciupitu 2012-09-27 14:30:47 EDT
*** Bug 861103 has been marked as a duplicate of this bug. ***
Comment 5 Michel Alexandre Salim 2012-09-28 01:26:09 EDT
https://admin.fedoraproject.org/updates/FEDORA-2012-14699/llvm-3.0-14.fc17 is being pushed to stable. Apologies for the mix-up, the problem is that Jakub Jelinek didn't have commit access to LLVM, so he can't add LLVM to the GCC update
Comment 6 Rex Dieter 2012-09-28 09:26:23 EDT
bodhi - 2012-09-28 08:24:08
This update has been pushed to stable
Comment 7 Andre Robatino 2012-09-28 09:29:12 EDT
From #fedora-devel :

<robatino> in https://bugzilla.redhat.com/show_bug.cgi?id=860861 , the Status was set to RELEASE_PENDING, which is unusual, and when the fix was pushed to stable, the bug was not automatically closed as usual. is this expected?
<rdieter> robatino: is it one of your packages?  was the bodhi flag "automatically close bugs" set?
<rdieter> (if that flag wasn't set, then the bug won't get closed obviously)
<robatino> rdieter: not my package, just watching the bug
<rdieter> ok, only maintainers can see if that flag is set or not, so hard to speculate
* rdieter closed the bug

Note You need to log in before you can comment on or make changes to this bug.