Bug 861103 - clang-3.0-13 requires libstdc++-devel 4.7.0, which impedes libstdc++-devel-4.7.2 update
clang-3.0-13 requires libstdc++-devel 4.7.0, which impedes libstdc++-devel-4....
Status: CLOSED DUPLICATE of bug 860861
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
i686 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-09-27 10:08 EDT by David J. Malan
Modified: 2012-09-27 14:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-09-27 14:30:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David J. Malan 2012-09-27 10:08:27 EDT
Description of problem:

Upon doing a `yum update` on 9/26/12 on an otherwise recently updated system (with clang and libstdc++-devel already installed), yum yields the actual results below.  Using --skip-broken for now indeed redresses.

Version-Release number of selected component (if applicable):


How reproducible:

`yum update` with clang-3.0-13.fc17.i686 and libstdc++-devel-4.7.0-5.fc17.i686 already installed.

Steps to Reproduce:
1. yum update
Actual results:

--> Finished Dependency Resolution
Error: Package: clang-3.0-13.fc17.i686 (@updates/$releasever)
           Requires: libstdc++-devel = 4.7.0
           Removing: libstdc++-devel-4.7.0-5.fc17.i686 (@os/$releasever)
               libstdc++-devel = 4.7.0-5.fc17
           Updated By: libstdc++-devel-4.7.2-2.fc17.i686 (updates)
               libstdc++-devel = 4.7.2-2.fc17
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

No such dependency error.

Additional info:

Replicated on multiple installations.
Comment 1 Marek Zdunek 2012-09-27 10:41:27 EDT
I have the same problem

log part:
--> Przetwarzanie zależności: libstdc++-devel = 4.7.0 dla pakietu: clang-3.0-13.fc17.x86_64

---> Pakiet libstdc++-devel.x86_64 0:4.7.2-2.fc17 zostanie zaktualizowany

---> Pakiet libtool.x86_64 0:2.4.2-3.fc17 zostanie zaktualizowany

---> Pakiet libtool.x86_64 0:2.4.2-3.1.fc17 zostanie zaktualizowany

---> Pakiet libtool-ltdl.i686 0:2.4.2-3.fc17 zostanie zaktualizowany

---> Pakiet libtool-ltdl.x86_64 0:2.4.2-3.fc17 zostanie zaktualizowany

---> Pakiet libtool-ltdl.i686 0:2.4.2-3.1.fc17 zostanie zaktualizowany

---> Pakiet libtool-ltdl.x86_64 0:2.4.2-3.1.fc17 zostanie zaktualizowany

--> Wykonywanie sprawdzania transakcji

---> Pakiet libstdc++-devel.i686 0:4.7.0-5.fc17 zostanie zainstalowany

--> Przetwarzanie zależności: libstdc++(x86-32) = 4.7.0-5.fc17 dla pakietu: libstdc++-devel-4.7.0-5.fc17.i686

---> Pakiet libstdc++-devel.x86_64 0:4.7.0-5.fc17 zostanie zaktualizowany

--> Ukończono rozwiązywanie zależności

Błąd: Pakiet: libstdc++-devel-4.7.0-5.fc17.i686 (fedora)

          Wymaga: libstdc++(x86-32) = 4.7.0-5.fc17

          Usuwanie: libstdc++-4.7.0-5.fc17.i686 (@anaconda-0)

              libstdc++(x86-32) = 4.7.0-5.fc17

          Zaktualizowano przez: libstdc++-4.7.2-2.fc17.i686 (updates)

              libstdc++(x86-32) = 4.7.2-2.fc17

 Można spróbować użyć --skip-broken, aby obejść problem

 Można spróbować wykonać polecenie: rpm -Va --nofiles --nodigest


Błąd:  Multilib version problems found. This often means that the root

      cause is something else and multilib version checking is just

      pointing it that there is a problem. Eg.:


        1. You have an upgrade for libquadmath which is missing some

           dependency that another package requires. Yum is trying to

           solve this by installing an older version of libquadmath of the

           different architecture. If you exclude the bad architecture

           yum will tell you what the root cause is (which package

           requires what).


        2. You have multiple architectures of libquadmath installed, but

           yum can only see an upgrade for one of those arcitectures.

           If you don't want/need both architectures anymore then you

           can remove the one with the missing update and everything

           will work.


        3. You have duplicate versions of libquadmath installed already.

           You can use "yum check" to get yum show these errors.


      ...you can also use --setopt=protected_multilib=false to remove

      this checking, however this is almost never the correct thing to

      do as something else is very likely to go wrong (often causing

      much more problems).


      Chronione wersje multilib: libquadmath-4.7.2-2.fc17.x86_64 != libquadmath-4.7.0-5.fc17.x86_64

Błąd: Chronione wersje multilib: libgfortran-4.7.2-2.fc17.x86_64 != libgfortran-4.7.0-5.fc17.x86_64
Comment 2 Cristian Ciupitu 2012-09-27 14:30:47 EDT

*** This bug has been marked as a duplicate of bug 860861 ***

Note You need to log in before you can comment on or make changes to this bug.