Bug 860974 - Number of downloaded packages increases on failed attempts
Number of downloaded packages increases on failed attempts
Status: CLOSED DUPLICATE of bug 854075
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
18
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 04:52 EDT by Petr Viktorin
Modified: 2014-01-21 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 06:26:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Viktorin 2012-09-27 04:52:24 EDT
Description of problem:
When time a package download fails, yum says "Trying other mirror." and re-tries the download elsewhere. When this happens the number of downloaded packages is incremented, causing misleading progress output.

Version-Release number of selected component (if applicable):
3.4.3-44.fc18


Steps to Reproduce:
1. Use a repo with bad mirrors
2. Do a yum update
  
Actual results:
$ sudo yum update
[snip]
(337/151): tzdata-java-2012f-1.fc18.noarch.rpm                                                                                                                                                                                                         |    0 B  00:00:30     
http://download-i2.fedoraproject.org/pub/fedora/linux/development/18/x86_64/os/Packages/t/tzdata-java-2012f-1.fc18.noarch.rpm: [Errno 12] Timeout on http://download-i2.fedoraproject.org/pub/fedora/linux/development/18/x86_64/os/Packages/t/tzdata-java-2012f-1.fc18.noarch.rpm: (28, '')
Trying other mirror.
(338/151): tzdata-java-2012f-1.fc18.noarch.rpm                                                                                                                                                                                                         | 154 kB  00:00:00     


Expected results:
Last package downloaded is marked as (151/151)
Comment 1 Zdeněk Pavlas 2012-09-27 06:26:45 EDT
It's fixed in python-urlgrabber upstream.  I'll do a F18 build today.

*** This bug has been marked as a duplicate of bug 854075 ***

Note You need to log in before you can comment on or make changes to this bug.