Bug 854075 - Download counter increments when there's a 404 error
Download counter increments when there's a 404 error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
: 860974 861562 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 19:26 EDT by Andrew Gunnerson
Modified: 2014-01-21 18:23 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 04:00:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Gunnerson 2012-09-03 19:26:10 EDT
I just installed Rawhide and found that yum increases the counter when there's a 404 error (eg. when mirrors are syncing).

Here's a screenshot of what I mean: http://i.imgur.com/pEkkM.png There were two 404 errors and yum counted to 12/10.

I have yum version 3.4.3-42.fc18 installed.
Comment 1 Zdeněk Pavlas 2012-09-04 04:46:39 EDT
This is intentional, (12/10) means "12th attempt to fetch 10 files in total".  Not just 404s but any mirror failures result in "extra" attempt.  So does the case when a file is downloaded but checksum fails.  In this case the whole file is downloaded again, so +1.

But now I'm a bit less convinced this is the best way to implement this.
Comment 2 Andrew Gunnerson 2012-09-04 13:45:06 EDT
I see. In that case, would it be better to place that information in the transaction summary? Maybe under a heading "Failed to download:"?
Comment 3 Zdeněk Pavlas 2012-09-05 04:00:04 EDT
Fixed in rawhide- failed download/checksum does not increment the finished_files counter.
Comment 4 Zdeněk Pavlas 2012-09-27 06:26:45 EDT
*** Bug 860974 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-09-27 06:56:47 EDT
python-urlgrabber-3.9.1-21.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-urlgrabber-3.9.1-21.fc18
Comment 6 Zdeněk Pavlas 2012-10-01 05:31:02 EDT
*** Bug 859202 has been marked as a duplicate of this bug. ***
Comment 7 Zdeněk Pavlas 2012-10-01 05:32:22 EDT
*** Bug 861562 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.