Bug 861253 - [abrt] liferea-1.8.8-1.fc17: google_source_remove_node: With Google Reader sync, on deleting Search Folder, Process /usr/bin/liferea was killed by signal 11 (SIGSEGV)
[abrt] liferea-1.8.8-1.fc17: google_source_remove_node: With Google Reader sy...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
17
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
abrt_hash:75247bc1e123e9722aa7f11a16c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 19:53 EDT by Ivan Cooper
Modified: 2012-11-23 02:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 22:13:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (3.47 KB, text/plain)
2012-09-27 19:53 EDT, Ivan Cooper
no flags Details
File: environ (1.43 KB, text/plain)
2012-09-27 19:53 EDT, Ivan Cooper
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-27 19:53 EDT, Ivan Cooper
no flags Details
File: backtrace (35.87 KB, text/plain)
2012-09-27 19:53 EDT, Ivan Cooper
no flags Details
File: cgroup (128 bytes, text/plain)
2012-09-27 19:53 EDT, Ivan Cooper
no flags Details
File: maps (48.84 KB, text/plain)
2012-09-27 19:53 EDT, Ivan Cooper
no flags Details
File: dso_list (9.36 KB, text/plain)
2012-09-27 19:53 EDT, Ivan Cooper
no flags Details
File: var_log_messages (1.30 KB, text/plain)
2012-09-27 19:53 EDT, Ivan Cooper
no flags Details
File: open_fds (1.19 KB, text/plain)
2012-09-27 19:53 EDT, Ivan Cooper
no flags Details

  None (edit)
Description Ivan Cooper 2012-09-27 19:53:11 EDT
Description of problem:
This crash is reproducible every time for me, and is quite annoying because it has created bogus "search folders" that I haven't figured out a way to delete from the user interface!

STEPS TO REPRODUCE:

1. Set up Liferea with Google Reader sync
   - Google Reader must contain at least one "Label" or "Folder"

2. Highlight one of the Google Reader folders

3. Select "Subscriptions / New Search Folder..."

4. Click "OK" to create "New Search Folder" as a child of the Google Reader folder

5. Right-click on newly created "New Search Folder" and select "Delete" (perhaps because you didn't mean to create the folder as a child of a GReader folder)

EXPECTED BEHAVIOR:
-- "New Search Folder" is deleted and program continues to operate
-- Also perhaps it should not be possible to create Search Folders as children of GReader folders
-- Also upon starting Liferea and refreshing the Google Reader account, bogus "Search Folders" under GReader categories should be removed

ACTUAL BEHAVIOR:
-- On attempting to delete the Search Folder, Liferea always crashes with SIGSEGV
-- Search folder may or may not be deleted
-- If the Search folder was not deleted on the first attempt, future attempts also fail and the Search Folder cannot be removed at all


Version-Release number of selected component:
liferea-1.8.8-1.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        liferea
crash_function: google_source_remove_node
kernel:         3.5.4-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 google_source_remove_node at google_source.c
: #1 feed_list_view_delete_response_cb at feed_list_view.c
: #2 g_cclosure_marshal_VOID__INTv at gmarshal.c
: #3 _g_closure_invoke_va at gclosure.c
: #9 gtk_real_button_released at gtkbutton.c
: #11 _g_closure_invoke_va at gclosure.c
: #14 gtk_button_button_release at gtkbutton.c
: #16 _gtk_marshal_BOOLEAN__BOXED at gtkmarshalers.c
: #21 gtk_widget_event_internal at gtkwidget.c
: #22 gtk_widget_event at gtkwidget.c
Comment 1 Ivan Cooper 2012-09-27 19:53:14 EDT
Created attachment 618341 [details]
File: core_backtrace
Comment 2 Ivan Cooper 2012-09-27 19:53:16 EDT
Created attachment 618342 [details]
File: environ
Comment 3 Ivan Cooper 2012-09-27 19:53:17 EDT
Created attachment 618343 [details]
File: limits
Comment 4 Ivan Cooper 2012-09-27 19:53:18 EDT
Created attachment 618344 [details]
File: backtrace
Comment 5 Ivan Cooper 2012-09-27 19:53:20 EDT
Created attachment 618345 [details]
File: cgroup
Comment 6 Ivan Cooper 2012-09-27 19:53:21 EDT
Created attachment 618346 [details]
File: maps
Comment 7 Ivan Cooper 2012-09-27 19:53:23 EDT
Created attachment 618347 [details]
File: dso_list
Comment 8 Ivan Cooper 2012-09-27 19:53:24 EDT
Created attachment 618348 [details]
File: var_log_messages
Comment 9 Ivan Cooper 2012-09-27 19:53:26 EDT
Created attachment 618349 [details]
File: open_fds
Comment 10 Yanko Kaneti 2012-09-28 02:32:50 EDT
Don't use Google Reader so I can't fully investigate right now but I've filled an upstream bug
https://sourceforge.net/tracker/?func=detail&aid=3572660&group_id=87005&atid=581684
also mentioned your other crash (bug 861231)
Comment 11 Gianfranco 2012-10-27 07:13:56 EDT
Hi!

Liferea crash happened when I tried to delete a folder containing one blog subscription.

Hope this helps, thank you! :)


backtrace_rating: 4
Package: liferea-1.8.8-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 12 Fedora Update System 2012-11-13 09:33:58 EST
liferea-1.8.10-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/liferea-1.8.10-2.fc17
Comment 13 Fedora Update System 2012-11-13 09:35:32 EST
liferea-1.8.10-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/liferea-1.8.10-2.fc18
Comment 14 Fedora Update System 2012-11-14 21:49:14 EST
Package liferea-1.8.10-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liferea-1.8.10-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18254/liferea-1.8.10-2.fc17
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2012-11-22 22:13:10 EST
liferea-1.8.10-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-11-23 02:57:50 EST
liferea-1.8.10-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.