Bug 861367 - [FEAT REQ] Make fstab entry for brick lvms
[FEAT REQ] Make fstab entry for brick lvms
Status: CLOSED DUPLICATE of bug 850463
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.0
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Sahina Bose
storage-qa-internal@redhat.com
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 07:20 EDT by Anush Shetty
Modified: 2015-01-23 06:31 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-23 06:31:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2012-09-28 07:20:39 EDT
Description of problem: Volume create should make a fstab entry for lvms used as bricks in gluster volumes.


Version-Release number of selected component (if applicable): RHS 2.0


How reproducible: N/A


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Doesn't make an entry in /etc/fstab.


Expected results:

Should create an entry in /etc/fstab

Additional info:
Comment 2 Amar Tumballi 2012-10-21 22:42:37 EDT
can you be more elaborate on this? I personally think glusterfs should not deal with messing around with system files (like /etc/fstab).

Meantime, if its an issue for you in RHS, we can bring a commit hook for create volume to achieve this. Please provide more details.

Challenge is what if the same mount point is used as brick in multiple volume? etc.. etc...
Comment 3 Anush Shetty 2013-01-15 01:03:17 EST
It is just an usability issue. You create a volume and mount the volume. But when a user forgets to make an fstab entry, if the machine reboots for some reason it ends up writing the data somewhere else.
Comment 5 Sahina Bose 2015-01-23 06:31:17 EST

*** This bug has been marked as a duplicate of bug 850463 ***

Note You need to log in before you can comment on or make changes to this bug.