This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 861500 - No network access in %post section
No network access in %post section
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 16:23 EDT by Cole Robinson
Modified: 2013-01-10 01:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 13:14:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Archive of /tmp/*log (88.98 KB, application/x-gzip)
2012-09-28 16:23 EDT, Cole Robinson
no flags Details
anaconda.log (3.76 KB, text/plain)
2012-10-01 19:19 EDT, Cole Robinson
no flags Details
ifcfg.log (56 bytes, text/plain)
2012-10-01 19:20 EDT, Cole Robinson
no flags Details
packaging.log (177.60 KB, text/plain)
2012-10-01 19:21 EDT, Cole Robinson
no flags Details
program.log (36.98 KB, text/plain)
2012-10-01 19:21 EDT, Cole Robinson
no flags Details
storage.log (89.54 KB, text/plain)
2012-10-01 19:21 EDT, Cole Robinson
no flags Details
X.log (55.05 KB, text/plain)
2012-10-01 19:21 EDT, Cole Robinson
no flags Details

  None (edit)
Description Cole Robinson 2012-09-28 16:23:41 EDT
Created attachment 618752 [details]
Archive of /tmp/*log

After install completes but before reboot:

ctrl-alt-f2
# ping google.com # works
# chroot /mnt/sysimage
# ping google.com
ping: unknown host google.com

This worked for all previous Fedora versions, and prevents a kickstart %post section from talking to the network.
Comment 1 Brian Lane 2012-09-28 19:22:09 EDT
Please attach logs as individual text/plain files, not as an archive. It makes it easier to search and examine them.
Comment 2 Jesse Keating 2012-10-01 12:37:36 EDT
Also please attach /mnt/sysimage/etc/resolv.conf  .  You might have network access, just not functional DNS resolution, which may be a side effect of using DHCP for network details.
Comment 3 Cole Robinson 2012-10-01 19:14:30 EDT
Jesse, there is no /mnt/sysimage/etc/resolv.conf. I assume the installer resolve.conf doesn't matter, but here it is:

# cat resolv.conf 
# Generated by NetworkManager
nameserver 192.168.123.1

Rest of the logs coming shortly
Comment 4 Cole Robinson 2012-10-01 19:19:59 EDT
Created attachment 620066 [details]
anaconda.log
Comment 5 Cole Robinson 2012-10-01 19:20:58 EDT
Created attachment 620067 [details]
ifcfg.log
Comment 6 Cole Robinson 2012-10-01 19:21:29 EDT
Created attachment 620068 [details]
packaging.log
Comment 7 Cole Robinson 2012-10-01 19:21:32 EDT
Created attachment 620069 [details]
program.log
Comment 8 Cole Robinson 2012-10-01 19:21:34 EDT
Created attachment 620070 [details]
storage.log
Comment 9 Cole Robinson 2012-10-01 19:21:36 EDT
Created attachment 620071 [details]
X.log
Comment 10 Jesse Keating 2012-10-01 20:38:03 EDT
(In reply to comment #3)
> Jesse, there is no /mnt/sysimage/etc/resolv.conf.

Well there's your problem :)  Could you verify that the network functions from the chroot just without name resolution?  Also can you tell us what networking configuration you used?  I presume it was boot time options?
Comment 11 Cole Robinson 2012-10-02 11:47:09 EDT
Yep, I can ping public IP addresses from the chroot. Networking is only configured with a kickstart which has:

network  --bootproto=dhcp --onboot=on

Nothing was configured interactively. And just to clarify, after booting into the newly installed OS, it has no problem resolving host names.
Comment 12 Radek Vykydal 2012-10-02 12:05:29 EDT
(In reply to comment #10)
> (In reply to comment #3)
> > Jesse, there is no /mnt/sysimage/etc/resolv.conf.
>.

Copying networking configuration to installation root was fixed in master but didn't went in F18 Alpha (bug 853584). So if the cause is actually the missing file, which seems to be so, this should be fixed post F18 Alpha.

(In reply to comment #11)

> Nothing was configured interactively. And just to clarify, after booting
> into the newly installed OS, it has no problem resolving host names.

Here the resolv.conf is generated by NetworkManager.
Comment 13 Jesse Keating 2012-10-02 13:05:27 EDT
You should re-test with the nightly boot.iso to see if the fix works for you.
Comment 14 Cole Robinson 2012-10-02 13:14:11 EDT
Let's just assume this is fixed and I'll reopen if I'm still hitting it.

Jesse, where are the nightly isos? I see http://alt.fedoraproject.org/pub/alt/nightly-composes/ but not sure if that's what you mean. Any nightly tree I can pull from and get a pxe boot image?
Comment 15 Jesse Keating 2012-10-02 13:19:26 EDT
(In reply to comment #14)
> Let's just assume this is fixed and I'll reopen if I'm still hitting it.
> 
> Jesse, where are the nightly isos? I see
> http://alt.fedoraproject.org/pub/alt/nightly-composes/ but not sure if
> that's what you mean. Any nightly tree I can pull from and get a pxe boot
> image?

http://download.fedoraproject.org/pub/fedora/linux/development/18/<arch>/os/images/

Note You need to log in before you can comment on or make changes to this bug.