Bug 861574 - Cannot complete disk partitioning after returning to hub without making any customized changes
Cannot complete disk partitioning after returning to hub without making any c...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
: 864172 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 04:50 EDT by Steve Tyler
Modified: 2012-11-22 21:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:43:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing "Installation Destination" spoke marked as incomplete (63.92 KB, image/png)
2012-09-29 04:50 EDT, Steve Tyler
no flags Details
anaconda.log (2.59 KB, text/plain)
2012-09-29 04:51 EDT, Steve Tyler
no flags Details
program.log (44.92 KB, text/plain)
2012-09-29 04:52 EDT, Steve Tyler
no flags Details
storage.log (87.63 KB, text/plain)
2012-09-29 04:52 EDT, Steve Tyler
no flags Details
storage.state (20.00 KB, application/octet-stream)
2012-09-29 04:53 EDT, Steve Tyler
no flags Details
dmesg (36.41 KB, text/plain)
2012-09-29 04:54 EDT, Steve Tyler
no flags Details
messages (213.14 KB, text/plain)
2012-09-29 04:55 EDT, Steve Tyler
no flags Details
ifcfg.log (641 bytes, text/plain)
2012-09-29 04:56 EDT, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2012-09-29 04:50:46 EDT
Created attachment 618935 [details]
screenshot showing "Installation Destination" spoke marked as incomplete

Description of problem:
After returning from the customized partitioning dialog without making any changes, the "Installation Summary" spoke cannot be selected, but it is marked as incomplete. The other spokes can be selected and the "Quit" button can be clicked.

See attached screenshot.

Version-Release number of selected component (if applicable):
anaconda-0:18.10-1.fc18.x86_64
Fedora-18-Nightly-20120928.14-x86_64-Live-desktop.iso

How reproducible:
Reproduced several times.

Steps to Reproduce:
1. Create disk image file:
   $ qemu-img create f18-test-2.img 10G
2. Start Live CD in a VM:
   $ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/nightly-composes/Fedora-18-Nightly-20120928.14-x86_64-Live-desktop.iso -vga qxl -boot menu=on -usbdevice mouse
3. From the Live CD in a terminal:
   # yum -y update anaconda
4. Click "Install to Hard Drive" on desktop.
5. Proceed to "Installation Summary" and click "Installation Destination".
   Click "Continue".
   Check "Let me customize ..." and click "Continue".
   Click "Back to destination selection".
   Click "Done".

Actual results:
The "Installation Destination" spoke is marked as incomplete, but it cannot be selected. See attached screenshot.
Localization spokes can be selected.
"Quit" can be clicked.

Expected results:
Can click on "Installation Destination" spoke when it is marked as incomplete.

Additional info:
Comment 1 Steve Tyler 2012-09-29 04:51:47 EDT
Created attachment 618936 [details]
anaconda.log
Comment 2 Steve Tyler 2012-09-29 04:52:28 EDT
Created attachment 618937 [details]
program.log
Comment 3 Steve Tyler 2012-09-29 04:52:59 EDT
Created attachment 618938 [details]
storage.log
Comment 4 Steve Tyler 2012-09-29 04:53:58 EDT
Created attachment 618939 [details]
storage.state
Comment 5 Steve Tyler 2012-09-29 04:54:34 EDT
Created attachment 618940 [details]
dmesg
Comment 6 Steve Tyler 2012-09-29 04:55:12 EDT
Created attachment 618941 [details]
messages
Comment 7 Steve Tyler 2012-09-29 04:56:09 EDT
Created attachment 618942 [details]
ifcfg.log
Comment 8 Dave Jones 2012-10-08 17:31:08 EDT
*** Bug 864172 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2012-10-08 20:22:01 EDT
anaconda-18.14-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.14-1.fc18
Comment 10 Fedora Update System 2012-10-09 13:21:51 EDT
Package anaconda-18.14-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.14-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15707/anaconda-18.14-1.fc18
then log in and leave karma (feedback).
Comment 11 Adam Williamson 2012-11-22 21:43:17 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(tested with Beta RC1, confirmed fixed.)

Note You need to log in before you can comment on or make changes to this bug.