Bug 86160 - Anaconda Unhandled Exception while checking for bad blocks
Anaconda Unhandled Exception while checking for bad blocks
Status: CLOSED DUPLICATE of bug 66181
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-14 22:46 EST by Timothy Bowers
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy Bowers 2003-03-14 22:46:59 EST
Description of problem:
While attempting to install RedHat 7.3, anaconda checks for bad blocks
(requested of the installer, as bad blocks are known to exist on my hard
drives).  Upon encountering bad blocks, the installer reports an unhandled
exception and exits.

Version-Release number of selected component (if applicable):
RedHat 7.3

How reproducible:
Every Time

Steps to Reproduce:
1. Begin installation process
2. Ask to check for bad blocks on linux partitions
3.
    
Actual results:
Anaconda performed an unhandled exception (due to multiple bad blocks next to
each other).  This bug has to do with anaconda being unable to handle the output
of the badblocks program.

Expected results:
Anaconda would have checked for bad blocks, and marked them as such.  Once
marking was accomplished, anaconda would have continued to install RedHat.

Additional info:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/anaconda/gui.py", line 529, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 135, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 375, in turnOnFilesystems
    thefsset.checkBadblocks(instPath)
  File "/usr/lib/anaconda/fsset.py", line 1007, in checkBadblocks
    self.badblocksEntry(entry, chroot)
  File "/usr/lib/anaconda/fsset.py", line 984, in badblocksEntry
    entry.fsystem.badblocksDevice(entry, self.progressWindow, chroot)
  File "/usr/lib/anaconda/fsset.py", line 211, in badblocksDevice
    val = (long(l[0]) * 100) / long(l[1])
ValueError: invalid literal for long(): 151296
   151297

Local variables in innermost frame:
childpid: 88
devicePath: /tmp/hdd6
w: <gui.ProgressWindow instance at 8bcd9c0>
fd: 72
num: 151296
   151297/  2393653
s:  
p: (73, 74)
l: ['151296\012   151297', '  2393653']
args: ['/usr/sbin/badblocks', '-vv', '/tmp/hdd6']
self: <fsset.ext3FileSystem instance at 82ea658>
windowCreator: <method InstallInterface.progressWindow of InstallInterface
instance at 86eaab0>
val: 6L
chroot: /mnt/sysimage
entry: <fsset.FileSystemSetEntry instance at 86871a0>


/tmp/syslog:
<4>Linux version 2.4.18-3BOOT (bhcompile@stripples.devel.redhat.com) (gcc
version 2.96 20000731 (Red Hat Linux 7.3 2.96-110)) #1 Thu Apr 18 06:53:28 EDT 2002
<6>BIOS-provided physical RAM map:
<4> BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
<4> BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
<4> BIOS-e820: 00000000000dc000 - 00000000000e0000 (reserved)
<4> BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
<4> BIOS-e820: 0000000000100000 - 0000000014000000 (usable)
<4> BIOS-e820: 00000000ff000000 - 00000000ffffffff (reserved)
<4>On node 0 totalpages: 81920
<4>zone(0): 4096 pages.
<4>zone(1): 77824 pages.
<4>zone(2): 0 pages.
<4>Kernel command line: initrd=initrd.img lang= devfs=nomount ramdisk_size=8192
vga=788 BOOT_IMAGE=vmlinuz auto
<4>Local APIC disabled by BIOS -- reenabling.
<4>Found and enabled local APIC!
<6>Initializing CPU#0
<4>Detected 350.804 MHz processor.
<4>Console: colour VGA+ 80x25
<4>Calibrating delay loop... 699.59 BogoMIPS
<6>Memory: 320696k/327680k available (1092k kernel code, 6596k reserved, 327k
data, 160k init, 0k highmem)
<6>Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
<6>Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
<4>Mount-cache hash table entries: 8192 (order: 4, 65536 bytes)
<6>Buffer cache hash table entries: 32768 (order: 5, 131072 bytes)
<4>Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
<7>CPU: Before vendor init, caps: 0183fbff 00000000 00000000, vendor = 0
<6>CPU: L1 I cache: 16K, L1 D cache: 16K
<6>CPU: L2 cache: 512K
<7>CPU: After vendor init, caps: 0183fbff 00000000 00000000 00000000
<6>Intel machine check architecture supported.
<6>Intel machine check reporting enabled on CPU#0.
<7>CPU:     After generic, caps: 0183fbff 00000000 00000000 00000000
<7>CPU:             Common caps: 0183fbff 00000000 00000000 00000000
<4>CPU: Intel Pentium II (Deschutes) stepping 02
<6>Enabling fast FPU save and restore... done.
<6>Checking 'hlt' instruction... OK.
<6>Checking for popad bug... OK.
<4>POSIX conformance testing by UNIFIX
<4>mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
<4>mtrr: detected mtrr type: Intel
<6>PCI: PCI BIOS revision 2.10 entry at 0xfdb01, last bus=1
<6>PCI: Using configuration type 1
<6>PCI: Probing PCI hardware
<6>PCI: Using IRQ router ALI [10b9/1533] at 00:07.0
<6>PCI: Hardcoded IRQ 14 for device 00:0f.0
<6>Linux NET4.0 for Linux 2.4
<6>Based upon Swansea University Computer Society NET3.039
<4>Initializing RT netlink socket
<4>Starting kswapd
<6>Detected PS/2 Mouse Port.
<4>pty: 256 Unix98 ptys configured
<6>Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI
enabled
<6>ttyS00 at 0x03f8 (irq = 4) is a 16550A
<6>ttyS01 at 0x02f8 (irq = 3) is a 16550A
<4>block: 608 slots per queue, batch=152
<6>Uniform Multi-Platform E-IDE driver Revision: 6.31
<4>ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
<4>ALI15X3: IDE controller on PCI bus 00 dev 78
<6>PCI: Hardcoded IRQ 14 for device 00:0f.0
<4>ALI15X3: chipset revision 32
<4>ALI15X3: not 100% native mode: will probe irqs later
<4>    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:pio, hdb:pio
<4>    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:pio, hdd:pio
<4>hda: SAMSUNG SV0844A, ATA DISK drive
<4>hdb: SAMSUNG WN321620A (2.16 GB), ATA DISK drive
<4>ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
<4>hdc: PCRW804, ATAPI CD/DVD-ROM drive
<4>hdd: ST36422A, ATA DISK drive
<4>ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
<4>ide1 at 0x170-0x177,0x376 on irq 15
<6>hda: 16514064 sectors (8455 MB) w/220KiB Cache, CHS=1027/255/63, (U)DMA
<6>hdb: 4219488 sectors (2160 MB) w/109KiB Cache, CHS=523/128/63, DMA
<6>hdd: 12500460 sectors (6400 MB) w/512KiB Cache, CHS=13228/15/63, (U)DMA
<4>hdc: ATAPI 32X CD-ROM CD-R/RW drive, 2048kB Cache
<6>Uniform CD-ROM driver Revision: 3.12
<4>ide-floppy driver 0.99.newide
<6>Partition check:
<6> hda: hda1
<6> hdb: hdb1
<6> hdd: [PTBL] [778/255/63] hdd1 hdd2
<6>Floppy drive(s): fd0 is 1.44M
<6>FDC 0 is a post-1991 82077
<4>RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
<6>loop: loaded (max 8 devices)
<4>ide-floppy driver 0.99.newide
<6>usb.c: registered new driver usbdevfs
<6>usb.c: registered new driver hub
<6>usb-uhci.c: $Revision: 1.275 $ time 06:55:51 Apr 18 2002
<6>usb-uhci.c: High bandwidth mode enabled
<6>usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
<6>PCI: Found IRQ 12 for device 00:02.0
<6>usb-ohci.c: USB OHCI at membase 0xd480d000, IRQ 12
<6>usb-ohci.c: usb-00:02.0, PCI device 10b9:5237
<6>usb.c: new USB bus registered, assigned bus number 1
<6>hub.c: USB hub found
<6>hub.c: 2 ports detected
<6>usb.c: registered new driver hiddev
<6>usb.c: registered new driver hid
<6>hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
<6>hid-core.c: USB HID support drivers
<6>mice: PS/2 mouse device common for all mice
<6>md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
<6>md: Autodetecting RAID arrays.
<6>md: autorun ...
<6>md: ... autorun DONE.
<6>NET4: Linux TCP/IP 1.0 for NET4.0
<6>IP Protocols: ICMP, UDP, TCP
<6>IP: routing cache hash table of 4096 buckets, 32Kbytes
<6>TCP: Hash tables configured (established 32768 bind 32768)
<6>NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
<5>RAMDISK: Compressed image found at block 0
<6>Freeing initrd memory: 514k freed
<4>EXT2-fs warning: checktime reached, running e2fsck is recommended
<4>VFS: Mounted root (ext2 filesystem).
<6>SCSI subsystem driver Revision: 1.00
<6>Initializing USB Mass Storage driver...
<6>usb.c: registered new driver usb-storage
<6>USB Mass Storage support registered.
<7>ISO 9660 Extensions: RRIP_1991A
<4>Unable to identify CD-ROM format.
<4>VFS: Can't find ext2 filesystem on dev loop(7,0).
<6>PCI: Found IRQ 9 for device 00:12.0
<4>3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
<6>00:12.0: 3Com PCI 3c905B Cyclone 100baseTx at 0xdc00. Vers LK1.1.16
<6>md: raid0 personality registered as nr 2
<6>md: raid1 personality registered as nr 3
<6>raid5: measuring checksumming speed
<4>   8regs     :   580.800 MB/sec
<4>   32regs    :   323.600 MB/sec
<4>   pII_mmx   :   793.600 MB/sec
<4>   p5_mmx    :   828.400 MB/sec
<4>raid5: using function: p5_mmx (828.400 MB/sec)
<6>md: raid5 personality registered as nr 4
<6>Journalled Block Device driver loaded
<6> hdb:
<6> hdb:
<6> hdd: hdd1
<6> hdd: hdd1
<6> hdb: hdb1
<6> hdb: hdb1
<6> hdd: hdd1 hdd2 hdd3 < hdd5 hdd6 >
<6> hdd: hdd1 hdd2 hdd3 < hdd5 hdd6 >
<6> hdd: hdd1 hdd2 hdd3 < hdd5 hdd6 >
<6> hda: hda1
<6> hdb: hdb1
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x40 { UncorrectableError }, LBAsect=8013905, sector=302592
<4>end_request: I/O error, dev 16:46 (hdd), sector 302592
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x40 { UncorrectableError }, LBAsect=8013905, sector=302594
<4>end_request: I/O error, dev 16:46 (hdd), sector 302594
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=8013905, sector=302596
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x40 { UncorrectableError }, LBAsect=8013905, sector=302596
<4>end_request: I/O error, dev 16:46 (hdd), sector 302596
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x40 { UncorrectableError }, LBAsect=8013905, sector=302598
<4>end_request: I/O error, dev 16:46 (hdd), sector 302598
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=8013905, sector=302600
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x40 { UncorrectableError }, LBAsect=8013905, sector=302600
<4>end_request: I/O error, dev 16:46 (hdd), sector 302600
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=8013905, sector=302602
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x40 { UncorrectableError }, LBAsect=8013905, sector=302602
<4>end_request: I/O error, dev 16:46 (hdd), sector 302602
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=8013905, sector=302604
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=8013905, sector=302604
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=8013905, sector=302604
<4>hdd: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=8013905, sector=302604
<4>hdd: DMA disabled
<4>ide1: reset: success
<4>hdd: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
<4>hdd: read_intr: error=0x40 { UncorrectableError }, LBAsect=8013900, sector=302636
<4>end_request: I/O error, dev 16:46 (hdd), sector 302636
<4>hdd: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
<4>hdd: read_intr: error=0x40 { UncorrectableError }, LBAsect=8013902, sector=302638
<4>end_request: I/O error, dev 16:46 (hdd), sector 302638
<4>hdd: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
<4>hdd: read_intr: error=0x40 { UncorrectableError }, LBAsect=8013904, sector=302640
<4>end_request: I/O error, dev 16:46 (hdd), sector 302640
<4>hdd: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
<4>hdd: read_intr: error=0x40 { UncorrectableError }, LBAsect=8013904, sector=302640
<4>end_request: I/O error, dev 16:46 (hdd), sector 302640
<4>hdd: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
<4>hdd: read_intr: error=0x40 { UncorrectableError }, LBAsect=8013904, sector=302640
<4>end_request: I/O error, dev 16:46 (hdd), sector 302640
<4>hdd: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
<4>hdd: read_intr: error=0x40 { UncorrectableError }, LBAsect=8013904, sector=302640
<4>end_request: I/O error, dev 16:46 (hdd), sector 302640
<4>hdd: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
<4>hdd: read_intr: error=0x40 { UncorrectableError }, LBAsect=8013904, sector=302640
<4>end_request: I/O error, dev 16:46 (hdd), sector 302640
<4>hdd: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
<4>hdd: read_intr: error=0x40 { UncorrectableError }, LBAsect=8013904, sector=302640
<4>end_request: I/O error, dev 16:46 (hdd), sector 302640
Comment 1 Michael Fulbright 2003-03-17 14:16:50 EST

*** This bug has been marked as a duplicate of 66181 ***
Comment 2 Timothy Bowers 2003-03-17 19:51:36 EST
This bug was labeled as a duplicate of #66181, yet no solution to the bug has
been presented.  All I am asking is how to load RedHat Linux 7.3 onto my machine
if my hard drive contains bad blocks.  If I turn off bad block checking, the
install goes as normal until it tries to write data to the bad blocks, then
install crashes out and I am left without linux.  If the bug is closed or
resolved, all I ask is HOW it was resolved, and WHAT I can do to properly
install RedHat 7.3 onto my machine.
Comment 3 Michael Fulbright 2003-03-21 11:00:16 EST
The error in this case was due to poor handling of the detection of bad blocks
on the system.  If you want to use the drive despite the detection of bad blocks
then you can just partition the drive and choose not to select the 'check for
bad blocks' option. Understand this is probably going to cause problems later
since the drive appears to be failing.

*** This bug has been marked as a duplicate of 66181 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:52:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.