Bug 861649 - can not recover files from existing backup and can not check to see if backup is valid
can not recover files from existing backup and can not check to see if backup...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: amanda (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Petr Hracek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-29 13:38 EDT by Craig Goodyear
Modified: 2013-03-31 23:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: amanda-3.3.1-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 895706 (view as bug list)
Environment:
Last Closed: 2013-03-31 23:28:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Goodyear 2012-09-29 13:38:25 EDT
Description of problem:
Starting with the update of amanda from version 3.3.0-5.fc17.x86_64
to version 3.3.0-6.fc17.x86_64, amcheckdump and amrecover no longer work.


Version-Release number of selected component (if applicable):
amanda-3.3.0-6.fc17.x86_64
amanda-server-3.3.0-6.fc17.x86_64
amanda-client-3.3.0-6.fc17.x86_64


How reproducible:
Fails every time an attempt is made to run either.

Steps to Reproduce:
1. make a backup with amanda
2. try to run amcheckdump or amrecover 
  
Actual results:

Output from amcheckdump:

[root@blue ~]# su amandabackup -c "/usr/sbin/amcheckdump DailySet1"
"match_disk" is not exported by the Amanda::Util module
 "match_host" is not exported by the Amanda::Util module
 "match_datestamp" is not exported by the Amanda::Util module
 "match_level" is not exported by the Amanda::Util module
Can't continue after import errors at /usr/lib64/perl5/vendor_perl/Amanda/DB/Catalog.pm line 407
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/DB/Catalog.pm line 407.
Compilation failed in require at /usr/lib64/perl5/vendor_perl/Amanda/Recovery/Planner.pm line 208.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Recovery/Planner.pm line 208.
Compilation failed in require at /usr/sbin/amcheckdump line 38.
BEGIN failed--compilation aborted at /usr/sbin/amcheckdump line 38.


============================================================

Output from amrecover:

amrecover> add /etc/amanda/DailySet1
Added dir /amanda/DailySet1/ at date 2012-09-18-01-05-02
Added dir /amanda/DailySet1/ at date 2012-09-29-01-05-01
amrecover> extract

Extracting files using tape drive chg-disk:/mnt/adata/amanda/DailySet1 on host blue.localdomain.
The following tapes are needed: DailySet1-7
                                DailySet1-10

Extracting files using tape drive chg-disk:/mnt/adata/amanda/DailySet1 on host blue.localdomain.
Load tape DailySet1-7 now
Continue [?/Y/n/s/d]? y
amrecover - can't talk to tape server: service amidxtaped: "match_disk" is not exported by the Amanda::Util module
Comment 1 Lukáš Nykrýn 2012-10-16 10:30:21 EDT
fix committed to git -> http://lists.fedoraproject.org/pipermail/scm-commits/2012-October/884930.html -> modified
Comment 2 Fedora Update System 2012-10-17 02:45:49 EDT
amanda-3.3.0-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/amanda-3.3.0-7.fc17
Comment 3 Fedora Update System 2012-10-17 20:31:20 EDT
Package amanda-3.3.0-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing amanda-3.3.0-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16357/amanda-3.3.0-7.fc17
then log in and leave karma (feedback).
Comment 4 Craig Goodyear 2012-10-20 10:02:05 EDT
After updating to amanda-3.3.0-7.fc17.x86_64, amrecover and amcheckdump are still broken.


======================================================================
output from amcheckdump:

[root@blue ~]# su amandabackup -c "/usr/sbin/amcheckdump DailySet1"
amcheckdump: Undefined subroutine &Amanda::Utilc::match_datestamp called at /usr/lib64/perl5/vendor_perl/Amanda/DB/Catalog.pm line 803.


======================================================================
output from amrecover

amrecover> add /etc/amanda/DailySet1
Added dir /amanda/DailySet1/ at date 2012-10-20-01-05-02
amrecover> list
TAPE DailySet1-16:4 LEVEL 0 DATE 2012-10-20-01-05-02
	/amanda/DailySet1
amrecover> extract

Extracting files using tape drive chg-disk:/mnt/adata/amanda/DailySet1 on host blue.localdomain.
The following tapes are needed: DailySet1-16

Extracting files using tape drive chg-disk:/mnt/adata/amanda/DailySet1 on host blue.localdomain.
Load tape DailySet1-16 now
Continue [?/Y/n/s/d]? y
Got no header and data from server, check in amidxtaped.*.debug and amandad.*.debug files on server


======================================================================
output from amidxtaped.20121020064802.debug

Sat Oct 20 06:48:02 2012: amidxtaped: pid 25261 ruid 33 euid 33 version 3.3.0: start at Sat Oct 20 06:48:02 2012
Sat Oct 20 06:48:02 2012: amidxtaped: CTL << FEATURES=ffffffff9efefbffffffffff0f
Sat Oct 20 06:48:02 2012: amidxtaped: CTL << CONFIG=DailySet1
Sat Oct 20 06:48:02 2012: amidxtaped: CTL << LABEL=DailySet1-16:4
Sat Oct 20 06:48:02 2012: amidxtaped: CTL << FSF=4
Sat Oct 20 06:48:02 2012: amidxtaped: CTL << HEADER
Sat Oct 20 06:48:02 2012: amidxtaped: CTL << DEVICE=chg-disk:/mnt/adata/amanda/DailySet1
Sat Oct 20 06:48:02 2012: amidxtaped: CTL << HOST=^blue.localdomain$
Sat Oct 20 06:48:02 2012: amidxtaped: CTL << DISK=^/etc$
Sat Oct 20 06:48:02 2012: amidxtaped: CTL << DATESTAMP=20121020010502
Sat Oct 20 06:48:02 2012: amidxtaped: CTL << END
Sat Oct 20 06:48:02 2012: amidxtaped: pid 25261 ruid 33 euid 33 version 3.3.0: rename at Sat Oct 20 06:48:02 2012
Sat Oct 20 06:48:02 2012: amidxtaped: critical (fatal): Undefined subroutine &Amanda::Utilc::match_host called at /usr/lib64/perl5/vendor_perl/Amanda/DB/Catalog.pm line 795.

amidxtaped: Undefined subroutine &Amanda::Utilc::match_host called at /usr/lib64/perl5/vendor_perl/Amanda/DB/Catalog.pm line 795.

/usr/lib64/libamanda-3.3.0.so(+0x29b17)[0x7ff950333b17]
/usr/lib64/libglib-2.0.so.0(g_logv+0x1e3)[0x394ca4e973]
/usr/lib64/libglib-2.0.so.0(g_log+0x82)[0x394ca4eb22]
/usr/lib64/perl5/vendor_perl/auto/Amanda/MainLoop/libMainLoop.so(+0x4054)[0x7ff94f8bb054]
/usr/lib64/libglib-2.0.so.0[0x394ca483bb]
/usr/lib64/libglib-2.0.so.0(g_main_context_dispatch+0x135)[0x394ca47825]
/usr/lib64/libglib-2.0.so.0[0x394ca47b58]
/usr/lib64/libglib-2.0.so.0(g_main_loop_run+0x72)[0x394ca47f52]
/usr/lib64/perl5/vendor_perl/auto/Amanda/MainLoop/libMainLoop.so(_wrap_run_c+0x63)[0x7ff94f8bb6c3]
/usr/lib64/perl5/CORE/libperl.so(Perl_pp_entersub+0x59c)[0x3fa0eb52bc]
/usr/lib64/perl5/CORE/libperl.so(Perl_runops_standard+0x16)[0x3fa0eac686]
/usr/lib64/perl5/CORE/libperl.so(perl_run+0x3a5)[0x3fa0e4e115]
/usr/bin/perl[0x400d39]
/lib64/libc.so.6(__libc_start_main+0xf5)[0x394aa21735]
/usr/bin/perl[0x400d71]
Comment 5 Fedora Update System 2012-12-20 11:10:15 EST
amanda-3.3.0-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Craig Goodyear 2012-12-20 16:47:32 EST
amanda-3.3.0-7.fc17 has been tested and did not resolve the problem.  See Comment 4.
Comment 7 lav 2013-03-01 01:28:44 EST
amanda-3.3.0-8.fc17.i686 - the problem is still NOT FIXED.
Comment 8 Bartlomiej Solarz-NIesluchowski 2013-03-03 04:21:40 EST
+1 amanda-3.3.0-8.fc17.i686 - the problem is still NOT FIXED

workaroud:
recompile amanda-3.3.2-4.fc19.src.rpm from rawhide:
rpm -Uhv http://ftp.wsisiz.edu.pl/pub/Linux/Fedora/linux/development/rawhide/source/SRPMS/a/amanda-3.3.2-4.fc19.src.rpm
rpmbuild -ba amanda.spec
and after that rpm -Fhv amanda* 

and all works correctly.....
Comment 9 Petr Hracek 2013-03-04 10:44:22 EST
It seems that problem occurs during moving match_*.
Perl part have been moved successfully but relevant C part were not moved.
And therefore some functions are not working properly

http://article.gmane.org/gmane.comp.sysutils.backup.amanda.devel/3410
https://bugzilla.redhat.com/show_bug.cgi?id=752253
Comment 10 Petr Hracek 2013-03-05 03:37:07 EST
Whole discussion about that problem is in following mailing list
http://groups.yahoo.com/group/amanda-hackers/message/6859
Comment 11 Petr Hracek 2013-03-18 04:36:01 EDT
fix commited to git (updated to version 3.3.1) -> http://lists.fedoraproject.org/pipermail/scm-commits/Week-of-Mon-20130311/980813.html -> modified
Comment 12 Fedora Update System 2013-03-18 04:38:57 EDT
amanda-3.3.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/amanda-3.3.1-1.fc17
Comment 13 Fedora Update System 2013-03-19 16:08:53 EDT
Package amanda-3.3.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing amanda-3.3.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4022/amanda-3.3.1-1.fc17
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-03-31 23:28:19 EDT
amanda-3.3.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.