Bug 861710 - [abrt] abrt-addon-ccpp-2.0.13-1.fc18: subprocess.py:1249:_execute_child:OSError: [Errno 2] No such file or directory
[abrt] abrt-addon-ccpp-2.0.13-1.fc18: subprocess.py:1249:_execute_child:OSErr...
Status: CLOSED DUPLICATE of bug 859674
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-09-30 03:30 EDT by Mikhail
Modified: 2012-10-01 03:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-10-01 03:15:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: core_backtrace (384 bytes, text/plain)
2012-09-30 03:30 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2012-09-30 03:30:20 EDT
Version-Release number of selected component:

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        /usr/bin/python -u /usr/bin/abrt-action-analyze-core --core=coredump -o build_ids
kernel:         3.6.0-0.rc7.git1.4.fc18.i686.PAE

:subprocess.py:1249:_execute_child:OSError: [Errno 2] No such file or directory
:Traceback (most recent call last):
:  File "/usr/bin/abrt-action-analyze-core", line 167, in <module>
:    b_ids = extract_info_from_core(core)
:  File "/usr/bin/abrt-action-analyze-core", line 73, in extract_info_from_core
:    eu_unstrip_OUT = Popen(["eu-unstrip","--core=%s" % coredump_name, "-n"], stdout=PIPE, bufsize=-1).communicate()[0]
:  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
:    errread, errwrite)
:  File "/usr/lib/python2.7/subprocess.py", line 1249, in _execute_child
:    raise child_exception
:OSError: [Errno 2] No such file or directory
:Local variables in innermost frame:
:errread: None
:c2pread: 3
:gc_was_enabled: True
:errwrite: None
:shell: False
:errpipe_write: 6
:executable: 'eu-unstrip'
:close_fds: False
:self: <subprocess.Popen object at 0xb748de0c>
:env: None
:cwd: None
:child_exception: OSError(2, 'No such file or directory')
:args: ['eu-unstrip', '--core=coredump', '-n']
:fd: None
:c2pwrite: 4
:data: 'cexceptions\nOSError\np0\n(I2\nS\'No such file or directory\'\np1\ntp2\nRp3\n(dp4\nS\'child_traceback\'\np5\nS\'Traceback (most recent call last):\\n  File "/usr/lib/python2.7/subprocess.py", line 1201, in _execute_child\\n    os.execvp(executable, args)\\n  File "/usr/lib/python2.7/os.py", line 344, in execvp\\n    _execvpe(file, args)\\n  File "/usr/lib/python2.7/os.py", line 380, in _execvpe\\n    func(fullname, *argrest)\\nOSError: [Errno 2] No such file or directory\\n\'\np6\nsb.'
:creationflags: 0
:errpipe_read: 5
:preexec_fn: None
:p2cread: None
:startupinfo: None
:p2cwrite: None
:universal_newlines: False
Comment 1 Mikhail 2012-09-30 03:30:24 EDT
Created attachment 619342 [details]
File: core_backtrace
Comment 2 Jiri Moskovcak 2012-10-01 03:15:12 EDT
$ yum install elfutils should fix this

*** This bug has been marked as a duplicate of bug 859674 ***

Note You need to log in before you can comment on or make changes to this bug.