Bug 859674 - abrt ccpp plugin should require elfutils
Summary: abrt ccpp plugin should require elfutils
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: abrt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 861710 861891 862384 863492 863632 867538 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-23 05:54 UTC by Steve Tyler
Modified: 2013-03-27 00:38 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-27 00:38:56 UTC
Type: Bug


Attachments (Terms of Use)
/var/log/messages (132.59 KB, text/plain)
2012-09-23 05:54 UTC, Steve Tyler
no flags Details
terminal session with "yum update abrt libreport" (23.75 KB, text/plain)
2012-10-07 20:21 UTC, Steve Tyler
no flags Details

Description Steve Tyler 2012-09-23 05:54:29 UTC
Created attachment 615982 [details]
/var/log/messages

Description of problem:
The elfutils package, which contains eu-unstrip, is not installed in a Gnome Desktop install. When eu-unstrip is missing, abrt deletes the dump directory and does not notify the user of the crash. 

Version-Release number of selected component (if applicable):
abrt-2.0.12-1.fc18.x86_64
Fedora-18-Alpha-x86_64-DVD.iso (RC3)

How reproducible:
Always.

Steps to Reproduce:
1. Install the F18 Gnome Desktop from the F18-Alpha-RC3 DVD:
   $ qemu-kvm -m 1024 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Alpha/RC3/Fedora-18-Alpha-x86_64-DVD.iso -vga qxl -boot menu=on
2. # rpm -q elfutils # verify elfutils is not installed
3. # yum update abrt
4. # systemctl restart abrt
5. Generate a core dump:
   $ sleep 1000 &
   $ kill -6 `pidof sleep`
  
Actual results:
From /var/log/messages:
Sep 23 08:27:56 localhost abrtd: Generating backtrace
Sep 23 08:27:58 localhost abrtd: Running eu-unstrip failed
Sep 23 08:27:58 localhost abrtd: 'post-create' on '/var/spool/abrt/ccpp-2012-09-23-05:27:55-1240' exited with 1
Sep 23 08:27:58 localhost abrtd: Corrupted or bad directory '/var/spool/abrt/ccpp-2012-09-23-05:27:55-1240', deleting

Expected results:
abrt retains the dump directory and notifies the user.

Additional info:
Before the last core dump, elfutils-0.155-1.fc18.x86_64 was installed to verify that the user is indeed be notified.

Comment 1 Jiri Moskovcak 2012-09-24 08:11:55 UTC
commit 27e217d2cb15a300b2d3465442aeaf416f5a730f
Author: Jiri Moskovcak <jmoskovc@redhat.com>
Date:   Mon Sep 24 10:11:07 2012 +0200

    spec: added deps on elfutils rhbz#859674

Comment 2 Jiri Moskovcak 2012-10-01 07:15:12 UTC
*** Bug 861710 has been marked as a duplicate of this bug. ***

Comment 3 Jakub Filak 2012-10-01 09:37:36 UTC
*** Bug 861891 has been marked as a duplicate of this bug. ***

Comment 4 Jakub Filak 2012-10-02 19:50:43 UTC
*** Bug 862384 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2012-10-05 10:46:43 UTC
abrt-2.0.14-1.fc17,libreport-2.0.15-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.14-1.fc17,libreport-2.0.15-1.fc17

Comment 6 Fedora Update System 2012-10-06 03:47:10 UTC
Package abrt-2.0.14-1.fc17, libreport-2.0.15-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.14-1.fc17 libreport-2.0.15-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15498/abrt-2.0.14-1.fc17,libreport-2.0.15-1.fc17
then log in and leave karma (feedback).

Comment 7 Jakub Filak 2012-10-07 13:18:45 UTC
*** Bug 863492 has been marked as a duplicate of this bug. ***

Comment 8 Steve Tyler 2012-10-07 20:21:07 UTC
Created attachment 623103 [details]
terminal session with "yum update abrt libreport"

An update to abrt-2.0.14-1 did not pull in elfutils.

# yum update abrt libreport
...
[root@localhost liveuser]# rpm -q elfutils
package elfutils is not installed
[root@localhost liveuser]# rpm -q abrt libreport
abrt-2.0.14-1.fc18.x86_64
libreport-2.0.15-1.fc18.x86_64

Tested in a VM with Fedora-18-Beta-TC2-x86_64-Live-Desktop.iso.

Comment 9 Fedora Update System 2012-10-08 02:24:54 UTC
Package libreport-2.0.15-1.fc17, abrt-2.0.14-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreport-2.0.15-1.fc17 abrt-2.0.14-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15498/abrt-2.0.14-2.fc17,libreport-2.0.15-1.fc17
then log in and leave karma (feedback).

Comment 10 Jakub Filak 2012-10-08 06:40:57 UTC
*** Bug 863632 has been marked as a duplicate of this bug. ***

Comment 11 Jakub Filak 2012-10-08 06:47:10 UTC
Hi Steve,

thank you for testing. I found out yesterday evening that I forgot to add Requires to the spec file. It should be fixed in the second build of abrt-2.0.14

Comment 12 Steve Tyler 2012-10-08 07:09:44 UTC
(In reply to comment #11)
> Hi Steve,
> 
> thank you for testing. I found out yesterday evening that I forgot to add
> Requires to the spec file. It should be fixed in the second build of
> abrt-2.0.14

Thanks for adding the Requires. The update worked perfectly and pulled in elfutils after I stopped trying to install the F17 packages on an F18 system ... :-)

Snippet from /var/log/yum.log:
Oct 08 02:29:24 Updated: abrt-libs-2.0.14-2.fc18.x86_64
Oct 08 02:29:26 Updated: abrt-2.0.14-2.fc18.x86_64
Oct 08 02:29:26 Updated: abrt-addon-kerneloops-2.0.14-2.fc18.x86_64
Oct 08 02:29:27 Updated: abrt-addon-vmcore-2.0.14-2.fc18.x86_64
Oct 08 02:29:28 Updated: abrt-retrace-client-2.0.14-2.fc18.x86_64
Oct 08 02:29:28 Updated: abrt-dbus-2.0.14-2.fc18.x86_64
Oct 08 02:29:29 Updated: abrt-gui-2.0.14-2.fc18.x86_64
Oct 08 02:29:30 Updated: abrt-addon-xorg-2.0.14-2.fc18.x86_64
Oct 08 02:29:31 Updated: abrt-addon-ccpp-2.0.14-2.fc18.x86_64
Oct 08 02:29:31 Updated: abrt-addon-python-2.0.14-2.fc18.x86_64
Oct 08 02:29:32 Updated: abrt-plugin-bodhi-2.0.14-2.fc18.x86_64
Oct 08 02:29:32 Installed: elfutils-0.155-1.fc18.x86_64
Oct 08 02:29:33 Updated: abrt-desktop-2.0.14-2.fc18.x86_64

Comment 13 Steve Tyler 2012-10-17 16:22:03 UTC
elfutils is not on Fedora-18-Beta-TC4-x86_64-DVD.iso.

elfutils is in stable, so it seems like it could be on the DVD:
https://admin.fedoraproject.org/updates/elfutils

After installing, but before rebooting:

# rpm -q abrt libreport elfutils firstboot system-config-date
abrt-2.0.13-1.fc18.x86_64
libreport-2.0.14-1.fc18.x86_64
package elfutils is not installed
firstboot-18.4-1.fc18.x86_64
system-config-date-1.9.67-3.fc18.noarch

Comment 14 Steve Tyler 2012-10-17 16:39:40 UTC
Bug 867538 - elfutils not on DVD; required by abrt

Comment 15 Bill Nottingham 2012-10-17 16:42:59 UTC
*** Bug 867538 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2013-02-05 13:37:49 UTC
abrt-2.1.0-1.fc17,libreport-2.1.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.1.0-1.fc17,libreport-2.1.0-2.fc17

Comment 17 Fedora Update System 2013-03-20 08:41:31 UTC
abrt-2.1.2-1.fc17,libreport-2.1.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.1.2-1.fc17,libreport-2.1.2-1.fc17


Note You need to log in before you can comment on or make changes to this bug.