Bug 861788 - mcedit in version mc-4.8.5-1.fc17.x86_64 handles TAB badly
mcedit in version mc-4.8.5-1.fc17.x86_64 handles TAB badly
Status: CLOSED DUPLICATE of bug 861421
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
17
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-30 14:39 EDT by Michal Ambroz
Modified: 2013-07-02 19:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-01 03:22:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot.png (12.23 KB, image/png)
2012-09-30 14:39 EDT, Michal Ambroz
no flags Details

  None (edit)
Description Michal Ambroz 2012-09-30 14:39:49 EDT
Created attachment 619491 [details]
screenshot.png

Description of problem:
After upgrade of mc to version mc-4.8.5-1.fc17.x86_64 the mcedit handles the TABs in a bad way. Once you press the TAB key on the line the visible cursor is misplaced by 2 chars further to the right than the real typing cursor. This is pretty annoying.


Version-Release number of selected component (if applicable):
mc-4.8.5-1.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
1. update to mc-4.8.5-1.fc17.x86_64
2. run mcedit
3. press TAB
  
Actual results:
cursor is moved by 6 chars to the right and cursor is from this on 2 chars more to the right than the real typing cursor

Expected results:
Cursor should move by 4 (or chars depending on the tabbing configuration) and stay on the focus on the position of typing.

Additional info:
Downgrade to mc-4.8.3-1.fc17.x86_64 works as workaround.
Comment 1 Jindrich Novy 2012-10-01 03:22:12 EDT

*** This bug has been marked as a duplicate of bug 861421 ***

Note You need to log in before you can comment on or make changes to this bug.