Bug 861812 - ValueError: ('invalid size specification', '-150.000000 mb')
ValueError: ('invalid size specification', '-150.000000 mb')
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:b0af0f03a78f054bc0771b027ab...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-30 17:43 EDT by trustthesky
Modified: 2012-11-13 20:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 20:17:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: ifcfg.log (697 bytes, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: anaconda-tb (305.26 KB, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: product (6 bytes, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: type (9 bytes, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: environ (758 bytes, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: storage.log (120.24 KB, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: version (8 bytes, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: program.log (24.14 KB, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: anaconda.log (5.21 KB, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: syslog (121.95 KB, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: packaging.log (1.25 KB, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: cmdline_file (93 bytes, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: release (24 bytes, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details
File: description (1.25 KB, text/plain)
2012-09-30 17:43 EDT, trustthesky
no flags Details

  None (edit)
Description trustthesky 2012-09-30 17:43:00 EDT
Version-Release number of selected component:
anaconda-18.6.8

Additional info:
libreport version: 2.0.12
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-0.rc2.git2.1.fc18.x86_64
Comment 1 trustthesky 2012-09-30 17:43:02 EDT
Created attachment 619511 [details]
File: ifcfg.log
Comment 2 trustthesky 2012-09-30 17:43:07 EDT
Created attachment 619512 [details]
File: anaconda-tb
Comment 3 trustthesky 2012-09-30 17:43:10 EDT
Created attachment 619513 [details]
File: product
Comment 4 trustthesky 2012-09-30 17:43:12 EDT
Created attachment 619514 [details]
File: type
Comment 5 trustthesky 2012-09-30 17:43:14 EDT
Created attachment 619515 [details]
File: environ
Comment 6 trustthesky 2012-09-30 17:43:17 EDT
Created attachment 619516 [details]
File: storage.log
Comment 7 trustthesky 2012-09-30 17:43:19 EDT
Created attachment 619517 [details]
File: version
Comment 8 trustthesky 2012-09-30 17:43:21 EDT
Created attachment 619518 [details]
File: program.log
Comment 9 trustthesky 2012-09-30 17:43:23 EDT
Created attachment 619519 [details]
File: anaconda.log
Comment 10 trustthesky 2012-09-30 17:43:26 EDT
Created attachment 619520 [details]
File: syslog
Comment 11 trustthesky 2012-09-30 17:43:28 EDT
Created attachment 619521 [details]
File: hashmarkername
Comment 12 trustthesky 2012-09-30 17:43:30 EDT
Created attachment 619522 [details]
File: packaging.log
Comment 13 trustthesky 2012-09-30 17:43:32 EDT
Created attachment 619523 [details]
File: cmdline_file
Comment 14 trustthesky 2012-09-30 17:43:34 EDT
Created attachment 619524 [details]
File: release
Comment 15 trustthesky 2012-09-30 17:43:36 EDT
Created attachment 619525 [details]
File: description
Comment 16 Chris Lumens 2012-10-01 10:22:01 EDT
What steps did take that resulted in this traceback?
Comment 17 trustthesky 2012-10-02 01:48:15 EDT
Not quite sure, I was at the partition step of Fedora 18 alpha, and when I changed the size of a partition or told it to propose an automatic configuration, this happened. I noticed that it happened more frequently when all space on the harddisk was occupied with partitions.
Comment 18 Chris Lumens 2012-10-02 09:15:30 EDT
*** Bug 862109 has been marked as a duplicate of this bug. ***
Comment 19 yach 2012-10-02 09:34:19 EDT
Hello,

Bug 862109 that I reported (marked as duplicate) shows the same symptoms but may be slightly different, or could help you find the cause.

As trustthesky said, this bug occured when he tried to change the size of a partition. I did not even had the chance to see the partition editor, the bug occured as soon as I chose the language for the installation program.

I can help giving info if needed.

Thanks
Comment 20 David Lehman 2012-10-04 13:58:34 EDT
trustthesky, you are getting bit by a bug. I should be able to get it fixed in time for the Beta.

yach, your ntfs partition (sdc1) is broken. The partition size (61054MB) is 700MB smaller than the minimum possible size (61783MB) reported by ntfsresize. Basically, it looks like you shrunk the partition too much and now the filesystem is in some inconsistent state. There's nothing the Fedora installer can do to help you with this.
Comment 21 yach 2012-10-04 17:20:01 EDT
Hi David,

Thanks for the reply.
However, I guess there is another problem than the partition size which is already more than 61783 MB (or I am missing something, which is quite possible) :

[yach@cortina ~]$ sudo ntfsresize /dev/sdc1 
ntfsresize v2012.1.15 (libntfs-3g)
Device name        : /dev/sdc1
NTFS volume version: 3.1
Cluster size       : 4096 bytes
Current volume size: 64020804096 bytes (64021 MB)
Current device size: 64020807680 bytes (64021 MB)
New volume size    : 64020804096 bytes (64021 MB)
Nothing to do: NTFS volume size is already OK.
[yach@cortina ~]$ 

I tried this (running fedora 17) then booted on the USB key (fedora 18 nightly) but had the same :
[yach@cortina ~]$ sudo ntfsfix /dev/sdc1 
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
NTFS volume version is 3.1.
NTFS partition /dev/sdc1 was processed successfully.
[yach@cortina ~]$

What should I do to give further valuable information ?
Thanks a lot !
Comment 22 David Lehman 2012-10-04 17:39:46 EDT
(In reply to comment #21)
> Hi David,
> 
> Thanks for the reply.
> However, I guess there is another problem than the partition size which is
> already more than 61783 MB (or I am missing something, which is quite
> possible) :
> 
> [yach@cortina ~]$ sudo ntfsresize /dev/sdc1 
> ntfsresize v2012.1.15 (libntfs-3g)
> Device name        : /dev/sdc1
> NTFS volume version: 3.1
> Cluster size       : 4096 bytes
> Current volume size: 64020804096 bytes (64021 MB)
> Current device size: 64020807680 bytes (64021 MB)
> New volume size    : 64020804096 bytes (64021 MB)
> Nothing to do: NTFS volume size is already OK.
> [yach@cortina ~]$ 

I think I see the problem. ntfsresize is reporting sizes in megabytes, whereas everything else in the installer reports sizes in mebibytes.
Comment 23 Fedora Update System 2012-10-05 16:55:21 EDT
anaconda-18.13-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.13-1.fc18
Comment 24 yach 2012-10-06 06:10:56 EDT
Thanks for the quick bugfix !

I'd like to try it, but as this is in the installer, I guess I should play with kickstart.

I was able to create an ISO with livecd-creator (using the nightly kickstart file), but I don't know how to replace the anaconda version in the repos with the one that you built. Is there some way ?
Comment 25 Fedora Update System 2012-10-08 20:21:33 EDT
anaconda-18.14-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.14-1.fc18
Comment 26 Fedora Update System 2012-10-09 13:21:08 EDT
Package anaconda-18.14-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.14-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15707/anaconda-18.14-1.fc18
then log in and leave karma (feedback).
Comment 27 Adam Williamson 2012-11-05 11:53:18 EST
yach: the fix should be in all the most recent Beta TCs. could you try with one (the latest is TC7) and let us know? Thanks!
Comment 28 yach 2012-11-11 06:24:37 EST
Hi there,

The fix works like a charm :)
This bug can be claused as far as I'm concerned.

Thanks a lot !
Yach
Comment 29 yach 2012-11-11 07:23:52 EST
I forgot to add that I tested it with beta TC8.
Comment 30 Adam Williamson 2012-11-13 20:17:52 EST
Thanks! Closing, as something much newer than the fix for this has been pushed.

Note You need to log in before you can comment on or make changes to this bug.