Bug 862109 - convert ntfsresize sizes in SI to IEC for use by the installer
convert ntfsresize sizes in SI to IEC for use by the installer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:be6c32c7816149f6b9a61d97dfb...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 18:22 EDT by yach
Modified: 2012-11-22 21:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:43:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (563.74 KB, text/plain)
2012-10-01 18:22 EDT, yach
no flags Details
File: environ (882 bytes, text/plain)
2012-10-01 18:22 EDT, yach
no flags Details
File: type (9 bytes, text/plain)
2012-10-01 18:22 EDT, yach
no flags Details
File: ifcfg.log (631 bytes, text/plain)
2012-10-01 18:22 EDT, yach
no flags Details
File: storage.log (215.16 KB, text/plain)
2012-10-01 18:22 EDT, yach
no flags Details
File: version (2 bytes, text/plain)
2012-10-01 18:22 EDT, yach
no flags Details
File: program.log (107.57 KB, text/plain)
2012-10-01 18:22 EDT, yach
no flags Details
File: product (6 bytes, text/plain)
2012-10-01 18:22 EDT, yach
no flags Details
File: anaconda.log (3.99 KB, text/plain)
2012-10-01 18:22 EDT, yach
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-01 18:23 EDT, yach
no flags Details
File: cmdline_file (127 bytes, text/plain)
2012-10-01 18:23 EDT, yach
no flags Details
File: release (33 bytes, text/plain)
2012-10-01 18:23 EDT, yach
no flags Details
File: messages (202.75 KB, text/plain)
2012-10-01 18:23 EDT, yach
no flags Details
File: other involved packages (32 bytes, text/plain)
2012-10-01 18:23 EDT, yach
no flags Details

  None (edit)
Description yach 2012-10-01 18:22:39 EDT
Description of problem:
1. Boot from an USB stick.
2. Click on "live user"
3. Switch to "French" keyboard layout use System settings on the top right menu
3. Click on "Install to Hard Drive"
4. Choose "French" language
5. Click "Continue"

Then the bug occurs.


Version-Release number of selected component:
anaconda-18.8-2.fc18.x86_64

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.0-0.rc6.git0.2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.8 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 79, in _parseSpec
:    raise ValueError("invalid size specification", spec)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 137, in __new__
:    self = Decimal.__new__(cls, value=_parseSpec(spec))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 939, in getFreeSpace
:    Size(spec="%f mb" % fs_free))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 473, in _update_summary
:    free_space = self.storage.getFreeSpace(disks=self.disks)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 461, in _initialize
:    self._update_summary()
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 87, in run
:    threading.Thread.run(self, *args, **kwargs)
:ValueError: ('invalid size specification', '-979.000000 mb')
Comment 1 yach 2012-10-01 18:22:44 EDT
Created attachment 620043 [details]
File: anaconda-tb
Comment 2 yach 2012-10-01 18:22:46 EDT
Created attachment 620044 [details]
File: environ
Comment 3 yach 2012-10-01 18:22:47 EDT
Created attachment 620045 [details]
File: type
Comment 4 yach 2012-10-01 18:22:49 EDT
Created attachment 620046 [details]
File: ifcfg.log
Comment 5 yach 2012-10-01 18:22:51 EDT
Created attachment 620047 [details]
File: storage.log
Comment 6 yach 2012-10-01 18:22:53 EDT
Created attachment 620048 [details]
File: version
Comment 7 yach 2012-10-01 18:22:55 EDT
Created attachment 620049 [details]
File: program.log
Comment 8 yach 2012-10-01 18:22:57 EDT
Created attachment 620050 [details]
File: product
Comment 9 yach 2012-10-01 18:22:59 EDT
Created attachment 620051 [details]
File: anaconda.log
Comment 10 yach 2012-10-01 18:23:00 EDT
Created attachment 620052 [details]
File: hashmarkername
Comment 11 yach 2012-10-01 18:23:02 EDT
Created attachment 620053 [details]
File: cmdline_file
Comment 12 yach 2012-10-01 18:23:04 EDT
Created attachment 620054 [details]
File: release
Comment 13 yach 2012-10-01 18:23:06 EDT
Created attachment 620055 [details]
File: messages
Comment 14 yach 2012-10-01 18:23:08 EDT
Created attachment 620056 [details]
File: other involved packages
Comment 15 Chris Lumens 2012-10-02 09:15:30 EDT

*** This bug has been marked as a duplicate of bug 861812 ***
Comment 16 Fedora Update System 2012-10-05 16:54:58 EDT
anaconda-18.13-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.13-1.fc18
Comment 17 Fedora Update System 2012-10-08 20:21:03 EDT
anaconda-18.14-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.14-1.fc18
Comment 18 Fedora Update System 2012-10-09 13:20:35 EDT
Package anaconda-18.14-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.14-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15707/anaconda-18.14-1.fc18
then log in and leave karma (feedback).
Comment 19 yach 2012-10-13 07:08:20 EDT
Hi,

I tried Fedora 18 Nighlty 20121011.09 x86_64, which is shipped with anaconda-18.14.1-fc18

The bug seems corrected, thank you !

I encounter another bug shortly after (which seems anaconda-related too), but I can't reproduce it every time so I will post it when (if) I have more valuable information.

Greetings
Comment 20 yach 2012-10-14 09:48:56 EDT
The other bug is not a bug but a misunderstanding. Posting this from Fedora 18 nightly, thank you :-)
Comment 21 Adam Williamson 2012-11-22 21:43:50 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(ref comment #19)

Note You need to log in before you can comment on or make changes to this bug.