Bug 861891 - [abrt] abrt-addon-ccpp-2.0.13-1.fc17: subprocess.py:1249:_execute_child:OSError: [Errno 2] Datei oder Verzeichnis nicht gefunden
[abrt] abrt-addon-ccpp-2.0.13-1.fc17: subprocess.py:1249:_execute_child:OSErr...
Status: CLOSED DUPLICATE of bug 859674
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
abrt_hash:3a3e4fa4a40b42f8a2c03169d33...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 05:10 EDT by Nikolas Moraitis
Modified: 2012-10-01 05:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-01 05:37:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (388 bytes, text/plain)
2012-10-01 05:10 EDT, Nikolas Moraitis
no flags Details

  None (edit)
Description Nikolas Moraitis 2012-10-01 05:10:41 EDT
Version-Release number of selected component:
abrt-addon-ccpp-2.0.13-1.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        /usr/bin/python -u /usr/bin/abrt-action-analyze-core --core=coredump -o build_ids
kernel:         3.5.4-2.fc17.x86_64

backtrace:
:subprocess.py:1249:_execute_child:OSError: [Errno 2] Datei oder Verzeichnis nicht gefunden
:
:Traceback (most recent call last):
:  File "/usr/bin/abrt-action-analyze-core", line 167, in <module>
:    b_ids = extract_info_from_core(core)
:  File "/usr/bin/abrt-action-analyze-core", line 73, in extract_info_from_core
:    eu_unstrip_OUT = Popen(["eu-unstrip","--core=%s" % coredump_name, "-n"], stdout=PIPE, bufsize=-1).communicate()[0]
:  File "/usr/lib64/python2.7/subprocess.py", line 679, in __init__
:    errread, errwrite)
:  File "/usr/lib64/python2.7/subprocess.py", line 1249, in _execute_child
:    raise child_exception
:OSError: [Errno 2] Datei oder Verzeichnis nicht gefunden
:
:Local variables in innermost frame:
:errread: None
:c2pread: 3
:gc_was_enabled: True
:errwrite: None
:shell: False
:errpipe_write: 6
:executable: 'eu-unstrip'
:close_fds: False
:self: <subprocess.Popen object at 0x7f00f0d6fcd0>
:env: None
:cwd: None
:child_exception: OSError(2, 'Datei oder Verzeichnis nicht gefunden')
:args: ['eu-unstrip', '--core=coredump', '-n']
:fd: None
:c2pwrite: 4
:data: 'cexceptions\nOSError\np0\n(I2\nS\'Datei oder Verzeichnis nicht gefunden\'\np1\ntp2\nRp3\n(dp4\nS\'child_traceback\'\np5\nS\'Traceback (most recent call last):\\n  File "/usr/lib64/python2.7/subprocess.py", line 1201, in _execute_child\\n    os.execvp(executable, args)\\n  File "/usr/lib64/python2.7/os.py", line 344, in execvp\\n    _execvpe(file, args)\\n  File "/usr/lib64/python2.7/os.py", line 380, in _execvpe\\n    func(fullname, *argrest)\\nOSError: [Errno 2] Datei oder Verzeichnis nicht gefunden\\n\'\np6\nsb.'
:creationflags: 0
:errpipe_read: 5
:preexec_fn: None
:p2cread: None
:startupinfo: None
:p2cwrite: None
:universal_newlines: False
Comment 1 Nikolas Moraitis 2012-10-01 05:10:45 EDT
Created attachment 619695 [details]
File: core_backtrace
Comment 2 Jakub Filak 2012-10-01 05:37:36 EDT
$ yum install elfutils should fix this

*** This bug has been marked as a duplicate of bug 859674 ***

Note You need to log in before you can comment on or make changes to this bug.