Bug 862044 - abrt fails on ppc64 (possibly all secondary arches) due to retrace server not being supported
abrt fails on ppc64 (possibly all secondary arches) due to retrace server not...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
18
ppc64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On: 835618
Blocks: F18Betappc
  Show dependency treegraph
 
Reported: 2012-10-01 13:30 EDT by IBM Bug Proxy
Modified: 2012-11-28 12:23 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 12:23:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2012-10-01 13:30:24 EDT
Description of problem:

abrt-gui (abrt) fails to report crashes because the retrace server is evidently not supported for secondary arches.  When trying to process a crash on ppc64 I get the following error message:

"The release 'fedora-rawhide-ppc64' is not supported by the Retrace server"

I understand the behavior of abrt has changed in F18 but it is unacceptable to ship an important application like this and not have it work with defaults.

Version-Release number of selected component (if applicable):

abrt-2.0.11-2.fc18.ppc64 abrt-gui-2.0.11-2.fc18.ppc64

How reproducible:

force a crash and run abrt

  
Actual results:


Expected results:

abrt should process and report crashes automatically

Additional info:
Comment 1 Karsten Hopp 2012-10-11 11:26:17 EDT
ping ? Could you please add the secondary arches to the retrace server ?
Comment 2 Jiri Moskovcak 2012-10-11 12:37:43 EDT
(In reply to comment #1)
> ping ? Could you please add the secondary arches to the retrace server ?

Unfortunately no, the secondary arches have to use the old way and locally create the backtrace. New version of libreport has been released (to Fedora and REHL7) which has LocalGDB set as fallback option when retrace-server is not supported.

Is this solution enough or is secondary architecture support in retrace server required?
Comment 3 Jiri Moskovcak 2012-10-22 06:33:20 EDT
Is this solution enough or is secondary architecture support in retrace server required?
Comment 4 Dan Horák 2012-10-22 07:42:11 EDT
(In reply to comment #3)
> Is this solution enough or is secondary architecture support in retrace
> server required?

it's fully acceptable for fedora/s390x
Comment 5 Brent Baude 2012-10-23 11:45:18 EDT
Fine for ppc64 too.  Im adding this as a blocker for our beta too.
Comment 8 Brent Baude 2012-10-31 15:19:30 EDT
looks like the new push of libreport fixes things up.  thanks a bunch!

Note You need to log in before you can comment on or make changes to this bug.