Bug 835618 - after retrace server refuses to analyze, the user has no way to use local retracing
after retrace server refuses to analyze, the user has no way to use local ret...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
17
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
: 853641 855136 856844 (view as bug list)
Depends On:
Blocks: ABRTF18 862044
  Show dependency treegraph
 
Reported: 2012-06-26 11:36 EDT by Kamil Páral
Modified: 2012-10-02 03:30 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 03:30:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (39.47 KB, image/png)
2012-06-26 11:36 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-06-26 11:36:21 EDT
Created attachment 594522 [details]
screenshot

Description of problem:
See attached screenshot. After retraced server refused to work, I am advised to use local retracing. But there is no way how to use it. There is no Back button. I can go only forward and that allows me to use Logger component and finish. I have to run abrt-gui, reopen the correct report and choose local debugger. That is sooo... unfriendly workflow.

Version-Release number of selected component (if applicable):
abrt-dbus-2.0.10-4.fc17.x86_64
abrt-libs-2.0.10-4.fc17.x86_64
abrt-addon-ccpp-2.0.10-4.fc17.x86_64
abrt-addon-python-2.0.10-4.fc17.x86_64
abrt-addon-vmcore-2.0.10-4.fc17.x86_64
abrt-desktop-2.0.10-4.fc17.x86_64
abrt-gui-2.0.10-4.fc17.x86_64
abrt-2.0.10-4.fc17.x86_64
abrt-addon-kerneloops-2.0.10-4.fc17.x86_64
abrt-retrace-client-2.0.10-4.fc17.x86_64
Comment 1 Jiri Moskovcak 2012-08-27 07:52:12 EDT
The workflow has been changed significantly and the local retracing is not available in the default configuratio, so there is not going back when the retrace server fails. If you need to use local retracing from abrt-gui you have to go to: Problem->Open problem data which is kind of "advanced users" interface.
Comment 2 Karel Volný 2012-09-05 03:17:54 EDT
(In reply to comment #0)
> I can go only forward and that allows me to use Logger component and finish.

you're sooo lucky - I don't even have the possibility to use logger in this case (exactly, "too large for retrace" ...)

(In reply to comment #1)
> The workflow has been changed significantly and the local retracing is not
> available in the default configuratio, so there is not going back when the
> retrace server fails. If you need to use local retracing from abrt-gui you
> have to go to: Problem->Open problem data which is kind of "advanced users"
> interface.

hm, have you considered the possibility that if the users clicks "Nahlásit" ("Report" I guess) that he really wants to report the problem and not to play "seek and hide" and "guess in which cryptic menu item got the function hidden in this release"?

the current workflow is absolutely incomprehensible for someone who doesn't know how does the reporting work - I was able to report the crash only after reading this bug and then using my knowledge of the previous workflow

the previous workflow was straightforward, and it didn't put any obstactles into beginners way so I do not see any need to make it "less advanced" - except to prevent users from reporting bugs but in that case I don't see the reason for this project to exist ...
Comment 3 Jakub Filak 2012-09-05 04:05:55 EDT
(In reply to comment #2)
We want to make reporting easier and faster. We known that the first version of simplified reporting need some work thus we are looking forward for your feedback.

Please, don't be scared of cryptic menus. We don't expect users are forced to use it. The default workflow must cover almost everything :)

Would you be happy with solution when the reporting window asks you for a permission to perform the failed step locally?
Comment 4 Jakub Filak 2012-09-05 09:30:22 EDT
*** Bug 853641 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Filak 2012-09-14 18:00:16 EDT
commit fefb26701f7f17280e4e8709aa37fa2ab39fd61b
Author: Jakub Filak <jfilak@redhat.com>
Date:   Wed Sep 12 09:54:56 2012 +0200

    rhbz#853641: a more reliable C/C++ analysis event
    
    - the event takes care about asking user for permission to do something
      which needs user's permission (upload coredump, run local analysis)
    - the event starts the local analysis if the remote analysis fails or if
      the remote analysis was rejected by user
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
Comment 6 Jakub Filak 2012-09-18 06:28:37 EDT
*** Bug 856844 has been marked as a duplicate of this bug. ***
Comment 7 Jiri Moskovcak 2012-09-18 06:33:30 EDT
*** Bug 855136 has been marked as a duplicate of this bug. ***
Comment 8 Stuart D Gathman 2012-09-19 21:08:58 EDT
Even when I tell it to use the retrace server, it just prints "initializing root fs" over and over again.  Could you leave instructions for running local analysis while we wait for the update?  When I try what I think is local analysis, the log window jumps to extremely wide (with a VERY long line) and gnome-shell crashes.
Comment 9 Stuart D Gathman 2012-09-21 12:42:32 EDT
I tried selecting opening a crash, and selecting Local GNU Debugger using gnome-fallback (since it crashes gnome-shell).  Again, once it starts downloading and installing the debuginfo RPMs, the log window becomes extremely wide, and metacity (window manager of gnome-fallback) crashes also.
Comment 10 Stuart D Gathman 2012-10-01 16:30:29 EDT
Just installed the update to abrt-2.0.13 - and I was able to locally analyse and submit a bug!  Seems to be fixed.  Close?
Comment 11 Jiri Moskovcak 2012-10-02 03:30:15 EDT
Thanks for the info -> closing.

Note You need to log in before you can comment on or make changes to this bug.