Bug 862149 - SELinux is preventing /usr/libexec/mission-control-5 from using the 'setsched' accesses on a process.
SELinux is preventing /usr/libexec/mission-control-5 from using the 'setsched...
Status: CLOSED DUPLICATE of bug 862156
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:792bf3250dec35e596c8a5987c9...
:
: 984002 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 00:10 EDT by D. Charles Pyle
Modified: 2013-07-16 08:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 04:31:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-02 00:10 EDT, D. Charles Pyle
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-02 00:10 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2012-10-02 00:10:47 EDT
Additional info:
libreport version: 2.0.14
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing /usr/libexec/mission-control-5 from using the 'setsched' accesses on a process.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that mission-control-5 should be allowed setsched access on processes labeled xdm_dbusd_t by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep mission-control /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
:Target Objects                 [ process ]
:Source                        mission-control
:Source Path                   /usr/libexec/mission-control-5
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           telepathy-mission-control-5.13.2-1.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-25.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    2012-09-30 12:50:04 MDT
:Last Seen                     2012-10-01 16:37:27 MDT
:Local ID                      d8a895e3-d12d-42f1-a8a6-724e7d9304ab
:
:Raw Audit Messages
:type=AVC msg=audit(1349131047.56:140): avc:  denied  { setsched } for  pid=3465 comm="mission-control" scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tclass=process
:
:
:type=SYSCALL msg=audit(1349131047.56:140): arch=x86_64 syscall=sched_setscheduler success=yes exit=0 a0=d89 a1=0 a2=7fff51af6490 a3=1 items=0 ppid=1 pid=3465 auid=42 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=3 comm=mission-control exe=/usr/libexec/mission-control-5 subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: mission-control,xdm_dbusd_t,xdm_dbusd_t,process,setsched
:
:audit2allow
:
:#============= xdm_dbusd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t self:process setsched;
:
:audit2allow -R
:
:#============= xdm_dbusd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t self:process setsched;
:
Comment 1 D. Charles Pyle 2012-10-02 00:10:50 EDT
Created attachment 620114 [details]
File: type
Comment 2 D. Charles Pyle 2012-10-02 00:10:51 EDT
Created attachment 620115 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-02 04:31:25 EDT

*** This bug has been marked as a duplicate of bug 862156 ***
Comment 4 Miroslav Grepl 2013-07-16 08:25:54 EDT
*** Bug 984002 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.