Bug 862156 - SELinux is preventing /usr/libexec/mission-control-5 from 'execute' accesses on the file /usr/libexec/mission-control-5.
SELinux is preventing /usr/libexec/mission-control-5 from 'execute' accesses ...
Status: CLOSED DUPLICATE of bug 859782
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:71929ac5c9c35f01cdc3c14eda1...
:
: 862049 862149 862151 862152 862154 862155 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 00:14 EDT by D. Charles Pyle
Modified: 2012-10-02 04:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 04:50:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-02 00:14 EDT, D. Charles Pyle
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-02 00:14 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2012-10-02 00:14:16 EDT
Additional info:
libreport version: 2.0.14
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing /usr/libexec/mission-control-5 from 'execute' accesses on the file /usr/libexec/mission-control-5.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that mission-control-5 should be allowed execute access on the mission-control-5 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep mission-control /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:telepathy_mission_control_exec_t
:                              :s0
:Target Objects                /usr/libexec/mission-control-5 [ file ]
:Source                        mission-control
:Source Path                   /usr/libexec/mission-control-5
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           telepathy-mission-control-5.13.2-1.fc18.x86_64
:Target RPM Packages           telepathy-mission-control-5.13.2-1.fc18.x86_64
:Policy RPM                    selinux-policy-3.11.1-25.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    2012-09-30 12:50:04 MDT
:Last Seen                     2012-10-01 16:37:26 MDT
:Local ID                      4876cc63-ec84-4bfa-b68b-3efcf4954251
:
:Raw Audit Messages
:type=AVC msg=audit(1349131046.806:133): avc:  denied  { execute } for  pid=3465 comm="dbus-daemon" name="mission-control-5" dev="dm-1" ino=3198782 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:telepathy_mission_control_exec_t:s0 tclass=file
:
:
:type=AVC msg=audit(1349131046.806:133): avc:  denied  { read open } for  pid=3465 comm="dbus-daemon" path="/usr/libexec/mission-control-5" dev="dm-1" ino=3198782 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:telepathy_mission_control_exec_t:s0 tclass=file
:
:
:type=AVC msg=audit(1349131046.806:133): avc:  denied  { execute_no_trans } for  pid=3465 comm="dbus-daemon" path="/usr/libexec/mission-control-5" dev="dm-1" ino=3198782 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:telepathy_mission_control_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1349131046.806:133): arch=x86_64 syscall=execve success=yes exit=0 a0=8eb7d0 a1=8e4940 a2=8eb860 a3=7f623a08bad0 items=0 ppid=3464 pid=3465 auid=42 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=3 comm=mission-control exe=/usr/libexec/mission-control-5 subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: mission-control,xdm_dbusd_t,telepathy_mission_control_exec_t,file,execute
:
:audit2allow
:
:#============= xdm_dbusd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t telepathy_mission_control_exec_t:file { read execute open execute_no_trans };
:
:audit2allow -R
:
:#============= xdm_dbusd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t telepathy_mission_control_exec_t:file { read execute open execute_no_trans };
:
Comment 1 D. Charles Pyle 2012-10-02 00:14:19 EDT
Created attachment 620127 [details]
File: type
Comment 2 D. Charles Pyle 2012-10-02 00:14:21 EDT
Created attachment 620128 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-02 04:29:20 EDT
*** Bug 862155 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-10-02 04:29:28 EDT
*** Bug 862154 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Grepl 2012-10-02 04:29:34 EDT
*** Bug 862152 has been marked as a duplicate of this bug. ***
Comment 6 Miroslav Grepl 2012-10-02 04:29:52 EDT
*** Bug 862151 has been marked as a duplicate of this bug. ***
Comment 7 Miroslav Grepl 2012-10-02 04:31:25 EDT
*** Bug 862149 has been marked as a duplicate of this bug. ***
Comment 8 Miroslav Grepl 2012-10-02 04:31:48 EDT
*** Bug 862049 has been marked as a duplicate of this bug. ***
Comment 9 Miroslav Grepl 2012-10-02 04:50:51 EDT

*** This bug has been marked as a duplicate of bug 859782 ***

Note You need to log in before you can comment on or make changes to this bug.