Bug 862161 - :lang=c package required ...suddenly everywhere and it doesn't stop
:lang=c package required ...suddenly everywhere and it doesn't stop
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 862175 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 02:15 EDT by trustthesky
Modified: 2013-06-20 12:49 EDT (History)
14 users (show)

See Also:
Fixed In Version: PackageKit-0.8.4-3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 12:49:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample screenshot of the message (14.43 KB, image/png)
2012-10-02 02:15 EDT, trustthesky
no flags Details

  None (edit)
Description trustthesky 2012-10-02 02:15:43 EDT
Created attachment 620141 [details]
sample screenshot of the message

Picture attached pops up at every application, even the network applet asks for this repeatedly. Chrome asks for it. Gedit asks for it. Every program of any kind asks for this since the latest yum update. And they keep asking again and again..help
Comment 1 Satish Balay 2012-10-02 11:28:54 EDT
I see the same issue on my x86_64 f18 vm
Comment 2 Eric Paris 2012-10-02 15:09:00 EDT
reassigning to package kit.  no idea if it is related.  But I'm certain it isn't the 0ad-data package and I did update packagekit yesterday.
Comment 3 Ricardo Arguello 2012-10-02 22:47:45 EDT
*** Bug 862175 has been marked as a duplicate of this bug. ***
Comment 4 Owen Taylor 2012-10-03 15:13:39 EDT
Following patch is bogus:

commit 677e8ab4086208f06b988d98b247aeb53e554638
Author: William Jon McCann <jmccann@redhat.com>
Date:   Tue Sep 11 00:21:34 2012 -0400

    Don't leak pango languages
    
    Signed-off-by: Richard Hughes <richard@hughsie.com>

diff --git a/contrib/gtk-module/pk-gtk-module.c b/contrib/gtk-module/pk-gtk-module.c
index 8145848..2c93f02 100644
--- a/contrib/gtk-module/pk-gtk-module.c
+++ b/contrib/gtk-module/pk-gtk-module.c
@@ -252,8 +252,7 @@ pk_pango_fc_font_map_load_fontset (PangoFontMap *font_map,
         * code instead of "xx"... */
        if (G_LIKELY (language == last_language) ||
            language == NULL ||
-           language == pango_language_from_string ("C") ||
-           language == pango_language_from_string ("xx"))
+           pango_language_matches (language, "C;xx"))
                return fontset;
 
        if (G_UNLIKELY (!seen_languages))

The old code didn't leak - pango_language_from_string() doesn't return memory that needs to be free - and the new code doesn't work since it would have to be:

 pango_language_matches (language, "c;xx")

to work - pango_language_matches() doesn't canonicalize the pattern.
Comment 5 Owen Taylor 2012-10-03 15:20:18 EDT
Revision - old code did leak, but only because pango_language_from_string() is buggy.
Comment 6 Paulo Andrade 2012-10-03 15:25:13 EDT
(In reply to comment #2)
> reassigning to package kit.  no idea if it is related.  But I'm certain it
> isn't the 0ad-data package and I did update packagekit yesterday.

0ad-data should be Component #1, and 0ad Component #0, I think
I will have some fun time with incorrectly assigned bug reports
(and should do some triaging), until someone beats me with
a package name coming before 0ad :-)
Comment 7 Owen Taylor 2012-10-03 15:34:33 EDT
(In reply to comment #5)
> Revision - old code did leak, but only because pango_language_from_string()
> is buggy.

Or, not - I was confused by my own code - pango_language_from_string() looks fine.
Comment 8 Fedora Update System 2012-10-04 07:10:58 EDT
PackageKit-0.8.4-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/PackageKit-0.8.4-3.fc18
Comment 9 Fedora Update System 2012-10-04 13:49:51 EDT
Package PackageKit-0.8.4-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PackageKit-0.8.4-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15375/PackageKit-0.8.4-3.fc18
then log in and leave karma (feedback).
Comment 10 Peter McNabb 2012-10-11 15:47:29 EDT
PackageKit-0.8.4-3.fc18 fixed this issue for me

Note You need to log in before you can comment on or make changes to this bug.