Bug 862264 - gnome-shell-extension-pomodoro does not work with the current version of Gnome Shell
gnome-shell-extension-pomodoro does not work with the current version of Gnom...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-pomodoro (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Mat Booth
Fedora Extras Quality Assurance
:
: 808838 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 09:42 EDT by HeCSa
Modified: 2012-12-01 03:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-01 03:41:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description HeCSa 2012-10-02 09:42:35 EDT
Description of problem:
I installed gnome-shell-extension-pomodoro.noarch from the fedora repo. 
When trying to activate it via "Advanced Settings", I receive a warning message telling me that "Extension does not support shell version".

Version-Release number of selected component (if applicable):
Name        : gnome-shell-extension-pomodoro
Arch        : noarch
Version     : 0
Release     : 0.3.git13030cd.fc17
Size        : 36 k
Repo        : installed
From repo   : fedora
Summary     : A gnome-shell extension for the pomodoro technique
URL         : https://github.com/codito/gnome-shell-pomodoro
License     : GPLv3+
Description : This extension helps you to work with the pomodoro technique here.
            : It provides a countdown timer in the gnome-shell and keeps track
            : of completed 25 minute cycles.


How reproducible:
yum install gnome-shell-extension-pomodoro.noarch
Open Advanced Settings, try to enable the applet, and the warning happens.

Steps to Reproduce:
1. yum install gnome-shell-extension-pomodoro.noarch
2. Open Advanced Settings, try to enable the applet ("Pomodoro Extension").
3. The applet cannto be enabled, and the warning message tells that "Extension does not support shell version".
  
Actual results:
Shell extension not enabled because of its version and gnome shell version.

Expected results:
To enable in the current gnome shell version.

Additional info:
Comment 1 Mat Booth 2012-11-16 06:38:31 EST
Hi, it looks like this package has been left alone for a little while now. If the maintainers have no objections, I would like to fix this package for Fedora 17 and 18. (I am a provenpackager, but I don't normally touch packages outside the Java eco-system.)

I will try and find some time to fix this over the weekend, again if there are no objections from the maintainers.
Comment 2 Fabian Affolter 2012-11-16 14:55:23 EST
Thanks for your offer. Please go ahead and fix it.
Comment 3 Mat Booth 2012-11-21 06:03:35 EST
*** Bug 808838 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2012-11-21 06:07:24 EST
gnome-shell-extension-pomodoro-0.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gnome-shell-extension-pomodoro-0.6-1.fc17
Comment 5 Fedora Update System 2012-11-21 22:53:14 EST
Package gnome-shell-extension-pomodoro-0.6-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-extension-pomodoro-0.6-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18774/gnome-shell-extension-pomodoro-0.6-1.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-12-01 03:41:49 EST
gnome-shell-extension-pomodoro-0.6-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.