Bug 862295 - Improper workflow when back is selected on launch screen
Improper workflow when back is selected on launch screen
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: beta4
: ---
Assigned To: Imre Farkas
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 10:37 EDT by james labocki
Modified: 2016-09-20 01:03 EDT (History)
8 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.18-1.el6cf
Doc Type: Bug Fix
Doc Text:
There was an improper work flow when "Back" was selected on the launch screen. The "Back" button was not aware of the navigation context and does not return the user appropriately. This bug fixes the back link on deployments#launch_new for RPM installations and now a proper workflow when the "Back" button is selected is in place.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:22:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen1.png (73.49 KB, image/png)
2012-10-02 10:37 EDT, james labocki
no flags Details
screen3.png (69.25 KB, image/png)
2012-10-02 10:38 EDT, james labocki
no flags Details
screen1 (77.16 KB, image/png)
2012-10-10 20:01 EDT, Shveta
no flags Details
screen2 (52.17 KB, image/png)
2012-10-10 20:02 EDT, Shveta
no flags Details
screen3 (161.68 KB, image/png)
2012-10-10 20:02 EDT, Shveta
no flags Details
cluster_selection (60.09 KB, image/png)
2012-10-15 16:10 EDT, Shveta
no flags Details

  None (edit)
Description james labocki 2012-10-02 10:37:28 EDT
Description of problem:

There is an improper workflow when "back" is select on the launch screen if a user navigates to launch an application blueprint via the application blueprint detail screen.

How reproducible:

1. Select Administer - Content - (Choose Catalog) - (Choose Application Blueprint). You will see screen1.png.
2. Select "Launch". You will see screen2.png
3. Select "Back". You will see screen3.png when you should see screen1.png.


Version-Release number of selected component (if applicable):
1.1 beta release (09.18.12 puddle)


Expected results:
"Back" button should be aware of which context a user has navigated to the page (via monitor or administer tabs) and return the user appropriately.
Comment 1 james labocki 2012-10-02 10:37:43 EDT
Created attachment 620320 [details]
screen1.png
Comment 3 james labocki 2012-10-02 10:38:16 EDT
Created attachment 620322 [details]
screen3.png
Comment 5 Dave Johnson 2012-10-02 11:26:24 EDT
This seems related to bug 860428
Comment 6 Imre Farkas 2012-10-03 09:12:29 EDT
#860428 seems to be a bug against a correct behaviour. Previously the launch button on deployables#show redirected to second page of the workflow instead of the first one. It was fixed with #859503.

As for this issue, Conductor just simply wasn't aware from where the user arrived to deployments#launch_new.
Pull request sent for to: https://github.com/aeolusproject/conductor/pull/93
Comment 7 Imre Farkas 2012-10-03 11:11:52 EDT
The above pull request is only partially fixing it, so switching back to on_dev
Comment 8 Imre Farkas 2012-10-04 07:36:02 EDT
Pull request containing the fix for RPM installations too: https://github.com/aeolusproject/conductor/pull/97
Comment 9 Matt Wagner 2012-10-04 16:38:29 EDT
I have merged this patch to master.

There is a conflict moving it over to 1.1, which I am investigating now.
Comment 10 Matt Wagner 2012-10-04 17:00:33 EDT
Conflict issues were easily resolved.

Now on 1.1:
commit d3b12322d5d26e06e891f3624317f7e8367b33d9
Author: Imre Farkas <ifarkas@redhat.com>
Date:   Thu Oct 4 13:31:45 2012 +0200

    BZ #862295: fix back link on deployments#launch_new for RPM installations
    
    https://bugzilla.redhat.com/show_bug.cgi?id=862295
    (cherry picked from commit c640ee4742c1b1b6e75a19a2ab259c383be59880)
Comment 11 Imre Farkas 2012-10-05 05:25:41 EDT
Conflicts were caused because the first commit was missing, so pushed it also to 1.1. Even if I resolved the conflicts, somehow it remained in the commit message.

commit 291543126ee689ae6855bbe8b357bcb4e25b740c
Author: Imre Farkas <ifarkas@redhat.com>
Date:   Wed Oct 3 15:04:12 2012 +0200

    BZ #862295: fix back link on deployments#launch_new
    
    https://bugzilla.redhat.com/show_bug.cgi?id=862295
    (cherry picked from commit f1d7baf24af51c12eb2cc3bb68537bb142559719)
    
    Conflicts:
        src/app/controllers/deployments_controller.rb
        src/app/views/deployables/show.html.haml
Comment 13 Shveta 2012-10-10 20:01:34 EDT
Tested in Puddle 4 .
Flow seems to be correct now.
Catalog-- App BP --Launch
Screen1.png shows , Next sceen2.png shows 
Hit Back Button screen2.png comes , Hit Back again screen3.png shows



rpm -qa|grep aeolus
aeolus-conductor-0.13.18-1.el6cf.noarch
aeolus-conductor-daemons-0.13.18-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-all-0.13.18-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-doc-0.13.18-1.el6cf.noarch
rubygem-aeolus-cli-0.7.4-1.el6cf.noarch
Comment 14 Shveta 2012-10-10 20:01:58 EDT
Created attachment 625243 [details]
screen1
Comment 15 Shveta 2012-10-10 20:02:18 EDT
Created attachment 625244 [details]
screen2
Comment 16 Shveta 2012-10-10 20:02:43 EDT
Created attachment 625245 [details]
screen3
Comment 17 Shveta 2012-10-15 16:10:16 EDT
Re-Opening this bug ..
Seeing it again ..



rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.18-1.el6cf.noarch
rubygem-aeolus-cli-0.7.4-1.el6cf.noarch
aeolus-conductor-doc-0.13.18-1.el6cf.noarch
aeolus-all-0.13.18-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-conductor-0.13.18-1.el6cf.noarch
Comment 18 Shveta 2012-10-15 16:10:42 EDT
Created attachment 627669 [details]
cluster_selection
Comment 19 Imre Farkas 2012-10-16 03:51:23 EDT
Cloud you be more specific, please? What are you seeing here? I am unable to reproduce the issue. Your attachment seems to be irrelevant to this bug as it is not showing to where does the back button redirected you.
Comment 20 Shveta 2012-10-16 12:35:03 EDT
I am Sorry it is https://bugzilla.redhat.com/show_bug.cgi?id=860428 
which i wanted to Re-open this one works .
Comment 22 errata-xmlrpc 2012-12-04 10:22:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.