Bug 862371 - Anaconda fails to upgrade from F17 to F18 [NEEDINFO]
Anaconda fails to upgrade from F17 to F18
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 14:08 EDT by Germano Massullo
Modified: 2014-02-05 17:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 17:48:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
wwoods: needinfo? (rhughes)


Attachments (Terms of Use)
screen1 (34.97 KB, image/png)
2012-10-02 14:08 EDT, Germano Massullo
no flags Details
screen2 (38.51 KB, image/png)
2012-10-02 14:08 EDT, Germano Massullo
no flags Details

  None (edit)
Description Germano Massullo 2012-10-02 14:08:37 EDT
Created attachment 620418 [details]
screen1

Description of problem:
I installed a VirtualBOX virtual machine to test the upgrade with preupgrade from Fedora 17 KDE to Fedora 18 KDE.
When I rebooted and Anaconda started, after a few moments the screen entered into graphic mode, then I got an error message "An error had occurred" and immediately a complete black screen.
I cannot paste here error messages since I can't copy messages from the virtual machine, then I have to take screenshots.
If I press ctrl+alt+f1 I get messages like in screenshot n.1
If I press ctrl+alt+f3 I get messages like in screenshot n.2

Version-Release number of selected component (if applicable):
Don't know how to get infos about versions.
Comment 1 Germano Massullo 2012-10-02 14:08:56 EDT
Created attachment 620419 [details]
screen2
Comment 2 Jesse Keating 2012-10-02 14:20:09 EDT
Anaconda won't be used for upgrades, a new tool is being worked on.
Comment 3 Steve Tyler 2012-10-14 23:37:32 EDT
(In reply to comment #1)
> Created attachment 620419 [details]
> screen2

Thanks for posting these screenshots. The last two lines read:

ERR anaconda: Error running metacity: SIGCHLD caught when trying to start the X server.
ERR anaconda: Problems running the window manager: Error running metacity: SIGCHLD caught when trying to start the X server.

Those are identical to the last two lines of anaconda.log attached to:
Bug 864547 - occasional black screen after installation is finished
Comment 4 Germano Massullo 2012-10-20 13:45:43 EDT
I tried again with a fresh F17 virtual machine and I get same errors
Comment 5 Thomas Oulevey 2012-11-27 17:14:55 EST
I have the same error on my Thinkpad T410s with Nvidia graphic card.
Comment 6 Steve Tyler 2012-11-28 22:05:26 EST
The new upgrade tool is called FedUp:

"FedUp (FEDora UPgrader) is the name of a new system for upgrading Fedora installs starting with Fedora 18. It will be replacing all of the currently recommended upgrade methods (PreUpgrade and DVD) that have been used in previous Fedora releases."

https://fedoraproject.org/wiki/FedUp

$ sudo repoquery fedup --releasever=18
fedup-0:0.7.1-1.fc18.noarch

fedup is going to need testing ...
Comment 7 Germano Massullo 2012-11-29 09:35:30 EST
Just created bugreport #881764 for fedup.
Do you think we should close this bugreport, since now fedup is the official upgrade method?
Comment 8 Steve Tyler 2012-11-29 12:36:59 EST
Thanks for your report:
Bug 881764 - fedup F17 to F18 upgrade failure 

preupgrade is installed from both the F17 Live CD and the F17 DVD, so users are likely to be trying to use preupgrade to upgrade from F17 to F18.

Will: Users shouldn't be wasting their time trying to use preupgrade when it isn't going to work. Is there a plan to obsolete preupgrade?
Comment 9 Will Woods 2012-11-30 17:40:59 EST
Yeah, the package should probably get retired.

PackageKit requires preupgrade; we'll need to make sure fedup provides whatever PackageKit needs.

Once that's settled we can remove the 'Requires: preupgrade' from PackageKit and add:
  
  Obsoletes: preupgrade < %{preupgrade_final_ver}

to fedup, and (if I'm reading [1] correctly) that will do it.

So, Richard - do you know what PackageKit needs from preupgrade?

[1] https://fedoraproject.org/wiki/Upgrade_paths_%E2%80%94_renaming_or_splitting_packages
Comment 10 Fedora End Of Life 2013-12-21 10:07:16 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 11 Fedora End Of Life 2014-02-05 17:48:54 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.