Bug 862388 - kdelibs: multilib conflict /usr/share/doc/HTML/en/sonnet/index.cache.bz2
kdelibs: multilib conflict /usr/share/doc/HTML/en/sonnet/index.cache.bz2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 867848
  Show dependency treegraph
 
Reported: 2012-10-02 14:58 EDT by Jacek Pawlyta
Modified: 2012-12-20 10:55 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 867848 (view as bug list)
Environment:
Last Closed: 2012-12-20 10:55:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacek Pawlyta 2012-10-02 14:58:52 EDT
Description of problem:
kdelibs update from kde-testing repo is not possible 

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install kde-testing and kde-i386-testing repo
2. run yum update kdelibs
  
Actual results:
Transaction Check Error:
  file /usr/share/doc/HTML/en/sonnet/index.cache.bz2 conflicts between attempted installs of kdelibs-6:4.9.2-2.fc17.i686 and kdelibs-6:4.9.2-2.fc17.x86_64


Expected results:
kdelibs updated
Comment 1 Rex Dieter 2012-10-02 15:20:01 EDT
Seems our current .spec hack to avoid this:

# fix Sonnet documentation multilib conflict
bunzip2 %{buildroot}%{_kde4_docdir}/HTML/en/sonnet/index.cache.bz2
sed -i -e 's!<a name="id[0-9]*"></a>!!g' %{buildroot}%{_kde4_docdir}/HTML/en/sonnet/index.cache
bzip2 -9 %{buildroot}%{_kde4_docdir}/HTML/en/sonnet/index.cache

is no longer sufficient. :(
Comment 2 Rex Dieter 2012-10-02 15:28:09 EDT
can't reproduce on f18, kdelibs-4.9.2-3.fc18.i686 and kdelibs-4.9.2-3.fc18.x86_64 co-install nicely.

Breaking out f17 laptop...
Comment 3 Rex Dieter 2012-10-02 15:40:55 EDT
ok, on f17 builds index.cache indeed is slightly different, one has
<a name=idm436...
the other
<a name=idm764...
Comment 4 Julian Sikorski 2012-10-04 01:30:37 EDT
file /usr/share/doc/HTML/en/kcontrol/kresources/index.cache.bz2 conflicts between attempted installs of kdepimlibs-4.9.2-1.fc17.i686 and kdepimlibs-4.9.2-1.fc17.x86_64

kdepimlibs suffers from the same issue.
Comment 5 Fedora Update System 2012-10-04 14:11:54 EDT
kdepimlibs-4.9.2-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kdepimlibs-4.9.2-2.fc17
Comment 6 Fedora Update System 2012-10-04 14:14:16 EDT
kdelibs-4.9.2-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kdelibs-4.9.2-5.fc17
Comment 7 Fedora Update System 2012-10-04 20:53:59 EDT
Package kdelibs-4.9.2-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdelibs-4.9.2-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15396/kdelibs-4.9.2-5.fc17
then log in and leave karma (feedback).
Comment 8 Jacek Pawlyta 2012-10-05 02:08:21 EDT
Confirming, the new package fixes it - I used kde-testing repo
Comment 9 Fedora Update System 2012-10-06 07:46:56 EDT
kdepimlibs-4.9.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kdepimlibs-4.9.2-2.fc18
Comment 10 Fedora Update System 2012-10-06 07:48:44 EDT
kdelibs-4.9.2-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kdelibs-4.9.2-5.fc18
Comment 11 Fedora Update System 2012-10-10 20:59:38 EDT
kdepimlibs-4.9.2-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-12-20 10:55:30 EST
kdepimlibs-4.9.2-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.