Bug 862519 - Fedora18:Alpha:Installation is blocked with Unknown error occured, if system is configured with software raid earlier
Fedora18:Alpha:Installation is blocked with Unknown error occured, if system ...
Status: CLOSED DUPLICATE of bug 862073
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
ppc64 All
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 02:31 EDT by IBM Bug Proxy
Modified: 2012-10-03 10:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 10:23:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
miz04-install-log.txt (281.60 KB, text/plain)
2012-10-03 02:32 EDT, IBM Bug Proxy
no flags Details
install-log1.txt (251.23 KB, image/png)
2012-10-03 02:32 EDT, IBM Bug Proxy
no flags Details
install-log4.png (236.90 KB, image/png)
2012-10-03 02:32 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 85609 None None None 2012-10-03 02:31:57 EDT

  None (edit)
Description IBM Bug Proxy 2012-10-03 02:31:56 EDT
Problem Description
-------------------------------
While doing Fedroa 18 ppc64 alpha VNC type installation on P7 LPAR , installation got blocked with unknown error occurred on "Installation summary " screen (see attached screenshot install-log1.txt).

Note that I am able to install other LPARS using same repo , but the current system where this issue got hit is currently having RAID configuration on top of LVM with Fedora17 installed.I looked into reason tab on anaconda VNC log screen (see attached screen shot install-log4.txt) , it says  " AttributeError:'MdRaidArrayDevice' Object has no attribute 'isMagic' "


--- Details information previous state of the system ---

System was earlier installed with Fedora17 and was having LVM volumes on top of RAID5 , which is on top of multipath disks.
Here are the details of the state of the system before F18 installation test:

[root@miz04 ~]# uname -a
Linux miz04.austin.ibm.com 3.3.4-5.fc17.ppc64 #1 SMP Mon May 14 10:18:37 MST 2012 ppc64 ppc64 ppc64 GNU/Linux

[root@miz04 ~]# pvscan 
  Found duplicate PV q50if4DipE96H1Flq9TrBKkm41yDS93b: using /dev/sdj1 not /dev/sdb1
  PV /dev/sdj1   VG myvg       lvm2 [10.00 GiB / 9.98 GiB free]
  PV /dev/sda3   VG vg_miz04   lvm2 [20.50 GiB / 0    free]
  Total: 2 [30.50 GiB] / in use: 2 [30.50 GiB] / in no VG: 0 [0   ]
[root@miz04 ~]# vgscan 
  Reading all physical volumes.  This may take a while...
  Found duplicate PV q50if4DipE96H1Flq9TrBKkm41yDS93b: using /dev/sdj1 not /dev/sdb1
  Found volume group "myvg" using metadata type lvm2
  Found volume group "vg_miz04" using metadata type lvm2
[root@miz04 ~]# lvscan 
  Found duplicate PV q50if4DipE96H1Flq9TrBKkm41yDS93b: using /dev/sdj1 not /dev/sdb1
  ACTIVE            '/dev/myvg/myvol1' [12.00 MiB] inherit
  ACTIVE            '/dev/vg_miz04/lv_swap' [3.91 GiB] inherit
  ACTIVE            '/dev/vg_miz04/lv_root' [16.59 GiB] inherit
[root@miz04 ~]# cat /proc/mdstat
Personalities : [raid6] [raid5] [raid4] 
md0 : active raid6 sdk[1] sdl[2] sde[3] sdb[0]
      31452672 blocks super 1.2 level 6, 512k chunk, algorithm 2 [5/4] [UUUU_]
      
unused devices: <none>
[root@miz04 ~]#  mdadm --detail /dev/md0
/dev/md0:
        Version : 1.2
  Creation Time : Fri Jun  1 07:17:23 2012
     Raid Level : raid6
     Array Size : 31452672 (30.00 GiB 32.21 GB)
  Used Dev Size : 10484224 (10.00 GiB 10.74 GB)
   Raid Devices : 5
  Total Devices : 4
    Persistence : Superblock is persistent

    Update Time : Thu Sep 27 18:31:25 2012
          State : clean, degraded 
 Active Devices : 4
Working Devices : 4
 Failed Devices : 0
  Spare Devices : 0

         Layout : left-symmetric
     Chunk Size : 512K

           Name : miz04.austin.ibm.com:0  (local to host miz04.austin.ibm.com)
           UUID : 3b7a77c3:74369530:dd64485b:d1f8e943
         Events : 6812

    Number   Major   Minor   RaidDevice State
       0       8       16        0      active sync   /dev/sdb
       1       8      160        1      active sync   /dev/sdk
       2       8      176        2      active sync   /dev/sdl
       3       8       64        3      active sync   /dev/sde
       4       0        0        4      removed


I rebooted the system and went for fedora 18 installation , where I noticed installation could not proceed due to "due to unknown error occurred "

Attached full installation console log "miz04-install-log.txt"

Thanks...
Manas
Comment 1 IBM Bug Proxy 2012-10-03 02:32:20 EDT
Created attachment 620630 [details]
miz04-install-log.txt
Comment 2 IBM Bug Proxy 2012-10-03 02:32:39 EDT
Created attachment 620631 [details]
install-log1.txt
Comment 3 IBM Bug Proxy 2012-10-03 02:32:54 EDT
Created attachment 620632 [details]
install-log4.png
Comment 4 Chris Lumens 2012-10-03 10:23:29 EDT

*** This bug has been marked as a duplicate of bug 862073 ***

Note You need to log in before you can comment on or make changes to this bug.