Bug 862632 - NameError: global name 'size_func_kwargs' is not defined
NameError: global name 'size_func_kwargs' is not defined
Status: CLOSED DUPLICATE of bug 862006
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:1a89fd7d43e741def1b7573ecc3...
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-10-03 07:56 EDT by Kamil Páral
Modified: 2012-10-03 10:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 10:20:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (276.88 KB, text/plain)
2012-10-03 07:56 EDT, Kamil Páral
no flags Details
File: product (6 bytes, text/plain)
2012-10-03 07:56 EDT, Kamil Páral
no flags Details
File: type (9 bytes, text/plain)
2012-10-03 07:57 EDT, Kamil Páral
no flags Details
File: storage.log (99.15 KB, text/plain)
2012-10-03 07:57 EDT, Kamil Páral
no flags Details
File: version (11 bytes, text/plain)
2012-10-03 07:57 EDT, Kamil Páral
no flags Details
File: environ (797 bytes, text/plain)
2012-10-03 07:57 EDT, Kamil Páral
no flags Details
File: anaconda.log (18.01 KB, text/plain)
2012-10-03 07:57 EDT, Kamil Páral
no flags Details
File: syslog (93.47 KB, text/plain)
2012-10-03 07:57 EDT, Kamil Páral
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-03 07:57 EDT, Kamil Páral
no flags Details
File: packaging.log (2.74 KB, text/plain)
2012-10-03 07:57 EDT, Kamil Páral
no flags Details
File: cmdline_file (174 bytes, text/plain)
2012-10-03 07:57 EDT, Kamil Páral
no flags Details
File: release (24 bytes, text/plain)
2012-10-03 07:57 EDT, Kamil Páral
no flags Details
File: program.log (31.82 KB, text/plain)
2012-10-03 07:57 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-10-03 07:56:51 EDT
Description of problem:
I entered custom partitioning, selected root partition and changed the type to LVM. After that it immediately crashed.

Version-Release number of selected component:
anaconda-18.11

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-1.fc18.i686

description:
:The following was filed automatically by anaconda:
:anaconda 18.11 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 3252, in device_size
:    return get_pv_space(self.size, len(self.disks), **size_func_kwargs)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1850, in setContainerMembers
:    device_space = factory.device_size
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2036, in newDevice
:    members=members)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 774, in _replace_device
:    self.__storage.newDevice(*args, **kwargs)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 888, in _save_right_side
:    selector=selector)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1534, in on_selector_clicked
:    self._save_right_side(self._current_selector)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 188, in _onSelectorClicked
:    cb(selector)
:NameError: global name 'size_func_kwargs' is not defined
Comment 1 Kamil Páral 2012-10-03 07:56:55 EDT
Created attachment 620779 [details]
File: anaconda-tb
Comment 2 Kamil Páral 2012-10-03 07:56:58 EDT
Created attachment 620780 [details]
File: product
Comment 3 Kamil Páral 2012-10-03 07:57:01 EDT
Created attachment 620781 [details]
File: type
Comment 4 Kamil Páral 2012-10-03 07:57:04 EDT
Created attachment 620782 [details]
File: storage.log
Comment 5 Kamil Páral 2012-10-03 07:57:07 EDT
Created attachment 620783 [details]
File: version
Comment 6 Kamil Páral 2012-10-03 07:57:09 EDT
Created attachment 620784 [details]
File: environ
Comment 7 Kamil Páral 2012-10-03 07:57:12 EDT
Created attachment 620785 [details]
File: anaconda.log
Comment 8 Kamil Páral 2012-10-03 07:57:15 EDT
Created attachment 620786 [details]
File: syslog
Comment 9 Kamil Páral 2012-10-03 07:57:17 EDT
Created attachment 620787 [details]
File: hashmarkername
Comment 10 Kamil Páral 2012-10-03 07:57:19 EDT
Created attachment 620788 [details]
File: packaging.log
Comment 11 Kamil Páral 2012-10-03 07:57:21 EDT
Created attachment 620789 [details]
File: cmdline_file
Comment 12 Kamil Páral 2012-10-03 07:57:24 EDT
Created attachment 620790 [details]
File: release
Comment 13 Kamil Páral 2012-10-03 07:57:26 EDT
Created attachment 620791 [details]
File: program.log
Comment 14 Kamil Páral 2012-10-03 07:59:02 EDT
So I am not sure whether this breaks Beta criterion
> >  The installer's custom partitioning mode must be capable of the following:
> >     Creating, destroying and assigning mount points to partitions of any specified size using most commonly-used filesystem types
> >     Creating encrypted partitions
> >     Rejecting obviously invalid operations without crashing 

Let's discuss.
Comment 15 Chris Lumens 2012-10-03 10:20:07 EDT

*** This bug has been marked as a duplicate of bug 862006 ***

Note You need to log in before you can comment on or make changes to this bug.