Bug 862006 - NameError: global name 'size_func_kwargs' is not defined
NameError: global name 'size_func_kwargs' is not defined
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:2b17cba3a04847ee0016150a5de...
:
: 862632 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-10-01 11:07 EDT by Clyde E. Kunkel
Modified: 2012-10-15 10:29 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-18.14-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 10:29:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: ifcfg.log (641 bytes, text/plain)
2012-10-01 11:07 EDT, Clyde E. Kunkel
no flags Details
File: anaconda-tb (596.44 KB, text/plain)
2012-10-01 11:07 EDT, Clyde E. Kunkel
no flags Details
File: environ (882 bytes, text/plain)
2012-10-01 11:07 EDT, Clyde E. Kunkel
no flags Details
File: type (9 bytes, text/plain)
2012-10-01 11:07 EDT, Clyde E. Kunkel
no flags Details
File: storage.log (249.93 KB, text/plain)
2012-10-01 11:07 EDT, Clyde E. Kunkel
no flags Details
File: version (2 bytes, text/plain)
2012-10-01 11:07 EDT, Clyde E. Kunkel
no flags Details
File: program.log (113.06 KB, text/plain)
2012-10-01 11:07 EDT, Clyde E. Kunkel
no flags Details
File: product (6 bytes, text/plain)
2012-10-01 11:07 EDT, Clyde E. Kunkel
no flags Details
File: anaconda.log (12.27 KB, text/plain)
2012-10-01 11:07 EDT, Clyde E. Kunkel
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-01 11:08 EDT, Clyde E. Kunkel
no flags Details
File: cmdline_file (162 bytes, text/plain)
2012-10-01 11:08 EDT, Clyde E. Kunkel
no flags Details
File: release (33 bytes, text/plain)
2012-10-01 11:08 EDT, Clyde E. Kunkel
no flags Details
File: messages (182.53 KB, text/plain)
2012-10-01 11:08 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2012-10-01 11:07:39 EDT
Version-Release number of selected component:
anaconda-18.8-2.fc18.x86_64

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.0-0.rc6.git0.2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.8 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 3241, in device_size
:    return get_pv_space(self.size, len(self.disks), **size_func_kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1839, in setContainerMembers
:    device_space = factory.device_size
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2025, in newDevice
:    members=members)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 647, in _replace_device
:    self.__storage.newDevice(*args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 748, in _save_right_side
:    selector=selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1123, in on_add_clicked
:    self._save_right_side(self._current_selector)
:NameError: global name 'size_func_kwargs' is not defined
Comment 1 Clyde E. Kunkel 2012-10-01 11:07:43 EDT
Created attachment 619829 [details]
File: ifcfg.log
Comment 2 Clyde E. Kunkel 2012-10-01 11:07:45 EDT
Created attachment 619830 [details]
File: anaconda-tb
Comment 3 Clyde E. Kunkel 2012-10-01 11:07:47 EDT
Created attachment 619831 [details]
File: environ
Comment 4 Clyde E. Kunkel 2012-10-01 11:07:49 EDT
Created attachment 619832 [details]
File: type
Comment 5 Clyde E. Kunkel 2012-10-01 11:07:51 EDT
Created attachment 619833 [details]
File: storage.log
Comment 6 Clyde E. Kunkel 2012-10-01 11:07:53 EDT
Created attachment 619834 [details]
File: version
Comment 7 Clyde E. Kunkel 2012-10-01 11:07:55 EDT
Created attachment 619835 [details]
File: program.log
Comment 8 Clyde E. Kunkel 2012-10-01 11:07:56 EDT
Created attachment 619836 [details]
File: product
Comment 9 Clyde E. Kunkel 2012-10-01 11:07:58 EDT
Created attachment 619837 [details]
File: anaconda.log
Comment 10 Clyde E. Kunkel 2012-10-01 11:08:00 EDT
Created attachment 619838 [details]
File: hashmarkername
Comment 11 Clyde E. Kunkel 2012-10-01 11:08:02 EDT
Created attachment 619839 [details]
File: cmdline_file
Comment 12 Clyde E. Kunkel 2012-10-01 11:08:03 EDT
Created attachment 619840 [details]
File: release
Comment 13 Clyde E. Kunkel 2012-10-01 11:08:05 EDT
Created attachment 619841 [details]
File: messages
Comment 14 Chris Lumens 2012-10-03 10:20:07 EDT
*** Bug 862632 has been marked as a duplicate of this bug. ***
Comment 15 Kamil Páral 2012-10-03 11:10:42 EDT
(In reply to comment #14)
> *** Bug 862632 has been marked as a duplicate of this bug. ***

Please transfer Blocks field, thanks.
Comment 16 Adam Williamson 2012-10-03 15:14:38 EDT
Discussed at 2012-10-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-03/f18-beta-blocker-review-2.2012-10-03-16.00.log.txt . 

Per the dupe, the cause here seems to be simply 'try and set up an LVM configuration through custom part'. On that basis we agreed this is clearly at least a Final blocker, per criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above" (though we cannot formally mark the bug as such as it would create confusion about the Beta blocker status). 

The status for Beta is less clear: during the discussions about what the criteria for Beta should be we have not yet clearly established whether we expect LVM to work at Beta or not. The current relevant criterion reads:

"The installer's custom partitioning mode must be capable of the following: Creating, destroying and assigning mount points to partitions of any specified size using most commonly-used filesystem types"

which leaves the question as 'is LVM a commonly-used filesystem type'. We agreed to delay decision on whether this is a blocker while we consider that with input from test@ and the anaconda team. The decision on this bug will set a broad precedent as to whether LVM is considered to block Beta or not, so we need to consider it carefully.
Comment 17 Alex Lancaster 2012-10-08 00:57:52 EDT
Switching an ext4 partition type from "standard" to LVM

Package: anaconda-18.12
OS Release: Fedora release 18-Beta-TC2
Comment 18 Reartes Guillermo 2012-10-08 11:23:38 EDT
I got this doing the opposite, most likely a duplicate.(Bug 864113)
Comment 19 Adam Williamson 2012-10-10 12:51:05 EDT
Discussed at 2012-10-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-10/f18beta-blocker-review-3.2012-10-10-16.05.log.txt . Unfortunately we didn't manage to discuss the status of LVM last week, so evaluation of this bug is delayed again. We will try and make sure it gets done this week.
Comment 20 Adam Williamson 2012-10-10 13:19:41 EDT
Belay that!

Discussed further at 2012-10-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-10/f18beta-blocker-review-3.2012-10-10-16.05.log.txt . We continued bashing away at this and eventually decided that anaconda should be capable of creating partitions/filesystems/devices/whatever you want to call them of all the types it actually offers (through the GUI) at Beta stage. If some partition types are 'unsupported', they shouldn't be offered (the same way we hid btrfs in the last few oldUI releases) or should be hidden behind kernel parameters (as we did with btrfs before it was 'stable'). We will work up precise wording on the mailing list. But with that general principle accepted, this bug is accepted as a blocker, as LVM is on the list of offered Device Types.
Comment 21 Adam Williamson 2012-10-10 13:29:03 EDT
Marking as ON_QA and fixed in 18.14 - this is actually fixed in 18.14 (TC3), anaconda team just forgot to update the bug and include it in the update description. This seems to be working for me in TC3, I was able to create an LV using custom part, but it'd be good if one of the original reporters can confirm before we set this to VERIFIED.
Comment 22 Kamil Páral 2012-10-15 10:29:12 EDT
This is now fixed with F18 Beta TC4. I can set partition type to LVM and continue with the installation and it doesn't crash. Closing.

Note You need to log in before you can comment on or make changes to this bug.