Bug 862784 - newUI custom partitioning does not allow formatting of an existing partition for use in the installed system
newUI custom partitioning does not allow formatting of an existing partition ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:13a1244d714f08ae019f5ae3a53...
:
: 866204 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 10:21 EDT by David Jaša
Modified: 2012-11-22 21:44 EST (History)
10 users (show)

See Also:
Fixed In Version: anaconda-18.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:44:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (221.38 KB, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details
File: product (6 bytes, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details
File: type (9 bytes, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details
File: storage.log (69.16 KB, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details
File: version (11 bytes, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details
File: environ (819 bytes, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details
File: anaconda.log (4.94 KB, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details
File: syslog (65.95 KB, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details
File: packaging.log (3.90 KB, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details
File: cmdline_file (97 bytes, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details
File: release (24 bytes, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details
File: program.log (27.78 KB, text/plain)
2012-10-03 10:21 EDT, David Jaša
no flags Details

  None (edit)
Description David Jaša 2012-10-03 10:21:09 EDT
Description of problem:
1. I've downloaded anaconda's vmlinuz and initrd.img
2. I've used the images for direct kernel boot of a VM, with boot=http://mirror.example.org/pub/fedora/fedora-alt/stage/18-Beta-TC1/Fedora/x86_64/os parameter -- the URI contains just anaconda, not yum repo
3. I've set up Time Zone and Partitioning; source was pre-selected to the closest mirror
4. anaconda threw and exception shortly after I hit "Continue" button


Version-Release number of selected component:
anaconda-18.11

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.11 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/rpmUtils/transaction.py", line 58, in dbMatch
:    mi = self.ts.dbMatch(*args, **kwds)
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1212, in _get_packages
:    mi = ts.dbMatch(*args, **kwds)
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 628, in returnPackages
:    for hdr, idx in self._get_packages():
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1133, in simpleVersion
:    for pkg in sorted(self.returnPackages()):
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 977, in preloadPackageChecksums
:    rpmdbv = self.simpleVersion(main_only=True)[0]
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 264, in _get_pkglist
:    csumpkgtups = self.preloadPackageChecksums(load_packages=False)
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 507, in simplePkgList
:    return self.pkglist
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 948, in _getGroups
:    self._comps.compile(self.rpmdb.simplePkgList())
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1032, in <lambda>
:    comps = property(fget=lambda self: self._getGroups(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3527, in selectGroup
:    if not self.comps.has_group(grpid):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 922, in _selectYumGroup
:    self._yum.selectGroup(groupid, group_package_types=pkg_types)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1029, in _applyYumSelections
:    self._selectYumGroup("core")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1074, in checkSoftwareSelection
:    self._applyYumSelections()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1143, in preInstall
:    self.checkSoftwareSelection()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 111, in doInstall
:    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 87, in run
:    threading.Thread.run(self, *args, **kwargs)
:error: rpmdb open failed
Comment 1 David Jaša 2012-10-03 10:21:15 EDT
Created attachment 620936 [details]
File: anaconda-tb
Comment 2 David Jaša 2012-10-03 10:21:17 EDT
Created attachment 620937 [details]
File: product
Comment 3 David Jaša 2012-10-03 10:21:19 EDT
Created attachment 620938 [details]
File: type
Comment 4 David Jaša 2012-10-03 10:21:22 EDT
Created attachment 620939 [details]
File: storage.log
Comment 5 David Jaša 2012-10-03 10:21:25 EDT
Created attachment 620940 [details]
File: version
Comment 6 David Jaša 2012-10-03 10:21:28 EDT
Created attachment 620941 [details]
File: environ
Comment 7 David Jaša 2012-10-03 10:21:33 EDT
Created attachment 620942 [details]
File: anaconda.log
Comment 8 David Jaša 2012-10-03 10:21:36 EDT
Created attachment 620943 [details]
File: syslog
Comment 9 David Jaša 2012-10-03 10:21:38 EDT
Created attachment 620944 [details]
File: hashmarkername
Comment 10 David Jaša 2012-10-03 10:21:40 EDT
Created attachment 620945 [details]
File: packaging.log
Comment 11 David Jaša 2012-10-03 10:21:44 EDT
Created attachment 620946 [details]
File: cmdline_file
Comment 12 David Jaša 2012-10-03 10:21:47 EDT
Created attachment 620947 [details]
File: release
Comment 13 David Jaša 2012-10-03 10:21:51 EDT
Created attachment 620948 [details]
File: program.log
Comment 14 David Jaša 2012-10-03 10:51:25 EDT
After a few tries, it seems that the bug is related to partitioning so the reproducer is like this:

1. pre-create GPT partition table
2. pre-create three partitions: BIOS Boot, swap and /
3. boot anaconda, select that you want to review & modify partitioning
4. in the root partition details, type "/" into Mountpoint input
5. finish partitioning
6. start installation

The bug may be also connected to the lack of information about partition format status.
Comment 15 Adam Williamson 2012-10-03 15:00:33 EDT
Discussed at 2012-10-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-03/f18-beta-blocker-review-2.2012-10-03-16.00.log.txt .

We agreed that as the new partitioning criteria are written this constitutes a blocker, but in fact that is an unintended consequence, my fault for bad wording. We did not really intend the Beta criteria to cover re-use of existing partitions, only creation of new ones within anaconda.

We agreed to postpone evaluation of this bug while I rework the criteria and we consider whether we do want to cover re-use of existing partitions, and if so, to what extent.
Comment 16 Adam Williamson 2012-10-10 13:44:47 EDT
Discussed at 2012-10-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-10/f18beta-blocker-review-3.2012-10-10-16.05.log.txt . Unfortunately we didn't yet get around to re-considering this, so evaluation is delayed again till the next meeting.
Comment 17 Chris Lumens 2012-10-15 10:46:19 EDT
*** Bug 866204 has been marked as a duplicate of this bug. ***
Comment 18 Paul W. Frields 2012-10-15 12:31:54 EDT
Installation of default "GNOME Desktop" package set, onto an existing F17 x86_64 system with LVM partition setup.

Package: anaconda-18.14
OS Release: Fedora release 18
Comment 19 Adam Williamson 2012-10-17 12:31:19 EDT
Adjusting the summary to be clearer. Essentially this bug is that you can't use an existing partition as a mount point in the installed system and format it. You can give a mount point to an existing partition, but it will not be formatted. This obviously works for /home, but not for /.

Workarounds are to format the partition with another tool before starting installation, or to delete the partition and create a new one with similar attributes once inside the installer.
Comment 20 Adam Williamson 2012-10-17 12:39:13 EDT
Discussed at 2012-10-17 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-17/f18beta-blocker-review-4.2012-10-17-16.00.log.txt . We agreed that the Beta partitioning requirements are still not clear and there was not a clear consensus on whether this bug should be a blocker, so determination of its status was delayed again.
Comment 21 David Lehman 2012-10-17 12:55:01 EDT
The simplest way to use an existing device as the root device is to change the filesystem type. It's not the final solution, but that's the simplest way to get it done now.
Comment 22 David Lehman 2012-10-24 11:45:19 EDT
A "Reformat" checkbutton was added to anaconda-18.20-1.
Comment 23 Adam Williamson 2012-10-24 13:03:29 EDT
Discussed again at the 2012-10-24 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-24/f18beta-blocker-review-5.2012-10-24-16.01.log.txt . We still haven't solidified the revision of the partitioning criteria for Beta, but there was solid agreement that whatever they wind up looking like, they shouldn't cover partition re-use beyond the common case of re-using /home without formatting it; anything beyond that is kind of out of scope for a Beta and there are many ways to work around this bug. So it was rejected as a Beta blocker.
Comment 24 Adam Williamson 2012-11-22 21:44:41 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(well known to be fixed in current builds.)

Note You need to log in before you can comment on or make changes to this bug.