Bug 866204 - error: rpmdb open failed
error: rpmdb open failed
Status: CLOSED DUPLICATE of bug 862784
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:edb30f20ffa33074d3d6f0220a9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 12:33 EDT by Keith Bare
Modified: 2012-10-15 10:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 10:46:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: release (24 bytes, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: anaconda.log (12.44 KB, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: type (9 bytes, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: storage.log (127.29 KB, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: version (11 bytes, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: environ (764 bytes, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: product (6 bytes, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: syslog (101.72 KB, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: install.log (52.25 KB, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: packaging.log (3.22 KB, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: cmdline_file (110 bytes, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: anaconda-tb (411.70 KB, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details
File: program.log (56.81 KB, text/plain)
2012-10-14 12:33 EDT, Keith Bare
no flags Details

  None (edit)
Description Keith Bare 2012-10-14 12:33:10 EDT
Description of problem:
I attempted to install F18-TC4 in place of an old F15 installation.  In the custom partitioing screen I selected the preexisting /boot and / partitions and entered those same mount points and hit apply changes.  The F18 tree then showed those partitions inside.  I hit done.  No other changes were made to installer defaults.  Proceeded to the next step.  Screen prompts for a root password, but an error windows pops up not more than 5 seconds into the installation process.

Version-Release number of selected component:
anaconda-18.16

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.16 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/rpmUtils/transaction.py", line 58, in dbMatch
:    mi = self.ts.dbMatch(*args, **kwds)
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1212, in _get_packages
:    mi = ts.dbMatch(*args, **kwds)
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1258, in _search
:    for hdr, idx in mi:
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1193, in searchNames
:    returnList.extend(self._search(name=name))
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 4480, in install
:    ipkgs = self.rpmdb.searchNames([po.name])
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3597, in selectGroup
:    pkg_warning_level='debug2')
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 946, in _selectYumGroup
:    self._yum.selectGroup(groupid, group_package_types=pkg_types)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1053, in _applyYumSelections
:    self._selectYumGroup("core")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1097, in checkSoftwareSelection
:    self._applyYumSelections()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1176, in preInstall
:    self.checkSoftwareSelection()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 111, in doInstall
:    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:error: rpmdb open failed
Comment 1 Keith Bare 2012-10-14 12:33:13 EDT
Created attachment 627017 [details]
File: release
Comment 2 Keith Bare 2012-10-14 12:33:15 EDT
Created attachment 627018 [details]
File: anaconda.log
Comment 3 Keith Bare 2012-10-14 12:33:16 EDT
Created attachment 627019 [details]
File: type
Comment 4 Keith Bare 2012-10-14 12:33:18 EDT
Created attachment 627020 [details]
File: ifcfg.log
Comment 5 Keith Bare 2012-10-14 12:33:20 EDT
Created attachment 627021 [details]
File: storage.log
Comment 6 Keith Bare 2012-10-14 12:33:21 EDT
Created attachment 627022 [details]
File: version
Comment 7 Keith Bare 2012-10-14 12:33:23 EDT
Created attachment 627023 [details]
File: environ
Comment 8 Keith Bare 2012-10-14 12:33:25 EDT
Created attachment 627024 [details]
File: product
Comment 9 Keith Bare 2012-10-14 12:33:28 EDT
Created attachment 627025 [details]
File: syslog
Comment 10 Keith Bare 2012-10-14 12:33:30 EDT
Created attachment 627026 [details]
File: install.log
Comment 11 Keith Bare 2012-10-14 12:33:32 EDT
Created attachment 627027 [details]
File: hashmarkername
Comment 12 Keith Bare 2012-10-14 12:33:34 EDT
Created attachment 627028 [details]
File: packaging.log
Comment 13 Keith Bare 2012-10-14 12:33:36 EDT
Created attachment 627029 [details]
File: cmdline_file
Comment 14 Keith Bare 2012-10-14 12:33:38 EDT
Created attachment 627030 [details]
File: anaconda-tb
Comment 15 Keith Bare 2012-10-14 12:33:40 EDT
Created attachment 627031 [details]
File: program.log
Comment 16 Steve Tyler 2012-10-14 13:47:37 EDT
I'm not sure if this matters, but your hardware clock seems to be way off:

From attached syslog:
16:23:14,042 WARNING chronyd: System clock wrong by 186949800.262671 seconds, adjustment started

Also, sda6 had some filesystem errors:
16:23:18,658 WARNING kernel:[   62.667813] EXT4-fs warning (device sda6): ext4_clear_journal_err:4419: Filesystem error recorded from previous mount: IO failure
Comment 17 Steve Tyler 2012-10-14 15:08:46 EDT
(In reply to comment #16)
...
> Also, sda6 had some filesystem errors:
> 16:23:18,658 WARNING kernel:[   62.667813] EXT4-fs warning (device sda6):
> ext4_clear_journal_err:4419: Filesystem error recorded from previous mount:
> IO failure

That looks like: Bug 839891 - e2fsck leaves ext4 journal unfixed
Bug 839891, Comment 19 says it was fixed in kernel-3.5.3-1.fc17.x86_64, so presumably it is fixed in 3.6.1-1.fc18.x86_64 ...
Comment 18 Chris Lumens 2012-10-15 10:46:19 EDT

*** This bug has been marked as a duplicate of bug 862784 ***

Note You need to log in before you can comment on or make changes to this bug.