Bug 862802 - Locked templates are not selectable when creating a new VM
Locked templates are not selectable when creating a new VM
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
unspecified
All All
unspecified Severity unspecified
: ---
: 3.3.4
Assigned To: Einav Cohen
virt
:
: 874451 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 11:12 EDT by Adam Litke
Modified: 2016-01-28 16:55 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 10:23:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Litke 2012-10-03 11:12:10 EDT
Description of problem:
Templates that are locked (because another VM of the same type is being created), do not appear in the list of available templates when creating additional VMs.


Version-Release number of selected component (if applicable): 
3bcdb751d14f9826345f372e2e412c3d610d0a3c


How reproducible: Always


Steps to Reproduce:
1. Create a VM from a template
2. Immediately attempt to create another VM from same template
  
Actual results:
Template is not available in the 'Based on template' list box.

Expected results:
Template should be selectable (even if that means the vm create process would be delayed.


Additional info:
Comment 1 Ayal Baron 2012-10-03 17:06:02 EDT
I believe this is intentional (and not the delayed behaviour) due to engine's current lack of ability to differentiate between the reasons the template is locked.
This means that it could be locked because it is being deleted so the suggestion above (waiting) would not work with current design.
The alternatives are:
1. have a list there and grey out with a tool tip
2. differentiate between reasons for lock, allow multiple concurrent creations, filter out when irrelevant (deleting) and we would still need to determine proper behaviour for other types of operations which are incompatible with creation (but if we wait then possibly we could succeed).
Comment 2 Adam Litke 2012-10-03 17:18:57 EDT
Thanks for your reply Ayal...

Hmm.  I guess I am a bit confused why a template must even be locked for creations to happen.  I think of this as roughly equivalent to 'qemu-img create -b <template> <new-im>'.  In that case, the base image doesn't even need to be touched.  Obviously there is a lot more going on underneath the covers.

Don't Volumes that are being deleted get a assigned a Volume Legality of ILLEGAL?  Could that be used to filter locked templates?  Does the HSM storage locking protect against multiple simultaneous creations?  Would the 'clone' operation just block until the previous one is finished?
Comment 3 Ayal Baron 2012-11-08 04:39:52 EST
*** Bug 874451 has been marked as a duplicate of this bug. ***
Comment 4 Michal Skrivanek 2013-07-31 10:23:05 EDT
Arik fixed the locking in 3.3 so you should not see that anymore.

Note You need to log in before you can comment on or make changes to this bug.