This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 862830 - [abrt] evolution-data-server-3.5.92-1.fc18: initialize_backend: Process /usr/libexec/evolution-calendar-factory was killed by signal 6 (SIGABRT)
[abrt] evolution-data-server-3.5.92-1.fc18: initialize_backend: Process /usr/...
Status: CLOSED DUPLICATE of bug 872652
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:7fb415992ff9e654630db5b1e18...
:
: 964405 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 13:05 EDT by Martin Meyer
Modified: 2014-05-02 12:04 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 03:04:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.69 KB, text/plain)
2012-10-03 13:05 EDT, Martin Meyer
no flags Details
File: environ (1.05 KB, text/plain)
2012-10-03 13:05 EDT, Martin Meyer
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-03 13:05 EDT, Martin Meyer
no flags Details
File: backtrace (36.72 KB, text/plain)
2012-10-03 13:05 EDT, Martin Meyer
no flags Details
File: cgroup (129 bytes, text/plain)
2012-10-03 13:05 EDT, Martin Meyer
no flags Details
File: maps (56.87 KB, text/plain)
2012-10-03 13:05 EDT, Martin Meyer
no flags Details
File: dso_list (11.68 KB, text/plain)
2012-10-03 13:05 EDT, Martin Meyer
no flags Details
File: open_fds (571 bytes, text/plain)
2012-10-03 13:05 EDT, Martin Meyer
no flags Details
File: var_log_messages (170 bytes, text/plain)
2012-10-03 13:05 EDT, Martin Meyer
no flags Details
evolution-calendar-factory was killed "error" after this update (21.15 KB, text/x-log)
2013-09-14 14:25 EDT, ILMostro
no flags Details

  None (edit)
Description Martin Meyer 2012-10-03 13:05:14 EDT
Version-Release number of selected component:
evolution-data-server-3.5.92-1.fc18

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory
crash_function: initialize_backend
kernel:         3.6.0-1.fc18.x86_64

truncated backtrace:
:Thread no. 1 (5 frames)
: #6 initialize_backend at e-cal-backend-caldav.c:2652
: #7 caldav_do_open at e-cal-backend-caldav.c:2754
: #8 cal_backend_open at e-cal-backend-sync.c:578
: #9 operation_thread at e-data-cal.c:183
: #11 g_thread_proxy at gthread.c:797
Comment 1 Martin Meyer 2012-10-03 13:05:17 EDT
Created attachment 621022 [details]
File: core_backtrace
Comment 2 Martin Meyer 2012-10-03 13:05:20 EDT
Created attachment 621023 [details]
File: environ
Comment 3 Martin Meyer 2012-10-03 13:05:22 EDT
Created attachment 621024 [details]
File: limits
Comment 4 Martin Meyer 2012-10-03 13:05:24 EDT
Created attachment 621025 [details]
File: backtrace
Comment 5 Martin Meyer 2012-10-03 13:05:26 EDT
Created attachment 621026 [details]
File: cgroup
Comment 6 Martin Meyer 2012-10-03 13:05:29 EDT
Created attachment 621027 [details]
File: maps
Comment 7 Martin Meyer 2012-10-03 13:05:31 EDT
Created attachment 621028 [details]
File: dso_list
Comment 8 Martin Meyer 2012-10-03 13:05:32 EDT
Created attachment 621029 [details]
File: open_fds
Comment 9 Martin Meyer 2012-10-03 13:05:35 EDT
Created attachment 621030 [details]
File: var_log_messages
Comment 10 Milan Crha 2012-10-16 11:08:20 EDT
Thanks for a bug report. I do not see from the backtrace why this crashed, it only shows that there was a memory corruption when opening a CalDAV calendar. Do you recall what you did, like just added a new CalDAV calendar, or was otherwise changing the calendar view or anything like that?
Comment 11 flebber 2012-12-11 05:43:13 EST
Rebooted after update

backtrace_rating: 4
Package: evolution-data-server-3.6.2-2.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 12 Pavel Ondračka 2013-02-21 03:53:09 EST
1. start evolution
2. crash notification shows up


backtrace_rating: 4
Package: evolution-data-server-3.6.3-2.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 13 Milan Crha 2013-05-30 02:59:26 EDT
*** Bug 964405 has been marked as a duplicate of this bug. ***
Comment 14 Herbert Carl Meyer 2013-05-30 20:42:28 EDT
Newly installed F19 beta

reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory
crash_function: initialize_backend
executable:     /usr/libexec/evolution-calendar-factory
kernel:         3.9.4-300.fc19.x86_64
package:        evolution-data-server-3.8.2-1.fc19
reason:         Process /usr/libexec/evolution-calendar-factory was killed by signal 6 (SIGABRT)
runlevel:       N 5
uid:            1000
Comment 15 David Woodhouse 2013-08-15 11:45:19 EDT
I just saw this after starting 3.8.5 for the first time. I haven't touched the configuration of my CalDAV (Google) calendars for a long time.
Comment 16 Mat Booth 2013-08-16 04:36:32 EDT
Have one personal Google account and one work GoogleApps account configured as gnome online accounts. This crash happens at start up, just after I log in.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory
crash_function: initialize_backend
executable:     /usr/libexec/evolution-calendar-factory
kernel:         3.10.5-201.fc19.x86_64
package:        evolution-data-server-3.8.4-1.fc19
reason:         Process /usr/libexec/evolution-calendar-factory was killed by signal 6 (SIGABRT)
runlevel:       N 5
uid:            1000
Comment 17 markus.comperini 2013-08-29 16:44:39 EDT
I dom't know, why this package crashed, because I switched the pc on, but I wasn't logged in. After the login I see the warning, that this package crashed.
Thank you!

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory
crash_function: initialize_backend
executable:     /usr/libexec/evolution-calendar-factory
kernel:         3.10.9-200.fc19.x86_64
package:        evolution-data-server-3.8.5-4.fc19
reason:         Process /usr/libexec/evolution-calendar-factory was killed by signal 11 (SIGSEGV)
reported_to:    uReport: BTHASH=fd1b76661c17f79bf047e4a6a5b97f81e05b9cfd
runlevel:       N 5
uid:            1000
Comment 18 javier del cristo 2013-09-05 23:30:26 EDT
I Unknow what happend the occur when I was to intented to update of Os.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory
crash_function: initialize_backend
executable:     /usr/libexec/evolution-calendar-factory
kernel:         3.10.10-200.fc19.x86_64
package:        evolution-data-server-3.8.5-4.fc19
reason:         Process /usr/libexec/evolution-calendar-factory was killed by signal 6 (SIGABRT)
reported_to:    uReport: BTHASH=446968fae00f140927f4e606b706eac21ab5e402
runlevel:       N 5
uid:            1000
Comment 19 ILMostro 2013-09-14 14:25:03 EDT
Created attachment 797681 [details]
evolution-calendar-factory was killed "error" after this update

So...are there any updates regarding this bug? Any progress on resolving this issue? I just received the same error after doing an update. Here's the history log of that update:
Comment 20 Milan Crha 2013-09-16 03:04:23 EDT
Unfortunately no progress and no update, I get the crash occasionally too, but whenever I try to debug the cause of the crash the factory doesn't crash. A simple code read doesn't show anything obvious, just the opposite, the code seems to do things right.

This has been moved upstream within bug #872652, thus I mark this as a duplicate of it. Any further investigation might be done upstream.

*** This bug has been marked as a duplicate of bug 872652 ***

Note You need to log in before you can comment on or make changes to this bug.