Bug 862852 - Subscription Redemption Dialog Remove One of the Two Separators
Subscription Redemption Dialog Remove One of the Two Separators
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: John Sefler
Entitlement Bugs
:
Depends On:
Blocks: 771481 840993 888457
  Show dependency treegraph
 
Reported: 2012-10-03 14:40 EDT by Matt Reid
Modified: 2013-02-21 03:56 EST (History)
6 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.12-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:56:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Double Separator (16.03 KB, image/png)
2012-10-03 14:41 EDT, Matt Reid
no flags Details
Not Fixed (14.12 KB, image/png)
2012-11-28 11:53 EST, J.C. Molet
no flags Details
single separator is now used in Subscription Redemption dialog (60.84 KB, image/png)
2012-12-12 12:31 EST, John Sefler
no flags Details

  None (edit)
Description Matt Reid 2012-10-03 14:40:35 EDT
Description of problem:
On our Subscription Redemption dialog, we use a double separator between the content of the dialog and the buttons at the bottom. This is the only place I've seen us use 2, we should only have 1 in that spot. With 1 separator it will match our other dialogs, like prefs, facts, sys reg, etc. 

Version-Release number of selected component (if applicable):
subscription-manager-1.1.2-1.git.28.85c7626
Comment 1 Matt Reid 2012-10-03 14:41:45 EDT
Created attachment 621068 [details]
Double Separator
Comment 2 Bryan Kearney 2012-10-29 15:56:11 EDT
Fixed in bug 805024 in commit 975d2b458f6ba8baa81e8e9dc50aa0808b67d762
Comment 4 J.C. Molet 2012-11-28 11:53:29 EST
Created attachment 653615 [details]
Not Fixed

As of version subscription-manager-gui-1.1.10-1.el6.x86_64 (latest release candidate) the fix for this has NOT made it to the rhel6.4 build. Throwing back.
Comment 5 Devan Goodwin 2012-12-05 11:54:13 EST
Commit above does not appear to fix the issue.

Issue will not appear if you run on Fedora 17, but will appear on RHEL 6. (exact same code)

I believe this is because the glade file specifies both a GtkHSeparator and then a GtkHButtonBox, and in older versions of GTK the box includes a separator, but does not in newer.
Comment 6 Devan Goodwin 2012-12-10 08:49:18 EST
Fixed in subscription-manager.git master: 0d5abc93aa276fa20ce1b46b2b84ed4b1ef215b6

alikins will bring into 6.4 stable branch.
Comment 9 John Sefler 2012-12-12 12:31:49 EST
Created attachment 662541 [details]
single separator is now used in Subscription Redemption dialog

Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.1.14-1.el6.x86_64
Comment 11 errata-xmlrpc 2013-02-21 03:56:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.